Previous 1 2 3 4 Next 52 Replies Latest reply: Oct 23, 2012 7:51 PM by weekstyler
Janvier Smith Level 1 Level 1
The first document I tried to print after updating the printer software failed to print - it shows up in the print queue, but it stops there. I have an HP Color LaserJet 2500L attached to the computer with a USB cable. I have tried a different cable, and I have tried printing from a different Mac -- same problem. I have re-downloaded the update, applied it, repaired permissions, and still it will not print. The printer will print fine when connected to a Windows XP PC. Is there any way I can get the old drivers (v 2.4.1?) and see if they work? Everything worked fine before this update.

Mac Pro Quad 3.0, Mac OS X (10.4.10)
  • baltwo Level 9 Level 9
    System Preferences->Print & Fax->select the printer and click the minus sign. CONTROL-click in the Printes window and reset the printing system, click the plus sign, and add the printer back in.
  • Janvier Smith Level 1 Level 1
    When I do this, the process hangs saying "Determining Installable Options, and then Status: Waiting for the printer to become available." I have checked the cable and used a spare one, with no luck. There appears to be some kind of communications problem.
  • baltwo Level 9 Level 9
    Then, power down the printer, remove the cable from both ends, reinsert it, power up the printer, and try again. If no go, then try a third cable.
  • -Byron- Level 1 Level 1
    I'm having the same problem, Janvier. I've done everything you've tried PLUS deleting the printprefs AND 'HP' folder from the 'Printers' folder in 'Library.' Anyone else having this problem? I can't find a way to revert back to the previous drivers without reinstalling the operating system.
  • JGolden1 Level 1 Level 1
    I have the same problem with one of my Mac's (and I tried the suggestions here) so I am not updating the other till it is resolved.
  • John Blanchard1 Level 5 Level 5
    Janvier, another thing to try, something that has worked with the Epson updates, is to delete the printer from the Print & Fax Prefs, delete the hp folder from /Library/Printers, empty the trash, and, most importantly, restart. Then try using Software Update to install the latest driver again. If that doesn't help, can you send me your System Profile please? Use Utilities/System Profiler and do Save. Hopefully the install logs will indicate what has happened. Thank you.

    <Edited by Host>
  • Janvier Smith Level 1 Level 1
    I tried the steps John suggested, but the problem remains. I e-mailed my system profile to him.
  • crabuback Level 1 Level 1
    I am having the same problem. Uninstalling, reinstalling the printer sometimes works for a few print jobs, but then fails. Restarting the computer works for a short time but then I get the same problem back.
  • Janvier Smith Level 1 Level 1
    I think we have a workaround, though the problem with 2.5.2 still persists. I followed the steps John recommended:
    - - - - -
    In Terminal, type the "ls -l /System/Library/Extensions" command, then delete all of the items whose name starts with "hp_" in that directory.

    cd System/Library/Extensions
    rm hp_

    The last command can be done for all the hp_ files, and you may have to use sudo if the machine says you need to be an administrator. If you're more comfortable in the Finder, you can just go to System/Library/Extensions and delete the hp_ files manually.

    Disconnect the printer, delete the printer if it's still there, reconnect the printer, and run Software Update to install the driver again.
    - - - - -
    I noticed that after I deleted the hp extensions, emptied the trash, disconnected and turned the printer off, turned it back on and reconnected it, and then rebooted the computer, that the printer showed up on the printer list without applying the 2.5.2 update. When I tried printing a document, it worked! Then I did the software update to install 2.5.2, and could no longer print! There is something definitely wrong with the 2.5.2 package. So I went through the whole process again, and as long as I do not install the 2.5.2 update, I can print just fine.

    I hope that between HP and Apple, there is a corrected software update so that we do not have to continually ignore this one. I hope others out there who are having this problem try these steps and post how they worked for you. Thanks to John Blanchard for heading us in the right direction!
  • James Stover Level 1 Level 1
    Since updating to the new HP Printer Software 2.5.2, my HP All-In-One Printer cannot be found as a wireless device. I tried removing the printer device and then adding the printer back with the IP address. It worked for a couple of print jobs and then couldn't find the printer again. I had no problems for over a year before this update.
    The printer will work fine if I plug in the USB cable, but it is not located in a place where I can use it plugged in with USB all the time.
  • WasatchGirl Level 1 Level 1
    Thank you Janvier and John. After hours of trying everything else, this finally worked and I am printing again!
  • RedActor Level 1 Level 1
    Yes!! I am having this same problem!

    waiting for printer to become available

    I tried rebooting my laptop and printer, moving the USB cord to different ports, using a different USB cord, Removed and reinstalled drivers... This seems to have happened after a software update on my Mac OS X Version 10.6.5 recently.

    Argh! I've considered using Time Machine to go back...will that do it?
  • Nelson Bazinet Level 1 Level 1
    Having the same problem here too (along with the people of this other thread:

    Reinstalling MacOS 10.6.4 and clearing the HP Drivers Update 2.5.2 seem to be a temporary solution for this problem...

    Transmitted a bug report to Apple Support AND HP Support.
  • Nelson Bazinet Level 1 Level 1
    Installed HP Driver Update 2.5.2, unable to print via wifi from a mac to another mac... Not installed MacOS 10.6.5. So the problem seems to be from the updated driver...
Previous 1 2 3 4 Next