Previous 1 2 3 4 Next 52 Replies Latest reply: Oct 23, 2012 7:51 PM by weekstyler Go to original post
  • SteveDemy Level 1 (0 points)
    Apple HP Printer Drivers 2.6 has solved this problem for me. The excellent workaround suggested by Janvier and John above, which I have been using since yesterday is no longer needed.
  • Piaggiagrande Level 1 (0 points)
    I have tried everything on this thread. Including the latest drivers from Apple. My HP printer is still invisible. I have spent a week trying to sort this out. Is the only solution to go back to OSX 10.4?
  • actionmarker Level 4 (1,555 points)
    After more testing and use, the issues with my HP2550L printer were not resolved as I previously posted in this thread.

    Hi All,

    It looks like my issue has been resolved now.

    Since my last post, I went through the whole process again and reinstalling the 2.5.2 update and initial tests look like my printing is OK.

    In summary I did the following;
    1. Trashed hp_ files from /System/Library/Extensions
    2. Turned off and disconnected Printer (HP Color Laserjet 2550L)
    3. Deleted printer from System Preferences/Print & Fax
    4. Reset Printing System (to do this, Control Click on the Printers field in the Print & Fax Window)
    5. Empty Trash
    6. Restarted Mac
    7. Connected and turned on Printer
    8. Applied 2.5.2 update. This update took 15 minutes to apply - is that normal?
    9. Restarted Mac
    10. Tested Printer and all appears OK

    Note: The hp_ files in /System/Library/Extensions never returned to my system after the 2.5.2 update.

    I have some serious printing to do in the upcoming weekend, so that will be the true test if the issue is resolved.

    Again thanks to all contributors especially John Blanchard and Janvier Smith for posting solutions to this issue.


    After getting very sick of the intermittent printing, restarting the printer after each print and sometimes nothing at all, I reinstalled 10.6 and upgraded to 10.6.6 using the Combo update and then also to 10.6.7.

    I have not done any updates to the HP printer software, it is as 'out of the box' and do not have any issues whats so ever.

    +HP color LaserJet 2550 series:+

    +Status: Idle+
    +Print Server: Local+
    +Driver Version: 10.4+
    +Default: Yes+
    +URI: usb://Hewlett-Packard/hp%20color%20LaserJet%202550%20series?serial=00CNHGC47898 +
    +PPD: HP Color LaserJet 2550 Series+
    +PPD File Version: 17.5+
    +PostScript Version: (3011.001) 1+
    +CUPS Version: 1.4.6 (cups-218.28)+
    +Fax support: No+
    +Scanning support: No+
    +Scanning app: -+
    +Scanning app (bundleID path): -+
    +Scanner UUID: -+

    The printer is working perfectly as it always did.
    This printer is only a colour laser printer, no scanners, faxes or anything else in it.
    So if you are still having issues, you could try this method for yourself.
    Luckily 10.6 is simple to reinstall, it does not loose any files, apps emails, just reinstalls the OS (of course backup first as a precaution).
    The whole process of reinstalling and updating using the combo took approx. 40 minutes, so it was well worth it for me as once again I can print reliably.

  • musicmanmu Level 1 (0 points)

    I have the same problem with my HP LaserJet 1320 printer and my iMac running 10.6.8. One day the printer was working fine, the next it just kept saying "waiting for printer to become avaliable."


    I downloaded the 2.6 version of the HP drivers, and tried to follow some of the previously offered suggestions, but nothing has worked.


    Any other help or suggestions for me? This is frustrating.

  • Gary Day1 Level 1 (0 points)

    Since the 10.6.8 update, both Macbook Pro's in my house now won't print to my HP 2550n over the network, connected via the Time Capsule. When connected directly via the USB to the Macbook or to the USB on the Time Capsule the printer works (although needs to be installed again). My kids laptops running window 7 both still work fine. The problem is that when i try to print, the printer goes into a paused mode, each time i try to un-pause it, the message "looking for printer" is displayed. VERY frustrating. I am trying some of the earlier suggestions to remove the HP drivers and re-install again.

  • Gary Day1 Level 1 (0 points)

    after hours of searching, i found a patch that Elektro80 posted :



    theres a 10.6.7 patch which backdates 4 files. tried it, works perfect. My HP 2550n now prints over he network again.




  • tdstout Level 1 (5 points)

    Excellent fix.  I had the same message with my HP Photosmart C3150 and struggled for days trying different fixes until I came across your suggestion.  Worked perfectly and now the printer is working normally again.  Thanks a lot!

  • weekstyler Level 1 (0 points)

    Here's the fix a friend gave me for the problem I was having of "waiting for printer..." all that would work was sending jobs to the que before the printer was plugged into the computer.  Now it works flawlessly:


    I had this issue too with my HP 2550. No more printing after the first printjob possible

    I managed to get the printer working as expected by removing the hp_io_enabler kext.

    sudo -s

    mkdir /Valhalla

    mv /System/Library/Extensions/hp_io_printerclassdriver_enabler.kext /Valhalla


    Wait for the systemcaches to be rebuilt and reboot. You can see if the caches are being rebuilt by opening the Activity Tool, the process is named kextcache.

    You need to have the Valhalla Folder in root of course.

    Not very mac-like, but it works"


    note the space between .kext and/Valhalla

Previous 1 2 3 4 Next