Skip navigation

Cannot print since HP Printer Software Update 2.5.2

38568 Views 52 Replies Latest reply: Oct 23, 2012 7:51 PM by weekstyler RSS
1 2 3 4 Previous Next
Janvier Smith Calculating status...
Currently Being Moderated
Nov 7, 2010 12:56 PM
The first document I tried to print after updating the printer software failed to print - it shows up in the print queue, but it stops there. I have an HP Color LaserJet 2500L attached to the computer with a USB cable. I have tried a different cable, and I have tried printing from a different Mac -- same problem. I have re-downloaded the update, applied it, repaired permissions, and still it will not print. The printer will print fine when connected to a Windows XP PC. Is there any way I can get the old drivers (v 2.4.1?) and see if they work? Everything worked fine before this update.
Mac Pro Quad 3.0, Mac OS X (10.4.10)
  • baltwo Level 9 Level 9 (59,145 points)
    System Preferences->Print & Fax->select the printer and click the minus sign. CONTROL-click in the Printes window and reset the printing system, click the plus sign, and add the printer back in.
    27" iMac i7 12 GB RAM, Mac OS X (10.6.4), G4 450 MP GB 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • baltwo Level 9 Level 9 (59,145 points)
    Then, power down the printer, remove the cable from both ends, reinsert it, power up the printer, and try again. If no go, then try a third cable.
    27" iMac i7 12 GB RAM, Mac OS X (10.6.4), G4 450 MP GB 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • -Byron- Calculating status...
    I'm having the same problem, Janvier. I've done everything you've tried PLUS deleting the printprefs AND 'HP' folder from the 'Printers' folder in 'Library.' Anyone else having this problem? I can't find a way to revert back to the previous drivers without reinstalling the operating system.
    iMac, Mac OS X (10.4.10)
  • JGolden1 Calculating status...
    I have the same problem with one of my Mac's (and I tried the suggestions here) so I am not updating the other till it is resolved.
    MacBook & HPLJ2100M, Mac OS X (10.6.4)
  • John Blanchard1 Level 5 Level 5 (4,735 points)
    Janvier, another thing to try, something that has worked with the Epson updates, is to delete the printer from the Print & Fax Prefs, delete the hp folder from /Library/Printers, empty the trash, and, most importantly, restart. Then try using Software Update to install the latest driver again. If that doesn't help, can you send me your System Profile please? Use Utilities/System Profiler and do Save. Hopefully the install logs will indicate what has happened. Thank you.

    <Edited by Host>
  • crabuback Level 1 Level 1 (5 points)
    I am having the same problem. Uninstalling, reinstalling the printer sometimes works for a few print jobs, but then fails. Restarting the computer works for a short time but then I get the same problem back.
    Mac Pro, Mac OS X (10.6.4)
  • James Stover Level 1 Level 1 (0 points)
    Since updating to the new HP Printer Software 2.5.2, my HP All-In-One Printer cannot be found as a wireless device. I tried removing the printer device and then adding the printer back with the IP address. It worked for a couple of print jobs and then couldn't find the printer again. I had no problems for over a year before this update.
    The printer will work fine if I plug in the USB cable, but it is not located in a place where I can use it plugged in with USB all the time.
    iMac 27"-i7-Late 2009, Mac OS X (10.6.4)
  • WasatchGirl Calculating status...
    Thank you Janvier and John. After hours of trying everything else, this finally worked and I am printing again!
  • RedActor Level 1 Level 1 (0 points)
    Yes!! I am having this same problem!

    waiting for printer to become available

    I tried rebooting my laptop and printer, moving the USB cord to different ports, using a different USB cord, Removed and reinstalled drivers... This seems to have happened after a software update on my Mac OS X Version 10.6.5 recently.

    Argh! I've considered using Time Machine to go back...will that do it?
    MacBook Pro, Mac OS X (10.6.5)
  • Nelson Bazinet Calculating status...
    Having the same problem here too (along with the people of this other thread:

    Reinstalling MacOS 10.6.4 and clearing the HP Drivers Update 2.5.2 seem to be a temporary solution for this problem...

    Transmitted a bug report to Apple Support AND HP Support.
    MacBook Pro i5, iMac i3, Mac OS X (10.6.5)
  • Nelson Bazinet Level 1 Level 1 (5 points)
    Installed HP Driver Update 2.5.2, unable to print via wifi from a mac to another mac... Not installed MacOS 10.6.5. So the problem seems to be from the updated driver...
    MacBook Pro i5, iMac i3, Mac OS X (10.6.5)
1 2 3 4 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.