5 Replies Latest reply: Dec 6, 2012 2:32 PM by El Deanio
Rod Fryer Level 4 Level 4 (1,865 points)
This is really following on from the 'Missing Glossary' thread.
I now have a working Glossary in a new User Account, but I'm interested in getting it to work in my Admin Account.
I posted in the Snow Leopard forum to try and get an idea as to how to pin down the culprit file. I've copied the following over from my post on the SL forum:

+I quit GB, removed the files 'com.apple.garageband.plist' and 'com.apple.garageband.LSSharedFileList.plist', one at a time from ~/Library/Preferences and each time opened GB again. Didn't solve the problem.+
+I'm wondering about the file: 'com.apple.garageband.cs' ? Is it OK to treat this in the same way as the two '.plist' files? It's just that I don't know about the '.cs' as opposed to the '.plist'.+
+Another question occurs to me. Is it just Pref. files in the Admin account I need to investigate? Am I right in thinking I don't need to check Pref. files in /Library as opposed to ~/Library?+

At this point I'm directed to the GB '11 forum for further advice.

How do I proceed? There are a lot of .plist files. Which ones are worth investigating first?

iMac 20" 2.4 GHz Intel Core 2 Duo/4GB/Win XP Pro SP3/, Mac OS X (10.6.4), iMac G4 15"/800MHz/1GB and PowerBook G4 17"/1.33 MHz/1GB, both OS 10.4.11
  • Rod Fryer Level 4 Level 4 (1,865 points)
    Since GB seems to work flawlessly In the new User Account – in particular the Glossary works – can I assume that the apparently 'missing' Glossary file in the original account is definitely not the fault of GarageBand?

    So far, my thoughts are that neither the OS nor GB are at fault. I don't know if this is a reasonable assumption.
  • MainStage Fan Level 1 Level 1 (60 points)
    you can delete both of them. GB simply creates new ones. the .cs file is only used for control surfaces, so you usually don't need to bother with it unless you have an iControl or an apogee gio.

    I'm not sure what exactly your problem is though - you can't get the Learn to Play glossary to come up? Or something else?
  • Rod Fryer Level 4 Level 4 (1,865 points)
    Well, we had GB '09 and then upgraded to GB '11. The prospect of the lessons and the feedback where you can see your skills improving (or not) was a big deciding factor.
    It's my wife who uses it. She found that when she tried to get the Glossary (accessed via the Glossary tab when using a lesson) what was returned was a blank white screen with the message: 'File not found' in the top left corner. I set up another account, and everything worked fine there. She got the full Glossary while working on a lesson.

    I tried to sift through the contents of the ~/Library/Preferences folder, testing each file one at a time, by removing it to the Desktop, and restarting. If there was no difference, with the newly created pref file, I replaced it with the original. I am assuming I was carrying out the appropriate steps. It was very time-consuming, and I wasn't able to find the file that might have been doing the damage.

    It's sort of niggling away at me and has become a personal crusade to isolate the problem.
  • compleidiot23 Level 1 Level 1 (15 points)

    Hate to bump a 2 year thread, but did you end up fixing it, I haven't. Doesn't matter if GarageBand updates it's still there.

     

    Thanks

  • El Deanio Level 3 Level 3 (735 points)

    Here's a thought.

     

    Try going into the Admin Account (I'm assuming you have an Admin Account plus your main Account). Temporarily turn off Admin privilages in your main account).  Re-install GB. I'm wondering whether you might at this point get a prompt asking you if you want to make GB available to all Accounts.  If you do get such a prompt, say Yes.

     

    Once reinstalled, try GB again to see if the Glossary is still enabled in your Admin Account.  Then open GB in your main account and check the Glossary again. 

     

    Re-enable Admin priviledges in your Main account again - if you wish to.