1 Reply Latest reply: Nov 11, 2010 7:36 AM by wilhil
wilhil Level 1 Level 1 (0 points)
I have just got an Ipad and tried to set up my mail server.

I have a server that has SMTP on port 25 and IMAP configured on the default port 143, nothing special.

In addition, I have port 144 for secure IMAP and 26 for secure SMTP. SSL is a self signed certificate for a custom root that is installed in all devices that allow it.

I use SSL exclusively here and every laptop, desktop and other device works fine with it.

I first tried to set the Ipad up with this, but when it did not work, I deleted the account and tried the non secure standard 25/143.

The failure message - "Cannot Get Mail - The connection to the server "name" failed." happens straight after entering the mail application.

After many failures, I decided to see what happens if I skip the error and try yo create a new message. When sending I got a message saying "Invalid security certificate" - "Cancel / Continue", or similar - I can't remember off by heart, I did continue and it successfully connected to my secure SMTP server, and I have not got that error since.

I turned on logging on my mail server and found whenever I attempted to retrieve emails, the following message happens:

TCPConnection - SSL handshake with client failed. Error code: 2, Message: End of file,

I get this when trying both SSL on and off.

I tested it on an Ipod touch that was here and it works fine on both Imap Secure and standard.

Does anyone have any ideas?

iOS 4
  • wilhil Level 1 Level 1 (0 points)
    I found the enterprise tool, and managed to pull a log. I have cleared the log, then go in to mail and the following occurs:

    Thu Nov 11 15:33:50 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:33:50 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:33:50 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:33:50 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:33:50 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:33:50 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:33:50 unknown configd[24] <Debug>: CaptiveNetworkSupport:UIAllowedNotifyCallback:63 uiallowed: true
    Thu Nov 11 15:35:14 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:35:14 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:35:14 unknown MobileMail[47] <Warning>: Error: Tried to get message at 0, but we only have 0 messages.
    Thu Nov 11 15:35:14 unknown MobileMail[47] <Warning>: ERROR: MFMessageErrorDomain/Socket Read - The connection to the server "ezpcltd.com" failed.
    Straight after hte last line, the device flashes the "Cannot Get Mail" message.