Previous 1 2 3 Next 77 Replies Latest reply: Jul 22, 2015 6:56 AM by brucemeacbook
Leanne73 Level 1 Level 1 (0 points)
I am connecting an external hard drive to read stored data files from it. I am connecting via USB to one of the terminals on the rear of the Mac Mini. My problem is that after about 5 minutes of using this 'connection' I get a message saying that it has been disconnected. The hard drive is still physically connected and powered up but I can no longer see the icon for the external drive within Finder and in order to be able to go back and read files on the external drive again I need to turn it off and turn it on again. I did not have any problems with the external drive before when using with a PC. Does anyone know the cause?

Mac Mini 2010, Mac OS X (10.6.4)
  • a brody Level 9 Level 9 (65,070 points)
    Welcome to Apple Discussions!

    You may have a loose or bad cable. Try replacing the cable.
  • Mauricette Level 1 Level 1 (35 points)
    You were losing power because your USB ports are all plug-in and four or five your USB ports were sharing the current, 1 for Keyboard, 1 for mouse, 1 for your External HDD, 1 for anything I don't know?

    If you were using 2 external HDDs? then that's it. your current could possibly less than 500mA.
  • a brody Level 9 Level 9 (65,070 points)
    To make it clearer, look at Apple menu -> About This Mac -> More Info under Hardware -> USB. This will tell you which USB buses your drive, keyboard, and mouse are sharing. If you are attempting to share a drive on too slow a bus, it may disconnect. It really needs a dedicated bus. For Mac Minis, most of the time, it is better to find a good Firewire hard drive to go with them than use USB.
  • Philsview Level 1 Level 1 (0 points)
    I am having exactly the same problem.
    I am using an IMAC with two external drives connected. The Freeagent drive that is connected by firewire give exactly the same problem that you have. After waking the computer from a sleep the drive wakes up but within a couple of minutes a message says that I didn't eject the drive correctly. The drive then disconnects but keeps spinning. It is not possible to mount the drive using utilities so the power has to be pulled out, and then turned on from scratch. The drive will then act normally for the new session but will fail the next time that it wakes from sleep. (The other WD external drive, running time machine, is working correctly) I have run first aid on the drive but there seems to be no problem. Needless to say I would be very happy to know how to solve this problem.
  • bradconnell Level 1 Level 1 (0 points)
    I'm having the same problem. I need to get a bigger internal hard drive put in, but I can't do a backup because the external USB hard drives keep stalling and/or disconnecting! Now it's spitting out my iPad during sync's as well. Seems like anything attached via USB 2.0 is vulnerable to be dropped at any time. >:/
  • Ocean Digital Level 1 Level 1 (0 points)
    Same problem.

    Mac Mini 2010
    osx 10.6.5
    Lacie 1TB external USB

    External is not showing up in finder or disk utility.
    It does show up in Sys Profiler, not sharing USB hub. I have to turn off the drive at least once a day for it to reappear in the finder.
  • Ossy1983 Level 1 Level 1 (0 points)
    I am having the same problem with a new external samsung 1tb 2.5" drive. tried a different cable and it still disconnects. please advise
  • gperetz Level 1 Level 1 (10 points)
    I have a Seagate FreeAgent GoFlex Desk 2TB drive. Connected via the USB 3.0 dock (functioning on the iMac's native USB 2.0 ports), I have had good success and a stable connection -- it functions normally. However, I wanted to leverage the GoFlex capability to use another desktop dock, so I bought the FireWire 800 version. While using it (the only FW800 device), I've been seeing the random disconnects as well. My computer is set not to go to sleep (just the display) and the hard drives are not allowed to spin down ("sleep when possible"). This behavior has been consistent between 10.6.5-10.6.7 updates. The only workaround I've found is to create a and run a shell script in the background:
    +while true+
    +touch /Volumes/2TB/touchy.log+
    +sleep 600+
    Basically, the script just generates a minimum of disk activity on a repeating basis. This seems to defeat whatever is timing out on the FireWire 800 bus and causing the disconnections. I've tried this at varying intervals, from every 30 sec. on up to the current 10 minutes and it seems to provide a stable connection to the drive. However, I don't like the "insomniac" nature of a continually spinning disk -- both for energy consumption and for drive wear that will shorten its lifespan. I would like to see this fixed properly, hopefully with the next 10.6 update.
  • gperetz Level 1 Level 1 (10 points)

    This issue is still present in 10.6.8 after applying the Combo update. Can any Lion beta testers confirm whether it appears to be fixed in 10.7?

  • babowa Level 7 Level 7 (28,415 points)

    gperetz wrote:


    This issue is still present in 10.6.8 after applying the Combo update. Can any Lion beta testers confirm whether it appears to be fixed in 10.7?


    If there are any beta testers, they are bound by an NDA (Non Disclosure Agreement); so you will not get an answer to that question: either we don't know or aren't allowed to discuss it.

  • Richard Olpin Level 1 Level 1 (5 points)

    Problem is still there for me I'm afraid.


    I've got the same problem occuring with two different external drives, and it doesn't seem to matter what the connection method is either. I can connect either drive via USB2 or FW800 and the same issue occurs. It will disconnect randomly.


    I've considered getting another new drive just for backups but at the moment I can't have any confidence that it will actually connect so I'm rather stuck as to what to do..

  • jefftb78 Level 1 Level 1 (0 points)

    Same problem here.  The problem is only with FireWire drives.  USB drive works fine.  I am using Lion.

  • Akk1 Level 1 Level 1 (0 points)

    Seagate GoFlex 1TB connected with FW800 to my Mac Mini (Lion), no disconnects here. But on bootup, the drive sometimes seem to lack power and doesen't start correctly. Have to disconnect and reconnect the cable to get it started.

  • Grant Harrington1 Level 2 Level 2 (370 points)

    I've got a Seagate GoFlex 2TB that was reformated, so the built-in utilites got wiped.  Every few minutes, I'd get a Device not put away properly message, then the drive would re-connect.

    I ran an app called Keep Drive Spinning that runs for a quick second to "hit' the drive to keep it awake and the problem went away.  It can be found at MacUpdate's site.

Previous 1 2 3 Next