Previous 1 2 3 Next 117 Replies Latest reply: Aug 20, 2015 8:03 AM by tonya l
ipilya Level 1 Level 1
Anyone else having issue of changes not being saved by iMovie? Any workarounds? I lost hours of work because of this... so I am very... upset... so if anyone else has issue please speak up... and solutions are very much appreciated.

MacBook Pro [Late 2008], Mac OS X (10.6.5), MacBook [Late 2007]
  • iamtheschmitzer Level 1 Level 1
    I am having the same issue in iMovie 09
  • sandemc Level 1 Level 1
    I am having the same problems in iMovie '11?? Has any one figured out the fix?

    I believe it has to with making sure you press "done" before you move onto the next slide, but even that is not working consistently. ?
  • officer_m168 Level 1 Level 1
    Same problem here, wanted to change the stabilisation settings (which i think are terrible).
    Every time i moved the slider to stop the software from zooming in on the clips it just reverted back after a while.
    Even after pressing done
  • jrothmanshore Level 1 Level 1
    I was suffering from this problem and figured out the cause, at least for me.

    One of my projects was corrupt (how that happened is still a mystery), and I was trying to recreate it. As I was doing this, I found that iMovie was frequently not saving my changes. Very annoying and very mysterious.

    I discovered that the root cause was other, corrupt project. It was still in iMovie, and I would periodically mouse over it to look at the order of the old project (this was still possible, despite its corrupt state).

    What I figured out was that every time I touched the corrupt project, iMovie was silently going into a bad state. It would allow me to continue to edit other projects, but in reality, it was not saving any of my changes to them. Once I finally abandoned the project and removed it from iMove, all of my mysterious problems with iMovie not saving changes to other projects went away.

    Very annoying that iMovie has these kinds of silent errors.
  • DCDesigner Level 1 Level 1
    Hi everyone- I think I may have solved this. It solved it for me at least and I'm really hoping this might be a solution for a lot of frustrated people (especially those making movies for the Holidays).

    For me, iMovie '09 and iMovie '11 were not allowing me to save projects. I could create new projects, and then add clips to them, and then close iMovie, and when I restarted everything was gone. I spent hours deleting preferences, restarting, moving all movie/event/project files to isolated folders, deleting projects, etc etc...

    It finally occurred to me that iMovie seemed to be having trouble automating this saving procedure. Which then made me think about why that might be, which lead to "permissions." When you don't have permission to write to a folder, you can't. Neither can iMovie. So I checked my main "Movies" folder, and I had the correct Read/Write permissions. So then I checked the "iMovie Events" folder, and I had the correct permissions there too. Which made sense because I was able to digitize stuff all day long. So lastly I checked the permissions on my "iMovie Projects" folder- and sure enough- for some reason I only had "Read" permissions. BINGO! I don't know if iMovie or OSX made that permission change at some time, or if I dragged that folder over when I got my new laptop... anything could have happened, but either way, changing that permission to Read/Write has solved the problem.

    So- to simplfy:

    1) Go to User > Movies and select that folder, right click and choose "Get Info", and make sure at the bottom of that pop-up window where it says "Sharing and Permissions" that your username is marked "Read & Write." If not, change it to Read & Write"

    2) Go to User > Movies > iMovie Events and do the same thing

    3) Go to User > Movies > iMovie Projects and do the same thing

    If any of those showed "Read Only" permission access, you probably just solved your problem.

    If this works for you please call Apple and tell them to send me a free iPad
  • HGU Level 1 Level 1
    I have the same problem in iMovie 11 (and 9) that not all titles are saved, even if I press done. This is a bug I thought they had fixed when I upgraded to iMovie 11.
  • alysia72 Level 1 Level 1
    Forgive me for sounding like an idiot, but I am not very tech savvy, yet I'm in the midst of a movie project and can't save either.

    What do you mean by
    Go to User > Movies >

    what buttons am i clicking?
  • 1906Beagley Level 1 Level 1
    DCDesigner -

    I was so glad to read your article... I was hoping for a lifeline, as I've been going crazy trying to figure out what's been going wrong with this "auto save" feature. I followed your instructions and, to my great chagrin, each of the three areas you recommended checking were already in both "Read & Write" mode. So, even though these would need to be checked if not a problem, they are STILL a problem for me - because they were already checked.

    I've got 3.5 months into a 2hr movie, and I'm learning now that my iMovie '11:
    a) saves about 92% of the time and
    b) when creating a DVD the quality is very grainy compared to what I see on my computer screen.

    I asked a Genius Bar guy about this and he suggested he had never heard of this problem. How can this be? So many people are having the same problem? ... and so close to Christmas?

    I am really disappointed in Apple, as this is my first ever major investment in their computing products, both hardware and software.

    Frustrated as HECK!
  • John Cogdell Level 5 Level 5
    What do you mean by - Go to User > Movies >
    what buttons am i clicking?

    Open Finder (should be the first item in the Dock with the happy face icon). In the window that opens, click on your User name in the left column (it has an icon like a house). You will see a number of folders on the right. Right-click (or Control-click if you don't have a 2 button mouse) on the Movies folder. Click on Get Info - at the bottom of the panel that appears you will see your Read & Write privileges. If it shows "Read only", click on the arrows and select "Read & Write".

    In the Movies folder you will see folders for iMovie Events and iMovie Projects. Follow the same procedure as I've described above to check the privileges (permissions) for each of these folders (right-click and Get Info). If you have Events and/or Projects stored on an external drive, you will need to check the appropriate folders there also. However, on an external drive the Events and Projects folders will be at the top level (not inside a Movies folder as on your internal drive).

  • CarloNewcastle Level 1 Level 1
    DCDesigner wrote:

    So lastly I checked the permissions on my "iMovie Projects" folder- and sure enough- for some reason I only had "Read" permissions. BINGO!

    DCDesigner you may have got it!

    So far great results. Your solution seems correct and fixes the problem.

    I should mention that for unknown reasons my iMovies project is not in the folder +~/Users/Owner/Movies/iMovies Projects/myfirst.rcproject+ but in the folder +~/Digital & Media/iMovie Projects/myfirst.rcproject+.

    Just to see what would happen, I created the Movies/iMovies folder under my user account to try but iMovies'09 would not accept this location even after I deleted com.Apple.iMovie8.plist.

    Never mind, the fact is your solution to check the ownership and permissions worked and I mention the other location issue in case someone else has not considered their folder and project might be in a different place.

    Let's hope this solution works while I complete my project!
  • JayhawkCWE Level 1 Level 1
    what say I did all the permission corrections (plus running the disk utility fix) and it still happens... any ideas?

    I'm using 11 btw.
  • DCDesigner Level 1 Level 1
    Woo hoo!
  • DCDesigner Level 1 Level 1
    One other thing I found fixed my problems- not sure if its related. I realized I could go through and digitize and hour of video, and then at the end, it wouldn't appear in the Events. But if I went into iMovie Events folder, I could see that a huge clip was added, so I know the video digitized. What I realized is that you've got to be sure you have enough hard disk space otherwise iMovie won't bring that event into the Porject file. For instance, if you've only got 3 GB of space left on your drive after you digitized an hour of video, you need to free up another 5 or 10 GB before iMovie will automatically import the clip. Once I fixed this problem everything has been smooth. I was digitizing lots of videos, that was the main problem. So I ran out of space quickly.

    Hope this additional info helps. Also restarting iMovie, restarting the computer, all of the obvious steps but I hope these additional fixes might help some people (permissions, and be sure you've always got at least 10-20GB available when digitizing.
  • JayhawkCWE Level 1 Level 1

    thanks for your response. I think we have it fixed (not my computer). Since all of the permissions appeared to be set correctly, i.e. she is the administrator and was set to read/write, I went to disk utility and did the ol' permissions repair. It took quite a long time and ran through a litany of permissions it needed to correct so I was hopeful. She came back today and her projects seem to be saving her changes. She does everything on an external (except for imovie) so space was not the issue.

    I'm not sure if that's what fixed it, but it was the only thing I did that resembled any type of fix...
Previous 1 2 3 Next