Previous 1 2 3 4 Next 117 Replies Latest reply: Aug 20, 2015 8:03 AM by tonya l Go to original post
  • Paul Howard4 Level 1 Level 1 (30 points)
    I've tried everything you guys have mentioned on here and I still can't see where you can manually "Save" or "Save as" a project under "File." Plus how do I go back to an old project I'm working on? It only shows the latest project I worked on when I last closed the program. Their is no "open" under "File" to open past projects.
  • John Cogdell Level 5 Level 5 (4,605 points)
    I still can't see where you can manually "Save" or "Save as" a project under "File"

    IMovie is designed to automatically save - there is no "Save" or "Save As" command. However, in some circumstances iMovie doesn't always save your edits, particularly when you change a Title. Instead of "Save As", iMovie offers you an alternative - that is, "Duplicate Project". I will explain how to do this shortly.

    Plus how do I go back to an old project I'm working on? It only shows the latest project I worked on when I last closed the program. Their is no "open" under "File" to open past projects.

    When you open iMovie it will open at the same Event and Project screen that you last closed with. If a Project is open, click on the heading on the left side of the project window, named "Project Library". A list will magically appear showing all your Projects, each with a single bar of thumbnails. Click on one of these Projects, then click on "Edit Project" at the top of the list (it's in the same place as "Project Library", but has now replaced it). Once you have opened a Project in this way, you will again see the header "Project Library" (replacing "Edit Project").

    To duplicate a project - while in Project Library view (where all your projects are listed), right-click (or Control-click) on the name of the project you wish to duplicate. Now select "Duplicate Project" from the menu that appears. A copy of your project will be created by iMovie, with the number 1 appended to the original name - you can re-name this if desired. Duplicating projects is a handy way to save different versions from time to time, particularly when you've made numerous edits that you don't want to have to recreate if a problem arises with the current project. You can always delete the duplicates once your project is complete and properly saved by iMovie.

    Note that projects have a relatively small file size, as they reference their corresponding Event (or Events) - they don't copy the video clips, but simply contain instructions regarding the clips to use, transitions, titles, voiceovers etc.

  • Paul Howard4 Level 1 Level 1 (30 points)
    John - Thank you very much for your detailed answer. It was very helpful and I've quickly gone in to see what you're talking about and see everything. I'll go in later today in more detail to play around with existing projects.

    One other quick question, how do you delete a project? I set up some test projects before I started working on one and now don't know how to delete those test ones. Thanks for your help.
  • Paul Howard4 Level 1 Level 1 (30 points)
    DISREGARD THIS EMAIL. I figured it out. Thanks.
  • Andrew Eddie Level 1 Level 1 (0 points)
    Have had the same problem with iMovie '09 and having the same problem with '11 (even after the update to 9.0.1 last night). Text is not saving between closes properly but this could manifest as either a loss of a font change through to reverting back to the default text ("Type title here" stuff) as if you'd just inserted it. So far only noticed it with text - no other loss of data fortunately (yet...).

    Edit: have checked permissions and they are ok.

    Message was edited by: Andrew Eddie
  • ZiggyYork Level 1 Level 1 (0 points)
    Yes I too have the problem of imovie 11 not saving my changes to text. At first I thought maybe it was me not clicking done after alterations but I have double checked and even after exporting the finished project I went back into the project in imovie and found that the changes I had made were undone.

    This is very frustrating and not a good reflection on what is otherwise a great program.
  • Questionable Sanity Level 1 Level 1 (5 points)
    I'm also having this problem, and permissions aren't an issue. This is a ridiculous bug. If you can't make an autosave work, then let us do it and put manual saving back in the program. There is absolutely no excuse for this.
  • Questionable Sanity Level 1 Level 1 (5 points)
    I chatted with Apple Support on Friday and they were unaware of the issue. He did some digging and saw that people were having trouble, and recommend the usual refresh of the preferences, etc. That didn't fix anything unfortunately. It worked for one save, that's it. He told me to call back, and then he'd forward it on to the software guys in case it was a bug.

    Called in today, a new said that the project file must be corrupted, and then tried to up-sell me to Final Cut Pro. Just thought I'd toss that out there to see if anyone has heard anything positive through the support system.
  • stacyg1 Level 1 Level 1 (0 points)
    iMovie 09 does the same thing. I was okay on 06, then upgraded. It was okay for the first few projects, but got progressively worse. Now, I can't save anything even after having deleted ALL my old projects and files to make sure nothing was corrupt.

    I'm going to try and reinstall to see if that helps.

    Surely, they have to know there's a bug. How many people have to call before they fix it?
  • tigertype Level 1 Level 1 (0 points)
    OK, I’ve got so many hours into this project, and this repeated failure to save my title updates was driving me crazy, and I was getting to the point where I was contemplating never quitting iMovie again until this project was finished, either that or I was gonna hafta jump off the Golden Gate Bridge.... I am driven to figure this out! So I read through this entire string and tried all the suggestions up to here with no luck. As I pondered it, it occurred to me that it was happening intermittently to me, i.e. some captions would stick and others wouldn’t, so I started focusing on those...and it seemed to me that the captions that weren’t sticking were generally inside of title “frames“ that either had been moved from their original position, or had been copied from elsewhere in this same project and pasted into a new location, or option-click-dragged to a new location. (And I have a lot of titles in this piece. It is strictly a glorified slide show, with no video clips, just iPhoto stills, each with an average duration of 4 to 8 seconds, with a thirteen minute movie, that’s about 150 to 190 pics, most with their own title)

    Imagine my excitement that maybe I had an answer. Maybe the individual title frames were getting glitchy on me. And it seems for me that I might have a solution! (anti-curse, knock on wood, throw salt over my shoulder, quick, find the rabbit’s foot). I tested my theory by opening the project, noting that again some fixes I KNOW I had made were gone. So I opened that title frame, selected the content, cut the content, hit return twice to escape editing of that title frame (now empty) and selected it in the timeline browser and deleted it. Immediately I dragged in a new title frame from the browser in iMovie, entered that title frame to edit it, pasted the previously cut content, made edits to that pasted content, hit return twice to exit editing, clicked “project library” button (in case that is what is supposed to activate the auto save?) and exited the timeline editing area, quit iMovie and then said a prayer to the computer gods, reopened iMovie...and VOILA! My edits are now sticking!

    I did this process a couple of times and it seems to be repeatable. I know I won’t feel comfortable until nothing has reverted for a couple of days, and I won’t try holding my breath that long.

    Don’t get me wrong, I’m one of the world’s biggest Apple fans. It just seems odd to me that Apple doesn’t weigh in on this topic. I try to rationalize it by saying that I know Steve’s obsession with secrecy has been a good thing in some ways (marketing mostly IMHO) and I like to think that Apple is feverishly working on a fix, silently, behind the would just be nice to actually know that “yes, we are aware of it and we will have it fixed someday”, instead of getting stonewalled by front line responders who “haven’t heard a thing about it“. I’ve experienced this once before from Apple. Did you know that it is nigh close to IMPOSSIBLE to restore an iPhoto library that has been backed up via Time Machine? Similarly they make no comment on this bug, and the phone support guys I have worked with on this had not heard of the issue until I called. That bug actually seems WAY bigger than this iMovie iPhoto library back up that can’t be restored is the equivalent of no back up at all!

    Message was edited by: tigertype
  • ruthfrommissoula Level 1 Level 1 (0 points)

    iMovie did not save the hour of work I did last night - opened the project this morning and everything I did was gone.  Do not appreciate paying for a product that wastes my time - please fix, Apple.

  • gualo Level 1 Level 1 (0 points)

    I was having this problem too and it was driving me crazy causing me to loose many hours of (usually night) work.

    After trying the different solutions I found here and elsewhere on the web I finally settled on just duplicating the project. This completely solves the problem, including copy/pasted titles because apparently it forces iMovie to save the master project as well.

    It's kind of weird to use "Duplicate project" instead of "Save copy as", and also the duplicate project command is not available in the project edit view so I have to switch back and forth between the project edit and the projects library views, but as long as it does the job I'm happy again   Also it has the added benefit of keeping a "version history" of the project as a byproduct, though I actually use GIT to do the real versioning.


    Happy yes, but not satisfied!  I think it's shameful for apple not to address this problem immediately with a patch. We are not talking here about an "inconvenience" but of actual loss of data, work and time. While I can understand the choice for an automagic saving feature and actually approve it it's either Apple does it right or they put back a standard "Save" command. Personally I'm used to "automatically" save my work constantly so this wouldn't affect my work. They could even keep the automagic saving just in case for people not used to periodic saves.


    Apple, do your job! Now!

  • btourwe Level 1 Level 1 (0 points)

    I experienced the same problem: worked on my project for 4 hours last week. When I opened it again this evening, all changes were lost. Also the modified-date of the project fil was not changed.


    I read in this post someone mentioning a thing with file permissions, so I checked.

    And yes the file permissions of the project file did not allow my user to change the file. I remember copying the project file from another user profile a couple of weeks ago, and figured that this might be the cause.

    Although I altered all folder permissions back then, the file permissions were not updated.


    Tip: To make sure all files in your user folder can be modified by yourself, edit the <user>folder permissions, and click on the wheel underneath, selecting something like 'modify all objects underneath'. Doing so, sets all file permissions like the <user>folder permissions.

    Afterwards, I tested changing the iMovie project again, and now it worked.


    Still, I wonder iMovie didn't complain when I quit the application last week after editing for 4 hours. It should have stopped from quiting I feel, and should have alerted me that it couldn't save the changes to the project. Then I could have modified the file permissions at that moment, quit iMovie, and my work wouldn't have been lost.


    Apple, this is a change request for your next release of iMovie.

  • leafromeastham Level 1 Level 1 (0 points)

    Having same problems in iMovie '11. I change the text in one of the text slides with a box around it, and each time when I reopen iMovie, the changes are gone. It's happened now 3 times. Will now delete the text slide and re add to see if it works.


    Also, I cropped one of the videos, and that change was also lost. Makes me lose faith in iMovie - who wants to spend all that time and effort when you don't know for sure the movie will not be saved as you made it.


    Can someone please from Apple answer this rather long thread and let us know how to work around this?


    Thanks, Lea

  • romanempireof4 Level 1 Level 1 (0 points)

    Just chiming in as another individual who's pretty upset at the bugs in iMovie '11 (and iDVD).  I too have lost hours of work.  I was creating a photo slideshow w/ my title edits getting lost w/ each opening.  After trying the other fixes, out of fear I did not close my project until I was ready to share with the Media Browser.  (Side note: when I created my iDVD with the project I found that once it burned it would skip in the dvd player like it was scratched.  I tried other fixes suggested in the discussion boards on that topic including a slower burn, but still had the same issues. Fortunately it plays fine in a computer which was good b/c that is how I was able to present.)  Back to iMovie though.. after finally having my project titles 'saved' properly for a couple of days, when I exported my project today to share on vimeo, it reverted back to the old titles before I edited them.  I am so distraught!!  Once again I have lost the work on my finalized project.  I can't believe my work is lost and I have to re-do.  I love the improvements to iLife, but without reliability... my computer has become a really expensive paperweight!!  Please fix!! 

Previous 1 2 3 4 Next