Skip navigation

iMovie '11 is not always saving changes

55989 Views 114 Replies Latest reply: Dec 30, 2013 8:53 AM by Icelyn RSS
  • hananias Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2011 1:24 AM (in response to BookX)

    I just do the basic color editing and titles.  That is it!  And now imovie 11 can't save my work! 

    iLife is strong reason why I chose OSX/Mac over Windows! 

    I have checked my permissions a billion times.  My user name profile is owner, and has permission "read/write" (including sub folders).  I repaired and rechecked... nothing!  This imovie is crazy!!!

    One day is working fine... and all of the sudden, it doesn't feel like saving??!!  I have over 90GB of free space, so thats not problem either.  Has anyone else found a real fix for this problem???

    Even my i5 MacPro 3,1 8GB Ram had a problem once that it was "low in memory".  How if I had 3GB free memory, and no other programs opened at the time???  Where did the rest of the 4-5GB Ram go to???

     

    By the way, running fully updated Lion (biggest regret of my OSX life).

  • elikness Level 4 Level 4 (2,635 points)
    Currently Being Moderated
    Dec 1, 2011 8:39 AM (in response to hananias)

    Has this happened after you upgraded to Lion 10.7? Or has it happened all along?

  • hananias Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2011 8:11 PM (in response to elikness)

    not immediately after.  But really about a week or 2 ago did that error start popping up...

    I haven't installed anything new this past month.  No changes what so ever.  Just one day out of the blue... iMovie just started showing that error (no space/ permission error).

    On the other hand, I created a new project and that work flawlessly.  It saves the changes on new projects, but for the other 51 projects it won't work!! not one of them can I make changes!    51 PROJECTS!!!

    I also tried creating new folders for the Projects and Events to move into... that didn't work either.

    Please, help!!!  I was working on a family home video, and now that project is on hold... well, till apple or some one comes up with a fix to this obvious bug.

  • elikness Level 4 Level 4 (2,635 points)
    Currently Being Moderated
    Dec 1, 2011 8:31 PM (in response to hananias)

    Have you deleted iMovie Preference file yet? com.apple.iMovieApp.plist

  • hananias Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2011 9:53 PM (in response to elikness)

    yes i deleted the plist file.  Still nothing changes. 

    I really don't know what to do next.  I have to finish this project for my mother that lives in the states.

     

    What gets me frustrated the most, is that I didn't do any changes what so ever to this machine, but it still acts crazy!!!  The folders/subfolders have the correct permissions... still acting stubborn... this is NONSENSE!!!

     

    Please any other ideas are welcome. 

  • amn_pie Calculating status...
    Currently Being Moderated
    Dec 1, 2011 10:22 PM (in response to hananias)

    I feel for ya. Here's a solution: download the trial for imovie pro (final cut pro x) and import all the imovie files, which will convert them to fcp files. Next download Adobe premiere pro, and it will allow you to import fcp files. Finish your projects with that bad boy and you'll see what you've been missing. It's much better than fcp x. Apple is going downhill nowadays.

  • hananias Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2011 10:58 PM (in response to amn_pie)

    I've tried fcpx and liked it, but ¥26,000 doesn't seem right for an iMovie Pro upgrade.  Sure the export came out beautiful and very small size.  But it doesn't feel like a "PRO" editor software... just an EXPENSIVE iMovie.

     

    Also tried the trial version of the ¥6,900 for Adobe Premiere 10, which seems more reasonable... but it was soooo hard to get use to.   And the layout is terrible, messy, confusing.  The exports were huge size and a little more pixelize than I thought for a paid program, not to mentioned you need a tutorial to learn how to export properly.  Literally I went to Google and Youtube to learn how to get good export with as small size as possible.  Still don't get that program. 

     

    Better yet, if apple could just update and fix iMovie for its customers, that would be great. 

     

    Question:  Has everybody in this forum found the fix or a workaround to this problem?  Or did everyone just moved on to FCPX & APE 10?

  • Steve Mullen Level 2 Level 2 (250 points)
    Currently Being Moderated
    Dec 1, 2011 11:13 PM (in response to hananias)

    I've tried fcpx and liked it, but ¥26,000 doesn't seem right for an iMovie Pro upgrade.  Sure the export came out beautiful and very small size.  But it doesn't feel like a "PRO" editor software... just an EXPENSIVE iMovie.

     

    Also tried the trial version of the ¥6,900 for Adobe Premiere 10, which seems more reasonable... but it was soooo hard to get use to.   And the layout is terrible, messy, confusing.

     

    I too agree that spending the money for FCP X since I've worked-out how to solve all iMovie (DV and DVD, p60/p60, etc.) problems -- except this one.

    iLife is typically update in January so my guess there will be no fixes until then.

  • amn_pie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2011 11:21 PM (in response to hananias)

    FCP X isn't pro software. The compressor program is very slow and processor intensive. And Motion cannot hold a candle to after effects. I was reccomending Premiere Pro, not Elements 10. I tried Premiere a few years back and despised it. I agree with you on that. But, the latest version is pure ecstacy.

    There is no workaround other than downloading FCP X. iMovie isn't going to get fixed. They have known about these issues since iMovie 2009 and didn't bother. Like I said before, it's looking a bit like they did it on purpose to sell their iMovie Pro (FCP X).

  • hananias Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2011 6:11 AM (in response to amn_pie)

    Well, it's not a fix... but a long work around. 

     

    - Make sure everything, I mean literally everything; every event, project and clips are saved !!! (can't stress that enought)

    - in iMovie 11 I deleted everything, and emptied the trash. (you may even want to delete the imovie.plist if you want to start fresh)

    - I double checked my permissions in my Movies folder

    - Started iMovie and from my back up, manually copied all the events/projects in the "events" & "project" folders in the Movies folder (or where ever you are storing your iMovie Files)

    - Everything is working fine again!!!

     

    *I guess the reason this "work around" worked, is because as I stated before...only "new projects" that I started, was I able to adjust and iMovie auto saved with out giving me the No Disk space/Permissions' error.

     

    It was a long work around, but I guess it did save me $$$ that would have cost if I bought FCPX/ APE10

     

    If somebody else has a better work around or fix... please post it up. 

  • elikness Level 4 Level 4 (2,635 points)
    Currently Being Moderated
    Dec 3, 2011 3:39 PM (in response to hananias)

    As I always say, thanks for posting this back to the group. Definitely, definitely was maybe an iMovie permission problem, but who knows what triggered it? Maybe it's the way iMovie keeps its own internal database of all the projects/events in both Libraries. Anways I guarantee this is going to help somebody else who runs into this issue. Occasionally I've read postings on the iMovie Discussion group where pulling out projects/events from the Movies folder and then starting iMovie, forcing it to maybe 're-index' both Libraries inside of iMovie will clear out something. Then upon moving folders back into the Movies folder, starting iMovie it has to re-account for the 'new' folders it sees and 're-index' them somehow (?) Dunno, just a guess at this point, but others have done similar things to get iMovie working again. Good troubleshooting, and cheers to you for not giving up.

  • hananias Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2011 2:14 AM (in response to elikness)

    Wow, that sounds like a very likely possibility.  Good theory.

     

    &

     

    Thanks for the kind words, but here is hoping that apple finds the problem and fixes it with a small update in the near future.

  • roger and carol Calculating status...
    Currently Being Moderated
    Dec 21, 2011 1:34 PM (in response to ipilya)

    I am having the same problems as everyone else.  It seemed to have started when I changed to “Lion”.  I spend about an hour reading all the threads and amazed that it started 13 months ago and has 14,000 views all directed at the SAME problem.  I to have tried deleting the plist, ran Onix, duplicated projects, checked and rechecked permissions and I am not sure of anything yet.  I’m kind of reluctant to put much of my time or effort into “Imovie” just yet.  I lost 8 hours and had to re-do my project.  I thought “Imovie 9.0.4” had the fix but was deflated when I viewed my release which was 9.0.4.  I’m frustrated but fortunately I’m a relatively “new” MAC user coming from 15 years of MS Windows so I’m pretty use to software crashes.  Reminds me of the MS “blue screen errors” gosh those were the good ole days.

  • Yoda429 Calculating status...
    Currently Being Moderated
    Jan 18, 2012 10:54 AM (in response to ipilya)

    I'm having the same issues too! All my permissions are correct, I'm able to Read & Write. Is this just yet another large bug in iMovie '11?

  • mekanic1 Calculating status...
    Currently Being Moderated
    Jan 19, 2012 11:15 AM (in response to DCDesigner)

    Pardon my ignorance but where do I find "User" in order to change those parameters? Thanks

1 2 3 4 5 6 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.