Skip navigation

iMovie '11 is not always saving changes

56193 Views 114 Replies Latest reply: Dec 30, 2013 8:53 AM by Icelyn RSS
  • Adam_Electric Calculating status...
    Currently Being Moderated
    Feb 21, 2012 12:22 AM (in response to mekanic1)

    its in FINDER>USER>BLAH BLAH ...

  • Adam_Electric Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 21, 2012 12:31 AM (in response to Yoda429)

    there is no such bug its just that its completely in different order since this is a different interface..

    its not going to save as or save ... under file!

     

    it will be different and i found out just now ..

    i came to this forum because i thought i was having issues is just that i am not having issues..

    i searched and logically found it on the tab ...

     

    this is how you "SAVE" a file or edited video or movie... and all about depends on which format you will like ...

     

    do step that follows and check the directory where it will be stored (FOLDER) for windows users..

     

    Go to IMOVIE...

    than go to ur task bar on top where it says SHARE under [IMOVIE ...]

     

     

    SHARE> EXPORT MOVIE> EXPORT.

     

    its very easy and simple and before you make your decisions where to store your file...

    always check ...

     

    WHERE WILL IT BE SAVED?

     

    AND WHAT TYPE OF SIZE WILL IT BE?

     

    thank you and i hope this helped you guys!!!

     

  • magdalen23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2012 5:38 PM (in response to Adam_Electric)

    adam_electric, thanks for trying to be helpful, but the issue here has nothing to do with how to export a Quicktime file or mp4 or what-have-you. it's that iMovie has known bugs related to not automatically saving changes (especially to text) as the user makes the changes. the user does not find this out until AFTER the editing session. it all looks fine when you quit out of iMovie with your nice movie all finished.

     

    later, you open iMovie and none of those changes were done. your nice movie is not all finished after all. and you should not have to save out a Quicktime file (which takes a good long while) every single time you make a good edit of your movie!!

  • G-Berg Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 2, 2012 8:52 PM (in response to magdalen23)

    Wow.  This is a mile long thread that spans multiple major versions of a software product through more than 15 months with no resolution.

     

    I find it hard to believe a problem like this couldn't be addressed in more than a year!

     

    I do believe the problem has to do with duplicating (or copy/pasting) titles as only those titles that were duplicated on my project seem to reset when I quit and relaunch iMovie.

  • Joed74 Calculating status...
    Currently Being Moderated
    Apr 1, 2012 9:56 AM (in response to elikness)

    I've been trying to resolve an issue with iMovie 11 not allowing me to save projects on my newer iMac.  I have followed every possible workaround discussed:

     

    1. I have repaired permissions with disk utility

    2. I have used chmod 777 to make sure all movies folder and subfolders including imovie project and events folders have full read & write access.

    3. I have deleted and reinstalled imovie 11

     

    The one workaround I have not been able to do is delete the imovie plist preference file.  This file does not exist in my library preference folder for some reason?  I don't know why.  All other apps have plist shown in there and I found imovie 8 and imovie 7 plist in there but no imovie11 plist.   The preferences in the iMovie 11 application are sticking and changeable when I set them so I know this must be stored somehwere but its not in the home directory library-> preferences like all these threads tell me to find it in. A full mac search does not find the .plist.

     

    I am at a loss for resolving the issue. Any other ideas?

  • G-Berg Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 1, 2012 11:42 AM (in response to Joed74)

    It seems to be saved in com.apple.iMovieApp.plist now...

     

    Good luck!

     

    Greg

  • BookX Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 1, 2012 11:57 AM (in response to Joed74)

    I don't really think this kind of occurrence is about a plist file, but if you really want to search for iMovie plists, here is how.

    Open a New Finder Window, then cmmd+f to Search: This Mac, click on Kind in the Search toolbar to expand it and chose Other…

    In the Select a search attribute pop-up window, scroll down to the File extension attribute and check its selection box and click on Okay button. Now, you can search for File extension is plist… iMovie 11, creates "Cache.plist" files stored in /Volumes/"your hdd"/iMovie Events.localized/"your event name"/iMovie Cache

     

    To sum up, each iMovie event contains its own Cache.plist stored in iMovie Cache

     

    Make sure you backup the plist(s) somewhere on your hdd or, don't empty the Trash so you can Put Back in case you want to recover the files.

     

    Personally, I don't really like much messing with inner works of any programs or with the OS and is good to always make a backup copy of the whole system on an external hdd, just in case something goes wrong while I am at it.

    Regards

  • BookX Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 1, 2012 12:41 PM (in response to ipilya)

    Hi Everyone,

     

    I have a decent work around, but this doesn't mean the problem is solved. It works on iMovie very well and I have a copy of the text I use in my videos. This method gives me more flexibility in changing fonts, style, color, etc.

     

    I use Text Edit to make my own text composition and I don't type the text in iMovie Title directly, but use Copy and Paste commands to change titles. The change is instant and iMovie save it every time.

     

    Please note not all title styles in iMovie respond to all font types due to their predefined motifs.

    Regards

  • Joed74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 1, 2012 4:53 PM (in response to BookX)

    Thanks BookX, I wasn't trying to delete the cache plists, just the imovie app main plist.  But I did try the search method you recommended. No luck finding the com.apple.imovieapp.plist without the "11" in the name.   My movies projects were all transferred over firewire from my macbook when I first brought up this iMac.  iMovie has never worked for saving movies on this new iMac and I can't figure out why.   I can make edits and work with projects but nothing saves. iMovie says the following when I first start with any project...

     

    "Please check the disk to ensure there is enough free space and you have permission to write projects. iMovie will try to save periodically, but your changes will be lost if you quit iMovie before the problem is resolved."

  • BookX Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 1, 2012 5:20 PM (in response to Joed74)

    Unfortunatelly, this post is about iMovie not saving Title text ocasionally, all other parts of the project do get saved every time.

     

    If you're getting this on the screen, "Please check the disk to ensure there is enough free space and you have permission to write projects. iMovie will try to save periodically, but your changes will be lost if you quit iMovie before the problem is resolved.", you should check disk quota size (if any) for your user name and/or your permissions if were changed to the folder or hdd you're trying to save the project to.

     

    "No luck finding the com.apple.imovieapp.plist without the "11" in the name."

     

    You're looking for a file that iMovie 11 does not make. As I mentioned before, look in /Volumes/"your hdd"/iMovie Events.localized/"your event name"/iMovie Cache for files called Cache.plist

     

    Where "your hdd" is the unique name given to the hdd, either by an administrator, by you or, it's just the original name the Mac came with. The same thing goes to the "your event name" - it's a unique alphanumerical name like this "New Event 5-14-10".

     

    I hope this helps.

  • BookX Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 1, 2012 6:01 PM (in response to Joed74)

    Try this: do a Cmd+Shift+g at Finder and paste this path into "Go To The Folder": /Applications/iMovie.app/Contents/MacOS then double left click on the file iMovie. You'll notice Terminal window shows up and launching iMovie. Do not close the Terminal and watch what it prints on cmmd line while the app is launching. See if there's any other warnings or launching statements.

     

    You should get something like this in Terminal:

    "Last login: Sat Mar 31 09:12:28 on console

    "Machine Name":~ "User_Name"$ /Applications/iMovie.app/Contents/MacOS/iMovie ; exit;

    logout

     

     

    [Process completed]

    Last login: Sun Apr  1 10:55:23 on ttys000

    "Machine Name":~ "User_Name"$

     

    Note: do not post your unique "Machine Name" nor "Your User Name" or any other sensitive personal information, but issues or statements between logout and [Process completed] space.

  • Joed74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 1, 2012 7:05 PM (in response to BookX)

    Thanks BookX. Okay, there is some  information in the terminal when the "can't save projects" window appears in iMovie.  Error writing disk and something about NSAlert.  The messages appear to be internal debug related. Not sure what they mean or point to as the culprit?  I am admin on my machine and have full RW access to everything.

     

    Last login: Sun Apr  1 18:45:02 on ttys000

    <machine name>:~ <home>$ /Applications/iMovie.app/Contents/MacOS/iMovie ; exit;

    2012-04-01 18:47:40.721 iMovie[6853:930b] Project '/Users/<home>/Movies/iMovie Projects.localized/<mymovieproject>.rcproject' - save: Error writing to disk!

    2012-04-01 18:47:40.743 iMovie[6853:930b] NSAlert is being used from a background thread, which is not safe.  This is probably going to crash sometimes. Break on _NSAlertWarnUnsafeBackgroundThreadUsage to debug.  This will be logged only once.  This may break in the future.

    logout

  • BookX Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 1, 2012 7:59 PM (in response to Joed74)

    Okay… this one is risky in the sense that you'll probably have to reinstall iMovie, but here it is anyway.

     

    Make sure your Trash is empty, then go to iMovie in Application folder and drag it to the trash (Do Not empty trash).

    Launch Disk Utility found in /Applications/Utilities folder and select the hdd at the very top in the left pane of the Disk Utility and then click on Verify Disk. If there are errors then chose Repair Disk. After this is complete, open Trash folder, right click on iMovie icon and chose Put Back.

     

    Last thing do this Cmd+Shift+g again at Finder and paste this path into "Go To The Folder": /Applications/iMovie.app/Contents/MacOS then double left click on the file iMovie.

     

    Let me know if these numbers change after all this:

    "iMovie[6853:930b] Project '/Users/<home>/Movies/iMovie Projects.localized/

    iMovie[6853:930b] NSAlert is being used from a background thread, which is not safe."

  • Joed74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 1, 2012 9:22 PM (in response to BookX)

    Disk utility found no problems with my disk.  After following the remaining steps, the hex values in the terminal error messages did change:

    iMovie[9222:14c07] Project....

    iMovie[9222:14c07]NSAlert...

  • BookX Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 1, 2012 10:14 PM (in response to Joed74)

    The way I see it, perhaps you manually moved a project, created with an earlier iMovie version (2-3 years old), onto your new Mac? If that's the case, you need to move all the necessary events (those that belong to the project) onto your new machine. First, I would put the project file back, exactly into its original folder, attach an external hdd to your earlier OS computer and export the project the correct way.

     

    I thought for a moment you had some sort of hardware failure on your new machine. Is that what happened?

    Regards

1 ... 3 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.