Previous 1 2 3 Next 108 Replies Latest reply: Jan 8, 2011 3:18 PM by mlblacy
PanixP Level 1 Level 1
We are a professional printing bureau and after 10.6.5 update all prints in Landscape mode come out cropped as if the page setup is portrait. The only solution is to rotate the artboard in Photoshop or Illustrator to Portrait.
Any more people facing this issue?

Thanks in advance


Solved by Gerrit DeWitt on Nov 14, 2010 2:39 PM Solved
After further testing and review, I have isolated the problem to the pstops filter that's included with CUPS 1.4.5 (and Mac OS X 10.6.5). I was incorrect in my first guess that the pictwpstops filter was involved (although I was close)!

If you'd like to fix the problem yourself before Apple does, you can. Here's how:


• CUPS is open-source and free software, so the source code is published at

• It is perfectly legal to replace an open-source part of Mac OS X with a different version of that part that you've compiled from source (or that a third party has compiled from source for you).

• Although I've heavily outlined the following procedure, and tested it to the best of my ability, you're the one who will be following the directions, so you could make a mistake. As such, you assume full responsibility for anything that goes wrong (including data loss)!

Now, here's what to do, in a nutshell:

(1) You need the Xcode Developer Tools installed (specifically, you need the gcc compiler). You can install these from your Mac OS X 10.6 Install DVD. You also must be logged-in as an administrator.

(2) Download the CUPS 1.4.4 sources from (Direct link: .bz2)

(3) Expand the compressed archive in your Downloads folder - you'll get a folder called "cups-1.4.4" after doing so. At this point, let's agree that the path to the "cups-1.4.4" folder is: ~/Downloads/cups-1.4.4

(4) Open Terminal, then issue the following commands:

(4a) *cd ~/Downloads/cups-1.4.4* +Press return.+ This takes you to the directory where you've expanded the CUPS 1.4.4 source.

(4b) *sudo ./configure --with-archflags="-arch i386 -arch x86_64"* +Press return, and enter your account password, then press return again.+ This begins the process of setting up the build. It will take a few seconds.

(4c) *sudo make -B* +Press return.+ This will build the CUPS software. It will take a few minutes to complete.

After 4a - 4c, you've built CUPS 1.4.4. At this point, you have two options to proceed:

*Option A - Replace all of CUPS.* You can replace the entire CUPS 1.4.5 that came with Mac OS X 10.6.5 with the CUPS 1.4.4 that you just built. OR

*Option B - Replace just the pstops filter.* This leaves the rest of your CUPS 1.4.5 installation intact, only downgrading the pstops filter.

(5) - Option A Only: In Terminal, type: *sudo make -B install* and press return. This will move the just-compiled CUPS 1.4.4 pieces into their appropriate locations. Restart your computer when this finishes.

(5) - Option B Only: Issue the following commands while still in Terminal:

*sudo launchctl unload /System/Library/LaunchDaemons/org.cups.cupsd.plist* (This stops the CUPS printing system so that we can replace the pstops filter.)

*sudo rm /usr/libexec/cups/filter/pstops* (This removes the CUPS 1.4.5 version of pstops.)

*sudo cp ~/Downloads/cups-1.4.4/filter/pstops /usr/libexec/cups/filter/pstops* (This copies the 1.4.4 version of pstops to its appropriate location.)

*sudo chown root:wheel /usr/libexec/cups/filter/pstops* (This sets the owner/group on pstops correctly.)

*sudo chmod 0555 /usr/libexec/cups/filter/pstop* (This sets the permissions on pstops correctly.)

Reboot your computer when finished with the above.

*To undo the changes you've made:* If you'd like to undo the changes you made - either replacing all of CUPS with version 1.4.4 or just the pstops filter - you can easily do so by re-applying the Mac OS X 10.6.5 Update Combo. Link:
Reply by Steve Dutton on Nov 11, 2010 4:51 AM Helpful
Same problem here . . . very frustrating.

All replies

  • Steve Dutton Level 2 Level 2
    Same problem here . . . very frustrating.
  • Steve Dutton Level 2 Level 2
    I've been trying different things to figure this out. Text Edit and Word seem to be fine when printing landscape. Adobe Reader is fine printing a landscape PDF if Portrait is selected in the Page Setup. Can't seem to get an InDesign document that is created in landscape to print in landscape regardless of the different combinations (on different printers). So is it an Adobe specific issue?
  • Steve Dutton Level 2 Level 2
    I've now printed in landscape with quite a number of programs with no problems. It seems to be an Adobe issue.
  • PanixP Level 1 Level 1
    It appears to be a bit Adobe specific even though this was an Apple update after all! . Preview also prints fine in landscape and so does IllustratorCS5 and inDesignCS5 if you select portrait in page setup. PhotoshopCS5 has its own print dialog for page setup so you can't really do anything... Hope this gets fixed soon because it creates a big confusion for our employees and our workflow. The issue is with all our printers btw.
  • Steve Dutton Level 2 Level 2
    I finally got InDesign to print properly (2 sided printing in landscape mode). In Setup, I had "Defined By Driver" in the Paper Size. Once I selected the actual paper size, it works.
  • PanixP Level 1 Level 1
    Any luck with Photoshop?
  • Richard Cartledge Level 2 Level 2
    This exact problem happened before with one of the 10.5 or maybe 10.4 versions. It was Apple who fixed it, not Abobe, and the fix posted above also worked back then..
  • PanixP Level 1 Level 1
    I hope this gets fixed asap as Adobe changed the print dialog for Photoshop CS5 without access to OSX page setup dialog....
    Only solution it to rotate the artwork to portrait...

    Message was edited by: PanixP
  • Gerrit DeWitt Level 4 Level 4
    I can confirm that this problem is unique and occurring with Mac OS X 10.6.5 and the HP Drivers 2.5.2 for HP LaserJet and DesignJet printers. Most likely, the problem is with the Mac OS X 10.6.5 update rather than the HP Drivers 2.5.2 because:

    (1) The HP Drivers 2.5.2 update has been out for a week, and was working just fine with Mac OS X 10.6.4.

    (2) Some are reporting problems with printers from a different brand (like Epson).

    (3) Mac OS X 10.6.5 includes CUPS 1.4.5 (10.6.4 included 1.4.4). This is most likely a CUPS bug.

    You can report this bug in two places:

    (1) At the Apple Bug Reporter:

    (2) At the CUPS site directly:, then click "Submit Bug or Feature Request." CUPS (Common UNIX Printing System) is the open-source printing engine that Apple uses for Mac OS X. Many Linux and other UNIX systems also use it. In 2007, Apple assumed control of the CUPS project, although it remains open-source and free-software (GPL).
  • Brian Alter Level 1 Level 1
    Quick fix: rotate canvas 90° and print portrait.
  • mino design Level 1 Level 1
    Yes , i also facing this problem, very headache, what can i do is quite troublesome for us to printing large file if we need to rotate to potrait, it is not the right way to solve the problem. pls let us know how to do , any update ?
  • Richard Walker Level 1 Level 1
    Yes, I also have the same landscape printing problem after 10.6.5 update with Acrobat, Illustrator, InDesign & Photoshop (CS5)
    Printer: Xerox Docucolor 242 and 240 (Fiery Rip)

    I can also confirm the workarounds mentioned above work for me:
    Indesign & Illustrator - Change 'Paper Size' 'Defined by driver' to the correct paper size
    Photoshop - Rotate canvas - Not great but works.
    Acrobat - Rotate page

    I have also reported the bug to Apple.
  • Nicholas Dring Level 1 Level 1
    Confirmed here too!
  • gregk2 Level 1 Level 1
    I'm having the same problems and I'm about to lose it this morning. What do I need to do to stay informed?
Previous 1 2 3 Next