7 Replies Latest reply: Feb 25, 2013 7:39 PM by jalexromero
tigchambers Level 1 Level 1 (0 points)
Hello,

I have been encountering a little problem on iMovie 11, when adding transitions (cross fade, cross blur etc.). Although I have been able to add a couple to the current project I'm working on, I am now finding that when I try to add another it malfunctions. When you bring a transition across to the editing suite, the area you drop it into is highlighted with a green bar between the clips in question; however when I try to drop the transition in, the green bar just stays there, and the entire project crashes - I can't spool through the rest of the clips.

To make sure I don't ruin my project, I simple do Apple+Z to undo, close the programme, and then reopen it, and nothing is lost.

But I'd like to be able to use the transitions, and if you could give me an idea of what might be gong wrong, I would be very grateful.

Thank you in advance.

iMac, Mac OS X (10.6.4)
  • Daniel Slagle Level 7 Level 7 (22,415 points)
    Did your try, the old standard answer, clearing caches and fixing permissions? http://uimfaq.us/b3aANe

    I am starting to feel like a parrot but it does work.

    -- Dan
    Keeper of TheUnofficialiMovieFAQ.com
  • tigchambers Level 1 Level 1 (0 points)
    Thanks for getting in touch, and sorry if you're feeling parrot-like!

    I'm afraid that your suggestion didn't seem to work for my transition problem (although it did solve a separate problem that emerged after I submitted the question, which was that a number of my projects seemed to buggy suddenly).

    I'm sure I can work through this and figure it out though.

    Thanks!
  • Daniel Slagle Level 7 Level 7 (22,415 points)
    If it was me I would go though the whole project and remove all the transitions. Close iMovie. Then put them back.
  • SimonCowart Level 1 Level 1 (0 points)

    I am seeing this problem as well and it is incredibly frustrating. It not only happens when adding transitions now but also just when moving around clips between or within projects.

     

    I have a suspicion that since this has come up only after editing for over a year and a half on the iMovie that it is caused by some sort of odd memory problem, however I'm not sure the nature of it. I have a lot of projects still in iMovie and a lot of Events to match those projects. Am I running iMovie out of memory or something?

     

    This is essentially made working with iMovie impossible at the moment and is really irritating. I have not cleared the cache as I haven't a clue how, but I will run a permissions check.

     

    Any other clues? Anyone??

  • Jpbeth Level 1 Level 1 (0 points)

    I am having the same problems in iMovie and can not access transitions, photos, music or anything.  I have not had this problem at all before and I use iMovie frequently. Now I can't use it at all.  I was in process of making a movie and initially was able to insert all my still photos and use a theme.  Once I did that, the problems started.  I tried clearing the cache, fixing permissions, etc. per above to no avail. 

  • jalexromero Level 1 Level 1 (0 points)

    I am having exactly the same problem.  Up until a few days ago, everything worked flawlessly.  I tried to create a short clip (< 5 min) and when I tried to export the movie I noticed that it exported well until the 3rd transition and then the image would freeze and while the audio would continue, there was evidently a problem.   I tried removing all transitions from project and export the movie and it worked but was also not able to export the whole thing...  Then I tried adding the transitions back into the movie only to notice that the transitions menu was not working well (when you hover they should show a simple animation of how they work, but instead in my mac they show TV noise!!).   I thought it was a bug, so I tried fixing permissions, clearing the cache, etc., then I tried un-installing iLife entirely and re-installing it... nothing seems to work.   I also tried removing the different movie projects I have (don't have a lot, but about 25)... one by one, then all at the same time only leaving one - to maybe find the one that had corrupted information... but unfortunately did not find any evidence of problems there and did not solve the iMovie problem...  Anyone has any other ideas?

  • jalexromero Level 1 Level 1 (0 points)

    Found the solution. There is one movie clip that has an error - really could not find an error within the movie clip, but I cloned it (duplicated it), then deleted it, and now all movies build/export correctly including this one, everything is back to normal.   Try doing the same - go movie clip by movie clip and export it, if it does work then skip it to next one, if it does not, then start there, duplicate the whole thing, then delete the original, then export it, if it works, you're done, if it doesn't, then move on through the list until you find the problematic one... once you fix that one, all the rest will work... really weird error, I'm guessing is an index within the database or something... would be nice to hear from an iMovie programmer or expert from Apple?  hope this helps...