Previous 1 2 3 Next 104 Replies Latest reply: Aug 16, 2014 9:25 AM by mrodecap66070
Paul Monks Level 1 Level 1

Home sharing is definitely activated on both ATV2 and iTunes (v10.0.1.22), as the option to Turn Off Home Sharing is given in the Advanced tab in iTunes. However, the Home Sharing does not appear under "Device" in iTunes and the two are not linking up.

The account is set up correctly on ATV2, as I have made purchases from Apple Store through it.

Any hints on what the problem may be ?

Dell M6400, Windows XP Pro
  • Harper101 Level 1 Level 1
    I have the same problem. I wish...

    ...I could JUST get my ATV Gen. 2 to recognize my iTunes library. Home sharing is ON on both. Haven't been able to watch my own media in a couple of weeks (very frustrating). Everything else on ATV works just fine. My only workaround has been to hook up my 1st Gen. ATV to watch the movies I have in iTunes.
  • winniemac Level 1 Level 1
    Just got a ATV2 and am experiencing the same problem with home sharing not linking up. Seeing both the ATV2 and iTunes network on my iPhone. Very peculiar. Any help would be appreciated. Thanks!
  • Matt Larson2 Level 1 Level 1
    I've had this problem several times too. Try turning off home sharing in iTunes, and then turn it back on. Mine will always come back afterwards.
  • Azsrr Level 1 Level 1
    Look through the forums -- there are tons of threads on this same problem. For me, I get everything set up and working, and then a few hours later the ATV can no longer see my iTunes library. It is setup correctly, and it actually works for a few hours after I reset everything. But then it drops the share. The only way to fix it is to turn off sharing on the ATV and iTunes, reboot everything and re-set it up. Very frustrating.
  • Darmstadtoasdkoaskdopaksdpoaks Level 1 Level 1
    Same problem on my new Apple TV.
    I have tried to turn it on and off, I have tried to reboot, tried to reinstall and so on. Everything is set up correct, I find the accounts on the iPhone and can control them, Apple TV cannot see the iTunes libary.
    Not ok, this need to be fixed!
  • Randy Macon Level 1 Level 1
    I'm experiencing that same issue. My itunes upgraded today and since then the itunes library disappeared from the app called Remote. I also bought the new apple tv (gen 2) today. Everything works beautifully except it won't recognize my itunes library via home sharing even when my imac is on and itunes is open. Itunes 10 doesn't recognize the apple tv gen 2 either... I dont even have the option to use the tv as a remote speaker.

    I don't think this is user error but if anyone has suggestions on troubleshooting please let me know. I've attempted the basics... Turning home sharing on/off several times... Changing passwords... Unplugging /reseting the apple device... Nothing has helped so far.
  • David id DC Level 1 Level 1
    Just bought my ATV2 on Friday. Hooked it up and was able to access my iTunes Library on my iMac just fine. I even watched a movie in my library. Came back the next day, and ATV2 can no longer access the library on my iMac. I've checked, re-checked and checked everything again. Home Sharing is turned on for both devices. My MacBook and iPhone Remote both recognize that Home Sharing is on in iTunes on the iMac, but ATV2 just simply refuses to see it. ATV2 can see my notebook, but not the desktop. Been trying all weekend to get it to work.

    I am so frustrated that I'm taking ATV back on Monday morning. Maybe I should have gone with GoogleTV, but I so wanted to us Apple TV.

    Message was edited by: David id DC
  • Pete Kroner Level 1 Level 1
    Mac OS X
    Apple TV works great... for a while butthen seems to turnitself off and the TV receives no signal... Is this what it is supposed to do... turn itself off after a period of time?
    Also, while watching ATV I started to upgrade several Apps on my iPhone... naturally through iTunes, too. When i returned to the TV the Apple TV was off and there of course was not signal from my Computer. Is this expected... can iTunes upgrade to an iPhone AND continue streaming from my computer (local drive iPhoto pics.)
    So far I like it very much... but i guess I may have to wait for all the books to be printed and sold through Barnes and Noble! ;>
  • David id DC Level 1 Level 1
    Finally solved this issue for me! Turns out it was my Intego VirusBarrier X6. After my initial use of ATV2 and accessing the iTunes library on my iMac, VirusBarrier began blocking the IP address of the ATV on my iMac to prevent a perceived data flood. All I had to do was open the Anti-Vandal tab within VirusBarrier and identify the ATV's IP address as trusted. (The ATV IP address is found under Settings-->General-->Network.)

    Thanks to an earlier post by CaptPulver.
  • RichardFosse Level 1 Level 1
    Thanks - have been banging my head against the wall for days. VirusBarrier was the answer. As you indicated it was blocking the ATV as a connection flood. Have unblocked the ports and BINGO.
  • JayOfTheFalls Level 1 Level 1
    Same prob, home share setup, but ATV2 won't recognize my itunes library. Worked well the first month recognizing it just fine, but now nothing. I've reset it a bunch of times (computer and unit), and turned HS off and back on which used to work, but now that doesn't even do the trick. Apple this isn't cool, please fix ASAP!
  • Pete Kroner Level 1 Level 1
    Mac OS X
    I found that home sharing, iTunes and the computer each need to be "on" and probably any "sleep" settings should be turned off. ATV needs continuous and uninterrupted signals from the computer... it's fun when it works....
  • JayOfTheFalls Level 1 Level 1
    Yes. It was fun while it lasted (which was about a month). Home share stopped working for me before, but a reset would get it going again. Now it's been a couple days and nothing! I even opened the ports thru my firewall per the Apple troubleshooting guide, but that didn't help (and I never messed with the ports before and HS worked before). So much for this device.
  • JayOfTheFalls Level 1 Level 1
    Latest update I finally got ATV2 homeshare working again. Now it wasn't the 4.1 update, or a complete restore, or unplugging, turning HS on and off on the device and computer, restarting the computer, or opening the firewall ports on both the desktop and router as Apple troubleshoot describes, because none of that worked.

    What finally did the trick was going into my router, and _*turning off the QoS (quality of service) protocol.*_ I had to turn it off completely, and voila! the homeshare lit right up.

    I hope this can help someone out there when "restarting and hoping for the best" doesn't work anymore.

    Best regards.
Previous 1 2 3 Next