Previous 1 2 3 4 Next 104 Replies Latest reply: Aug 16, 2014 9:25 AM by mrodecap66070 Go to original post
  • jsimpohio Level 1 Level 1 (0 points)
    Same problem. My ATV works for a while and then when I come back the next day it is not recognizing my library. I turn computer on and Home sharing is on. I have to turn Home Sharing off and back on to make it work again. Any thoughts? This is a pain to reset every time I want to watch something.
  • Vassillios Level 1 Level 1 (0 points)
    Everything was working hunky dory for me until ATV 4.2 came along...now nadda! POS!
  • Steve'sMAC Level 1 Level 1 (0 points)
    Hey, thanks for this tip. I was having a similar problem with the 4.1 update to ATV2 seemingly "killing" Home Sharing. Instead, it was my Intego VirusBarrier blocking under the Anti-Vandal tab the IP address the ATV was using. Two different blocks occurred (when I switched IP addresses in prior attempts to fix the problem): first was a perceived data flood; then when I switched IP address I got a block due to a "port scan".
  • IanMcKay Level 1 Level 1 (0 points)
    Thank you so much - I have been frustrated for days - tried everything - when I turned off QoS on my router I too now have homesharing working - fingers crossed it stays that way!
  • JayOfTheFalls Level 1 Level 1 (10 points)
    Great! I'm glad that turning off the router's QoS worked for you too! I know how frustrating this was for me too when my home share wasn't working!
  • steevregal Level 1 Level 1 (0 points)
    My ATV2 worked fine the first day and then it stopped recognizing itunes. After doing the restores and reboots several times with no success I read a post that suggested tweaking my firewall. Sure enough when I looked at the firewall itunes was blocked by default. I unblocked it and everything now works as it should. Hope this works for you.
  • steevregal Level 1 Level 1 (0 points)
    My ATV2 worked fine the first day and then it stopped recognizing itunes. After doing the restores and reboots several times with no success I read a post that suggested tweaking my firewall. Sure enough when I looked at the firewall itunes was blocked by default. I unblocked it and everything now works as it should. Hope this works for you.
  • Coolgarriv Level 1 Level 1 (0 points)
    My ATV2 was working fine for ages but then since the update to 4.1 it has intermittently started dropping the home share with my iTunes library. For some reason now I can play the songs from my iTunes via airplay on the ATV but the ATV just doesnt pick up the home share so I can watch anything that I have in my iTunes library.

    Very frustrating!
  • JayOfTheFalls Level 1 Level 1 (10 points)
    Latest update I finally got ATV2 homeshare working again. Now it wasn't the 4.1 update, or a complete restore, or unplugging, turning HS on and off on the device and computer, restarting the computer, or opening the firewall ports on both the desktop and router as Apple troubleshoot describes, because none of that worked.

    What finally did the trick was going into my router, and turning off the QoS (quality of service) protocol. I had to turn it off completely, and voila! the homeshare lit right up.

    I hope this can help someone out there when "restarting and hoping for the best" doesn't work anymore
  • Coolgarriv Level 1 Level 1 (0 points)
    also to add to my previous post, the Apple TV has NEVER been displayed under the devices list in my iTunes, even when it was working (those were the days!)
  • JayOfTheFalls Level 1 Level 1 (10 points)
    The new ATV2 will not ever show up under the iTunes device list, so you're okay that's normal.
  • Jerry Hicklin1 Level 2 Level 2 (180 points)
    Thanks for taking the time to put this on here but, can't find that setting in my router. I am logged in and looking at all the different settings but no QoS. Thanks,
  • Jerry Hicklin1 Level 2 Level 2 (180 points)
    I am sure everyone knew this but I missed it. I had "sharing" on in itunes Preferences but did not turn on Sharing in the ADVANCE tab at the top of itunes. At least now ATV is working. Still don't see it in itunes but its playing my music and showing my photos on the tv.
  • JayOfTheFalls Level 1 Level 1 (10 points)
    Glad its working for you now, sometimes it's the simple things we overlook. Some routers don't have the QoS options and yours might be so. As far as ATV, it will not ever show in your iTunes under device list or anything. The only place I even has a ATV reference is the bottom right corner if you click the box with the triangle in it. It' references airshare and mine has the option of my computer or the ATV. I agree though and it would be nice if it would show up in a device list to confirm it's "linked" with iTunes.
  • newagemac Level 2 Level 2 (240 points)
    The new Apple TV works like any other iOS device like an iPhone or iPod Touch. It doesn't show up as a device in iTunes unless you connect it with a USB cable. I don't think that will change.
Previous 1 2 3 4 Next