1 2 Previous Next 17 Replies Latest reply: Feb 21, 2011 11:31 PM by Charles Laine
ScuseMe Level 2 Level 2 (215 points)
I thought I had worked out the problems with my Magic Trackpad and 10.6.5, but right now it looks as though 10.6.5 broke my Magic Trackpad's functionality.

After the 10.6.5 update, my Magic Trackpad is no longer recognized. I've reinstalled the Magic Trackpad Update 1.0 and also reinstalled the 10.6.5 combo, but I can't get my iMac to recognize the Magic Trackpad. I've also trashed the com.apple.bluetooth.plist as was mentioned in another thread, but that change didn't stick after a reboot.

Symptoms: When I go into the Trackpad Preference pane, I turn on my Magic Trackpad and begin the Bluetooth search. The dialog comes up with 'Found "Apple Wireless Trackpad"', but when I hit Connect, I eventually get an error - "The pairing attempt was unsuccessful". The strange thing is that if I go into the Bluetooth Preference pane, the "Apple Wireless Trackpad" shows up defined and connected. If I delete the "Apple Wireless Trackpad" pairing under the Bluetooth pane, then add the MT back in, the pairing works correctly. But as soon as I enter the Trackpad pane, all the problems start.

I've rebooted into Safe mod and tried the Trackpad Preference pane, but it still doesn't work there. I called Apple Support, and they advised me to do an archive/install of 10.6.0 from my SL DVD, then apply the 10.6.4 combo and MT 1.0 update, then try the MT out. If it works, then apply the 10.6.5 combo and try again. But this seems like a long process for something that I know worked up until the 10.6.5 release.

Does anyone have any other suggestions as to what I can try (other than reverting to 10.6.4)? I really want to keep 10.6.5 for the graphics improvements (I play Steam), so I can live without the MT until it's fixed. But I really want my MT to work.

Thanks.

24" iMac 3.06 GHz Core 2 Duo/1 TB/8 GB; MBP 17" C2D, Mac OS X (10.6.5), Parallels v5 with Win7 x64; iPod Touch 2G; iPhone 3GS (4.1); iPhone 4 (4.1)
  • 1. Re: 10.6.5 and Magic Trackpad = FAIL
    ScuseMe Level 2 Level 2 (215 points)
    This issue was caused by a failed uninstall of the USB Overdrive program. Even though I ran the provided uninstaller, it did not delete com.usboverdrive.driver.installer.bom, com.usboverdrive.driver.installer.plist and com.usboverdrive.settings.plist . When I manually deleted these and restarted, the Magic Trackpad preferences were back.

    I hope anyone who has a problem with their Magic Trackpad looks toward 3rd party mouse utilities, in particular USB Overdrive.
  • 2. Re: 10.6.5 and Magic Trackpad = FAIL
    cheeseb Level 1 Level 1 (20 points)
    I had exactly the same problem on 10.6.4, and now it still exists on 10.6.5. I am able to get my Magic Trackpad working again simply by shutting down and restarting under 10.6.5, but then it stops working if I leave my computer alone overnight or while at work.

    I long ago removed all USB Overdrive components, but the problem persists.

    As a side effect, I notice that iTunes stops recognizing my iPhone 4 with latest iOS when the Magic Trackpad stops working. When I get the Magic Trackpad working again, iTunes again recognizes the iPhone. The iPhone is connected via the USB cable, and BlueTooth is turned OFF on the iPhone. This suggests a possible USB issue, in addition to the obvious possible BlueTooth issue.

    Under 10.6.4, I sometimes had to shut down and reboot several times, and remove all user and local preference panes, before the Magic Trackpad would start working again. Sometimes I noticed that the BlueTooth preference pane had disappeared from System Preferences, which it is supposed to do when it detects no pairable BlueTooth devices nearby. Replacing the Magic Trackpad's batteries, turning it off and on, etc., make no difference.

    I suspect a software conflict somewhere, but despite considerable exploration I have found nothing. Monday, I'm going to ask Apple to replace my Magic Trackpad (because, really, I can't live without it).
  • 3. Re: 10.6.5 and Magic Trackpad = FAIL
    Roger Wilmut1 Level 9 Level 9 (65,525 points)
    The conflict between the Magic Trackpad and USB Overdrive is rather annoying: I actually got one and then discovered the conflict and returned it for a refund. I need USB Overdrive as I have a trackball which needs to be left-handed, and also is set up for various special functions using USB Overdrive; I was hoping to have the trackpad on the right for inertial scrolling etc. Ah well.
  • 4. Re: 10.6.5 and Magic Trackpad = FAIL
    ScuseMe Level 2 Level 2 (215 points)
    I feel your pain

    I was experimenting with USBOverdrive to take out the wild cursor movements when using my Logitech and Radtech mice in Steam for Mac. USBOverdrive seemed to temper my problem, but I can't live without my Magic Trackpad.

    The way I found out that USBOverdrive was the culprit was to search my logs for "usboverdrive". Once I saw the messages in there (even thought I did an uninstall), I went looking for anything with usboverdrive in the file name. Deleted, rebooted, and all was well again with my MT.

    Subsequently, I found a great Preference pane that enables you to adjust the response curve - Mouse Acceleration Preference Pane. After running it and setting the curve to -1.0, my mouse is behaving itself again (coming from a long-time DOS/Win FPS gamer, playing again for the first time on a Mac has been a frustration for me).

    Have you tried Steermouse with your trackball? I've never used it, but it seems to be liked in Steam (along with the ubiquitous USBOverdrive).
  • 5. Re: 10.6.5 and Magic Trackpad = FAIL
    ScuseMe Level 2 Level 2 (215 points)
    Did you scan your drive (Finder search - enable System file inclusion) for the USBOverdrive files I mentioned in my 2nd post? Like I said, I uninstalled USBOverdrive and rebooted, but all the files weren't removed.

    And I echo the "I can't live without it". Inertial scrolling is da bomb
  • 6. Re: 10.6.5 and Magic Trackpad = FAIL
    cheeseb Level 1 Level 1 (20 points)
    I was convinced that I had already removed all USB Overdrive files, but I searched again anyway -- and I found 5 of them! I deleted them, and after 24 hours my Magic Trackpad is still working. I will post again if it fails, so if you don't hear back from me here you'll know this cure worked.
  • 7. Re: 10.6.5 and Magic Trackpad = FAIL
    ScuseMe Level 2 Level 2 (215 points)
    That's great! Hopefully it'll remain good for you; it has for me (after a few more trial reboots).

    p.s. - I hate rebooting
  • 8. Re: 10.6.5 and Magic Trackpad = FAIL
    cheeseb Level 1 Level 1 (20 points)
    I am sad to report that removing all the USB Overdrive components did not solve the problem. I came back to my computer after a dinner break, and the Magic Trackpad is no longer working. So it obviously is something apart from the USB Overdrive conflict. I have a bunch of Console.app log messages showing problems with Bluetooth and Trackpad during that period.

    I will start pressing Apple for a solution tomorrow.
  • 9. Re: 10.6.5 and Magic Trackpad = FAIL
    ScuseMe Level 2 Level 2 (215 points)
    Sorry to hear that. Just another thought, have you tried reinstalling the Magic Trackpad update and rebooting?
  • 10. Re: 10.6.5 and Magic Trackpad = FAIL
    cheeseb Level 1 Level 1 (20 points)
    Reinstalling the Magic Trackpad update did not help.

    But I believe I have finally found the root of the problem. There are discussion threads all over the place about the Bluetooth menu extra suddenly having a squiggly line through the icon and a single menu item saying "Bluetooth: Not Available." This always happens to me when the Magic Trackpad stops working, and the Bluetooth preference pane also disappears from System Preferences. Surely the loss of Bluetooth capability on my Mac Pro is the cause, not a symptom, of the Magic Trackpad ceasing to work.

    The recommended cure on the discussion threads is to unplug the Mac and all USB devices and leave them unplugged for a couple of minutes, then plug the Mac back in, reboot, and then plug the USB devices back in. I did this, and Bluetooth is now back, and the Magic Trackpad once again works.

    The only question is, how long will this continue to work? There have been stories for years about flaky Bluetooth hardware support in many Mac models. I'm really not interested in a new motherboard.
  • 11. Re: 10.6.5 and Magic Trackpad = FAIL
    ScuseMe Level 2 Level 2 (215 points)
    I'm glad you got it sorted out. Hopefully permanently!

    Once a couple of years ago I had a problem with my bluetooth Apple keyboard not functioning. A couple of the things that the Apple tech said to do was to unplug everything from my iMac, pull out the power cord from my iMac (not the wall, the iMac itself), wait a couple of minutes, then plug everything back in again. Also, he had me clear the PRAM. Once I did these things, my bluetooth keyboard worked fine.

    My solution sounds a lot what you encountered. I've never had a problem since.
  • 12. Re: 10.6.5 and Magic Trackpad = FAIL
    cheeseb Level 1 Level 1 (20 points)
    The recommended cure on the discussion threads is to unplug the Mac and all USB devices and leave them unplugged for a couple of minutes, then plug the Mac back in, reboot, and then plug the USB devices back in. I did this, and Bluetooth is now back, and the Magic Trackpad once again works.

    The only question is, how long will this continue to work? There have been stories for years about flaky Bluetooth hardware support in many Mac models. I'm really not interested in a new motherboard.


    I am pleased to report that, after several days of heavy use, my Magic Trackpad is still working without problems. Also, iTunes always recognizes my iPhone. So unplugging the Mac and all USB device cables for a minute or two appears to be a real cure.
  • 13. Re: 10.6.5 and Magic Trackpad = FAIL
    Brady Johnson Level 1 Level 1 (45 points)
    Had the same problem, tried everything suggested in this thread without any luck. I've never used USB Overdrive, so that wasn't it. I was pondering the disparity between the various indicators - Bluetooth panel says "connected" with green light, Trackpad panel says "paired by can't connect', and the Bluetooth menu item shows the trackpad even when the Trackpad panel says there isn't one. Then I took the missing step, and it all worked.

    I can't be sure that it wasn't the repeated restarts, shut downs, and all that. But here are the last few things I did that ended with success.

    Turned off all bluetooth device, including the trackpad.
    Reinstalled the Magic Trackpad software.
    Restarted (which is the last step of the reinstall anyway)
    Make sure the Bluetooth menu is enabled (open the Bluetooth panel and click the box at the bottom for "Show Bluetooth status in the menu bar".)
    Pulled down the Bluetooth menu item
    Select "Set up Bluetooth device" (this was the step I'd been missing)
    Follow the instructions.

    That's what did it for me.
  • 14. Re: 10.6.5 and Magic Trackpad = FAIL
    Brady Johnson Level 1 Level 1 (45 points)
    Naturally, in my post I left off the "turn bluetooth items back on" step. /facepalm

    Did that after the restart.
1 2 Previous Next