Previous 1 4 5 6 7 8 Next 116 Replies Latest reply: May 28, 2014 9:50 AM by RPTB1 Go to original post
  • tjlav Level 1 Level 1 (0 points)
    I am having the same issue with Itunes. It no longer checks for app updates even though my phone is saying they are available. I can update through the phone which I have been doing for 2 weeks but some programs are over 20MB and need the computer and or wireless (which I do not have).

    I have tried the log out of store, restart Itunes and log back in with not success. I take it apple does not monitor the forums?!?!?
  • tjlav Level 1 Level 1 (0 points)
    I figured out my problem after reporting the problem to iTunes support.

    Something hid the apps icon from my library, I went to Edit/Preferences and on the general tab was my problem starring me in the face. Under the sources section my iTunes U, Books and Apps were unchecked. I checked apps closed the program and restarted it and it was showing I had updates and I was able to update from there.

    I am not sure how many of you are having this problem and I do hope this is able to help at least 1 of you
  • TMM66 Level 1 Level 1 (0 points)
    I had similar problem to those listed in previous posts. No app updates showing in iTunes. No app updates showing on either of our 2 iPads and no app updates showing on iPhone.

    I deleted (kept the files) all of the apps in iTunes one by one. Each time checking to see if update would work. Got all the way down to one app and update still didn't work. I didn't have any of the offending apps that were listed in previous posts.

    I ran the iTunes diagnostics under the help menu. Everything reported fine. I was going to give up so I went to download updates on my iPhone. Pulled up App store, selected updates. They all showed up on the list. So everything on the phone looked perfectly normal. I treid to start the download and received a message that the update were large so I should turn on my WiFi. I turned on the iPhone's WiFi, wnet back to the App Update page and now I received an error that it couldn't connect to the app store. Then I turned WiFi off and the updates appeared. I connected to my neighbor's WiFi and everything worked fine.

    I rebooted my cable modem and router but that didn't fix it. All other wired and WiFi traffic works fine. Then I reset my router to factory defaults. Still no happiness. Finally I unplugged a USB drive I had connected to the router (LinkSys WRT600N Storagelink) and suddenly iTunes and the iPads could see the updates. I don't know why, just that it fixed the problem. Strange but true......
  • Orion512 Level 1 Level 1 (0 points)
    After updating apps from my iPad for a couple months, and poking around this forum for a while, I finally fixed the problem. iTunes on my MBP has been giving me an "iTunes server down. Please try again later" error every time I tried to update my apps. Every other online function of iTunes was working perfectly.

    I tried everything from logging out of my account in iTunes, deauthorizing, and finally reinstalling iTunes. Nothing worked until I stumbled across a post about Appshopper causing an issue, one of my more frequently used apps. I was skeptical at first, primarily because all of my other iOS devices with Appshopper installed were updating just fine. I finally deleted the app (along with a couple other infrequently used apps) from iTunes. Nothing initially seemed to have changed. But then the next day, POOF! iTunes has 37 new updates.

    It is ridiculous that a version of one app can cause such an annoying problem!
  • puckknot Level 1 Level 1 (0 points)
    iTunes 10.2 newly update no longer correctly updates my calender, no longer updates installed apps and no longer syncs my ical application=all calendar info was erased after the 10.2 update...
  • Orion512 Level 1 Level 1 (0 points)
    After an extensive reinstallation, etc of iTunes, I was having spotty connection issues again while trying to update my iOS apps. It would always work at other wifi hotspots such as Starbucks, but rarely at home. The problem, I discovered, was my constantly denying random AirPort Base Station network connections to ".akamai.net" servers. Not that there was any rhyme or reason to the timing of these connection attempts, once I started allowing these connections to go through, I no longer had an issue with my iTunes updates.
  • PSI70Y Level 1 Level 1 (5 points)

    I had this issue the last couple of days and it was driving me nuts.

     

    The app "Pregnancy Tracker from Whattoexpect.com" is causing this as well.

  • valfran Level 1 Level 1 (0 points)

    I had exactly the same problem. Check for updates wasn't working. I tried reinstalling itunes, formatting computer without success. Finally I saw this tip above. Then I deleted "Pregnancy Tracker from Whattoexpect.com" app and everything is working again.

  • pedromendonca Level 1 Level 1 (0 points)

    I had the same problem, deleteting this app made itunes complete the "Check for Updates" verification for the apps.

  • MarkBebb Level 1 Level 1 (0 points)

    +1 for deleting Pregnancy Tracker! Hmmm, seems to be a problem Apple...

  • PSI70Y Level 1 Level 1 (5 points)

    Pregnancy Tracker just received an update which removes this problem

  • RPTB1 Level 1 Level 1 (0 points)

    I just had this problem in iTunes 11.2.1.

     

    It turned out I was not signed in to the iTunes Store.  Instead of iTunes *telling* me this, it just silently said there were no updates.

     

    Just select the iTunes Store and make sure you're signed in.

     

    Once I did this, I started receiving updates.

Previous 1 4 5 6 7 8 Next