Skip navigation
This discussion is archived

Clearing the DNS Cache

2722 Views 5 Replies Latest reply: Nov 13, 2010 12:05 PM by xnav RSS
tparis0022 Calculating status...
Currently Being Moderated
Nov 12, 2010 6:04 PM
I having problems clearing the DNS Cache - I have recently uploaded a website to xposem.co.nz. However, it works on everyone elses computer put mine... I have found out this is due to the DNS Cache needing to be cleared. I am using Snow Leopard 10.6.4 and I have located the program Terminal and typed in 'dscacheutil -flushcache' - it seems to have accepted the command but it still does not work.. Any advice?
MacBook Pro, Mac OS X (10.6.4)
  • Mihalis Tsoukalos Calculating status...
    Currently Being Moderated
    Nov 13, 2010 7:53 AM (in response to tparis0022)
    The command you used for clearing your DNS cache is OK.
    I think that you should use the host command for some troubleshooting.

    Mihalis.
    iMac 3.06Ghz, Mac OS X (10.6.5), http://widgetbook.blogspot.com
  • xnav Level 5 Level 5 (6,625 points)
    Currently Being Moderated
    Nov 13, 2010 8:09 AM (in response to tparis0022)
    You have something mis-configured on your server. Using xposem.co.nz, I get your web page. DNS lookup gives your IP as 203.170.87.185. If I used that to try and get to your web page I get the cPanel default page hinting at a DNS error.
    Does your server listen on the standard HTTP port 80?

    Message was edited by: xnav
    Mac Pro 2x3GHz Dual, Mac OS X (10.6.5), BlueTooth Kybd, MagicMouse, Trackpad, BootCamp WinXP, WRT54G, iPhone, TV
  • xnav Level 5 Level 5 (6,625 points)
    Currently Being Moderated
    Nov 13, 2010 10:04 AM (in response to tparis0022)
    I used WireShark to verify that specifying xposem.co.nz does result in communication with 203.170.87.185:80. My guess is that you are using a service that supports multiple domain names and the URL entered is used to direct the correct page back to the user. For some reason when you use 'xposem.co.nz' on your web browser the correct name is not getting through to the service, and you get the default error page. Try a different browser from your same user ID, or try a different/new user ID on your system.
    Mac Pro 2x3GHz Dual, Mac OS X (10.6.5), BlueTooth Kybd, MagicMouse, Trackpad, BootCamp WinXP, WRT54G, iPhone, TV
  • MrHoffman Level 6 Level 6 (11,720 points)
    Currently Being Moderated
    Nov 13, 2010 10:56 AM (in response to xnav)
    It's probably an Apache Virtual Host (what Apple calls Sites) setting; the displayed web site selection is based on the domain substring within the string sent over from the browser, rather than anything to do with DNS.

    Server Admin > select the target server > Web > Sites...
  • xnav Level 5 Level 5 (6,625 points)
    Currently Being Moderated
    Nov 13, 2010 12:05 PM (in response to MrHoffman)
    Yep!
    Mac Pro 2x3GHz Dual, Mac OS X (10.6.5), BlueTooth Kybd, MagicMouse, Trackpad, BootCamp WinXP, WRT54G, iPhone, TV

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.