Previous 1 2 3 Next 43 Replies Latest reply: Jul 31, 2014 11:04 AM by ralphy
Lionel-Oxon Level 1 (0 points)

Have just bought wife Ipad. It will find the wifi network on my Imac, it shows that it is connected, but will not connect to Internet.

Ipad works fine on 3g, as we are home want to use wifi from my Imac.

On Safari on Ipad get message "Safari cannot open the page because it is not connected to internet"

Have the icon at the top left of screen showing that wifi is getting a signal. Password is correct. Have also tried after set the airport on desktop not to request a password and this makes no difference.

Have been Googling all morning and it seems that this has occurred in the past with other users, but so far unable to find an answer.

Apple Support not working Sunday in UK.

Any suggestions please?



iMac, Mac OS X (10.5.7)
  • Philly_Phan Level 6 (13,226 points)
    Did you turn on Internet Sharing on your Mac?
  • Lionel-Oxon Level 1 (0 points)
    Yes have turned on Internet Sharing.

    Status shown as Connected. Green Spot to show turned on, It shows Self Assigned IP

  • Anthony J Howe Level 4 (1,150 points)
    Have you tried resetting your settings on the iPad?
    Settings>General>Reset>Reset All Settings

    Maybe rebooting the Wifi router and iPad also, might help.
    It could also be some app perhaps on the iPad preventing access to the Internet.
  • Level 8 (41,760 points)
    This is discussed in this Apple article:

    This has also been a discussion topic on here about a month or two ago.
  • Lionel-Oxon Level 1 (0 points)
    I have reset the Ipad and rebooted the router, earlier today, have tried again, still no connection.

    Thanks for link to

    Unfortunately this does not help as it does not refer to anything that have not already checked.
  • Lowell Tuttman Level 4 (1,350 points)
    I suspect the problem lies with the self assigned IP address. Open the network preferences from the airport icon on your main computer. Click on the advanced tab on the bottom of the page. Click on the TCP/IP tab and make sure you are using DHCP. Then redo your ipad network settings to use dhcp also, and that should work.
  • Lionel-Oxon Level 1 (0 points)
    Thanks for reply, it's already set at Using DHCP. The Ipad found the settings and shows connection, but not one that will connect when checking the connection with a google search.

    In the end I switched off the Airport that is built into my Imac, and used an Airport plug in base station, wired to my router by cable.

    This is working fine, just by using the Airport Utility program to set it up.

    I gave up on trying to set up the built in airport in the Imac.

  • grimstad Level 1 (0 points)
    I have the same problem with two iPads, purchased for two school children. The Linksys network has always worked fine for both the parent's PC and the kids old Mac, but the iPads show a strong signal and accepted the password, but Safari says it is not connected to the internet. The iPads worked fine on my home Airport Extreme network and at another family member's generic pc network.

    The suggested articles do not seem to address this problem at all.
  • Graham Outterside Level 4 (2,910 points)
    Manually put your ISP DNS servers into the network connection details but leave the IP address assigned by DHCP - normally fixes most problems like yours.
  • TashTish Level 1 (15 points)
    An iPad bought a few days ago connected fine to a Linksys (Cisco) router, then yesterday refused to negotiate a valid IP address via DHCP handshake. No amount of resetting, restarting, or rebooting--even restoring--either the router, cable modem, or iPad resulted in success. (This included forgetting networks and renewing leases.) All other devices in the network connected and re-connected flawlessly; conversely, the iPad would connect to other wi-fi networks.

    The router was put through several changes, including choosing only 11g devices, and changing transmission channels & SSID names. Finally, what worked a mere seconds ago, was changing the security protocol from WPA2/AES+TKIP to WPA/TKIP (only). That kickstarted the iPad into a valid IP address. In a fit of impulsivity, I changed the security BACK to WPA2/AES+TKIP and then to AES (only), and the iPad continues to connect appropriately, even after awakening from sleep mode.

    I'm not sure what happened, but my guess is that the IP lease expired, and the iPad refused to negotiate a new address with the router, until the security change forced something loose. In any case, this seems to be a prevalent issue, judging from the number and breadth of threads clamoring about this issue in many forms, so this just a note of what worked for me.
  • Ryan Vetter1 Level 2 (460 points)

    This is the answer. I can't find where to mark it as an answer. I selected the blue arrow next to the Wifi name on my iPod Touch, and was able to see the advanced settings, like IP Address, whether to set it as DCHP, etc. In there, I touched the field next to DNS Server. Sure enough, it did not match what was showing in my Network Pane in System Prefernces on my Mac. I copied my DNS Servers (yes, I had 3 listed) into the field on the iPod Touch next to DNS Server. I separated each value by a comma. I then entered, also, a domain name that was listed on my Mac under the Network Pane next to "Search Domains" on the iPod Touch next to "Search Domains".

    Bingo, it now works. Before, without these values manually entered in, I could see I was getting a Wifi signal, and it was like I was connected, but I could not call up any pages online.


    Now, the Internet works on my iPod Touch via a Wifi hotspot being transmitted from my MacBook Pro connected via an Ethernet cable to our cable modem. I also just did the same thing to an iPhone and now it works too.


    Confirmed working, try this for a solution!


    Looks like iOS doesn't completely play nice here by having all these values populate over to your iPad/iPod/iPhone. So some manual labour may be needed.

  • Baronia Level 1 (0 points)

    The same thing happened to me. My iPad2 was in good working order for some months until I decided to go surf at Starbucks. When I got back home, all **** broke loose. I can connect to my wifi network, my DropCopy app could see my iMac but when I use Safari, it just doesn't want to take me to the internet!


    I tried to copy the DNS settings from my Mac, that didn't work, I rebooted my router- nope, I reset my router's security settings- same response, I switched off my iPad, turned my Wifi on/off, swtiched 'Airplane mode', Cleared Cookies/Cached/History for Safari- all in vain.


    Then, I went to my iPad's Settings-> General -> Reset -> RESET NETWORK SETTINGS


    This sent my iPad2 back to its friendly, happy self again. My wife suggested this. We're all happy now

  • Ryan Vetter1 Level 2 (460 points)

    I don't think this is the answer. Your problem sounds overly complicated and there's not enough information to determine that reseting network settings is an answer to the OP. Yes, if all else fails, reset network settings, but I doubt that'll help people in the OP's situation, and here's why:


    I can confirm in different locations on 2 different iOS devices (iPod Touch 4g and iPhone 4) that you have to manually populate the DNS servers and domain search fields in the network settings on the iOS device when you're using a computer as a wifi hotspot. And this has happened to brand new iOS devices I've had as well, so it was the first network they were ever on.


    The problem: the network settings as shown on the computer's network settings pane weren't all populating over to the iOS devices and therefore, the iOS devices could not connect to the Internet, even though they had signals.


    This is a software problem that Apple will need to look into to make sure all network settings get populated over to iOS devices. I doubt it happens to all set ups... In the offending set ups, there were 3 DNS servers and 1 domain. It might be that any more than 1 DNS server listed on the computer as part of the network doesn't populate over. But the search domain didn't populate over either so definitely things are populating over to iOS.

  • navg8or03 Level 1 (0 points)

    i bought six new ipad 2 (ridiculous?) these are all graduation gifts for my dear teen agers. all of them successfully connected to wi-fi but cannot connect to the internet. Solution is simple.: 1) go to settings 2) tap MAIL, CONTACTS, CALENDARS, 3) select ADD ACCOUNT, 4) SELECT MOBILEME. CREATE AN ACCOUNT (WHICH IS YOUR APPLE ACCOUNT OR CREATE A NEW ONE IF YOUR WIFE HAS NO APPLE ACCOUNT ACCOUNT) and just follow the prompts after soon as your new account is created you automatically connect to internet. happy surfing.

Previous 1 2 3 Next