12 Replies Latest reply: Jan 20, 2014 11:44 AM by sk1ngy
pomme4moi Level 1 Level 1 (35 points)
Hi. My ATV2 has been working correctly, but today when I try to rent a movie I get this error message on my television screen: "Your password has been incorrectly entered too many times. Go to the iTunes store on your computer and retrieve your password."

Does anyone know how to go to the iTunes store and "retrieve a password"? As FYI, I did change the password on my Apple account yesterday. I then went into iTunes, turned off home sharing, then turned it back on using my new password.

Thanks for your help!

MacBook Pro, Mac OS X (10.6.2)
  • 1. Re: "Password entered too many times"
    Chenks Level 5 Level 5 (7,420 points)
    pomme4moi wrote:
    Does anyone know how to go to the iTunes store and "retrieve a password"? As FYI, I did change the password on my Apple account yesterday. I then went into iTunes, turned off home sharing, then turned it back on using my new password.


    you do it in itunes on your PC/laptop. you don't do it on the appletv.
  • 2. Re: "Password entered too many times"
    Alley_Cat Level 6 Level 6 (17,035 points)
    Might be worth unplugging AppleTv, then restarting it in case there's a bug preventing the changed password updating correctly for some reason with it being retained in RAM or something.
  • 3. Re: "Password entered too many times"
    pomme4moi Level 1 Level 1 (35 points)
    To Alley Cat: Thanks. I disconnected the ATV2, both the HDMI cable and the electrical cable. I then plugged them back in but same problem.

    To Chenks: Yes, I understand that I need to go to the iTunes store on my computer, and not on the ATV2. But once in the iTunes store, I don't know how to retrieve a password. I don't see any option of that type within my account settings, and typing "password" or "retrieve password" in the help box produces no hits. Do you happen to know where exactly to find the "retrieve password" option in the iTunes store?

    Thanks
  • 4. Re: "Password entered too many times"
    Damitri Level 1 Level 1 (0 points)
    I am in the same situation as you. Thought I would be Mr Safety so I updated my password to something longer. Ever since my AppleTV keeps telling me to retrieve my password in iTunes. If I go to my computer and reset the password to something new and then put in the new password on the AppleTV the problem goes away for 30 min but then pops up again. What is weird is that I can just click OK whenever it asks for the password and continue using my AppleTV. Everything works it is just annoying to be interrupted by that warning all the time.

    I regret changing my password in the first place...
  • 5. Re: "Password entered too many times"
    Damitri Level 1 Level 1 (0 points)
    Did a quick search on this forum and found this thread: http://discussions.apple.com/thread.jspa;jsessionid=D32B3B0F08035607412A7B1079A4 A44D.node0?messageID=12559601&#12559601

    The solution seems to be to go into Settings->General->iTunes Store and log out. Then just log back in with your new password. Works for me so far. Let's hope it lasts more than 30 min this time!
  • 6. Re: "Password entered too many times"
    laner19 Level 1 Level 1 (0 points)
    I was having the same problem. Tried entering the password several times after signing out but no luck. I did not want to change my password so I was looking for other options. I then tried entering my MobileMe ID (ie @me.com instead of @mac.com) instead and it worked!

    I then went to iTunes and tried logging into the iTunes store with my .me ID and it worked but displayed the account as my .mac ID (I don't believe it did this before).

    I had the older .mac account and was converted to a .me account when they switched the flip on MobileMe. At the time I was hoping I could use my new .me account for my iTunes Apple ID but they would not allow this. Maybe they have enabled the linking now based on what I've seen with my login tests???
  • 7. Re: "Password entered too many times"
    pomme4moi Level 1 Level 1 (35 points)
    Thank you. The Settings->General->iTunes Store->log out trick seems to work!
  • 8. Re: "Password entered too many times"
    c.h.r Level 1 Level 1 (0 points)
    I've been having a similar problem.

    I get the "your password has been incorrectly entered too many times. please go to the itunes store to retrieve it".

    I know what my password is, and I changed it again just to be safe (verifired in the iTunes store, changed at iforgot.apple.com)

    However, I have no option to do anything with my appleTV except click "ok" and then it just pops back up with the same error on the screen. I am completely locked out of the AppleTV so I am unable to sign off and on in settings>general, etc...

    I am able to use AirPlay to stream music from my computer via the AppleTV, however the only UI i have is the one on my computer - the appleTV remains completely inaccessible and stuck at the error message.

    Anyone seen this situation before? Where the AppleTV is telling me to verify my password; however once verified, I have no way to enter it on the TV? Any help at all would be appreciated
  • 9. Re: "Password entered too many times"
    stormhaus Level 1 Level 1 (0 points)
    I finally figured this out! It has nothing to do with the iTunes account on the computer, but make sure your apple ID is working before trying this on your Apple TV

    Here is what worked for me:

    On the *Apple TV:*

    1. Go to Settings
    2. Go to General
    3. Go to "iTunes Store"
    4. Click Sign Out
    5. Sign back in with the correct one again

    Finally a resolution for me on this.
  • 10. Re: "Password entered too many times"
    whateveridontcare3333 Level 1 Level 1 (0 points)
    This has been driving me crazy for a couple of weeks now to the point where I finally got off the couch and looked up the solution. The error message could definitely be a bit more helpful. Thanks guys!
  • 11. Re: "Password entered too many times"
    maclovin1986 Level 1 Level 1 (0 points)
    This WORKS!!!
  • 12. Re: "Password entered too many times"
    sk1ngy Level 1 Level 1 (0 points)

    Did you ever find out how to fix this as it is happening to me