Previous 1 2 3 Next 129 Replies Latest reply: Nov 29, 2011 9:24 AM by Pierre29
Martin Jaekel1 Level 1 Level 1
Since updating to 10.6.5 (via the combo update), I experience strange DNS problems on my laptop.

After working fine for some time, suddenly no DNS names are resolved any longer.
Looks like mDNSResponder simply died.

- This happens simultaneously in Firefox, Safari & even from the Terminal.
- It happens both on ethernet, and on wifi.
- I can still Ping my DNS servers, and I can ping my machine from remote as well.
- Everything where I can still remember the IP address seem to work fine.
- Problem happened in different networks
- Nothing obvious in the console messages

It really looks like a pure DNS problem, not a network issue.
Even the Windows emulation I sometimes run on that machine keeps working and can still resolve DNS names correctly.

I repaired permissions, reinstalled the update, cleared the DNS cache... the usual.

Until now, nothing solved the problem. I need to reboot, to get dns lookup back.
This will then work for some time (in the order of hours) and suddenly I'm stuck again.



MacBook Pro 15" i7, Mac OS X (10.6.5)
  • a brody Level 9 Level 9
    Classic Mac OS
    On Intel Macs it is not emulation, rather virtualization. What this means is it is using Windows with Windows drivers on the Mac to speak to the hardware. What this states is either the DNS tables got corrupt on the Mac side, or data the system relies on for networking has gotten corrupted. It could also mean that the firmware of the router needs to be updated for 10.6.5 driver compatibility. Finally, it could mean that the driver that's on the machine is old because of how a prior installation was made. If you are using a program such as Onyx, or Cache cleaner, you can inadvertently delete important files.

    Prior installs that can create issues with driver updates when the system updates include:

    1. Migration Assistant from PowerPC.
    2. Install from a system specific disc not for the Mac model or vintage Mac in question.
    3. Target Disk Mode install of operating system.
    4. Network software such as Norton Firewall or Intego's software not up to date for the operating system install.

    A simple permissions repair or zap of PRAM can solve many a problem.

    Sometimes switching to entries on both your router and your system preferences for DNS numbers can solve issues.
  • Martin Jaekel1 Level 1 Level 1
    Thanks for the fast reply !!!!!

    Sorry, of course it's virtualization. Old habit, late hour - so I called it wrongly. But that's not the point.
    I just mentioned it to exclude the usual network problems anyhow.

    The point is that I loose all DNS lookup after same time of working.
    Without any obvious cause. The time varies between 1/2 h and now multiple hours.
    But at one point it hits me.

    The MacBookPro is a new 15" i7, which I set up cleanly when I received it around 2 month ago.
    This machine has never seen anything else the 10.6. No vintage Mac involved, no old drivers. 10.6.4 was also just fine. No Norton Firewall (it still exists ?) or other 3rd party software involved. No Onyx, Cache cleaner involved either. Just a clean combo update with repair permissions before and after the update.

    The DNS issue is NOT linked to a particular network. Happens at small network or huge research facility. Maybe more often at work then home, where I have much more bonjour connections (?).

    What puzzles me is that it works just fine for some time. And while working with the same URLs, connecting to the same servers - suddenly everything fail. No more connections in Safari, no new mails in not even a "host" in terminal works. Entering an IP directly still is fine. Just no DNS resolving until I reboot.


  • Benjamin Kuperman Level 1 Level 1
    Are you running the Firewall service? I see many, many messages in the Console that the Firewall has now decided to start blocking mDNSResponder traffic. I can't back up to my Time Capsule without disabling the firewall. Does the problem go away if you turn off the firewall?
  • teryan2006 Level 1 Level 1
    I got the exact same problem. But for me the DNS lookup comes back after about 5 minutes. Tried resetting network, flush DNS cache, combo update. Nothings seems to work.
  • a brody Level 9 Level 9
    Classic Mac OS
    Wonder if it is the same DNS issues recently found on AppleTV2? Regardless, make sure your routers are up to date.
  • raymondchua Level 1 Level 1
    I had almost similar problem too. Before the update, I able to connect to my exchange server locally through FQDN, however this morning it fails to connect out of sudden! I have to change to local IP address or exchange hostname in order to connect it. I did the cache flush but no luck
  • Loscookas Level 1 Level 1
    I have same problem!
  • jadzea Level 1 Level 1
    We are having problems here too!

    We have in our dns server CNAME aliases setup for servers. Simple hostnames work fine, or internal FQDNs.

    Problem is when we try to access FQDNs we have setup as aliases for internal names which are really external name (to make it easier for students to use just the external names even when they are in college).

    For instance, we have an internal name of server5.countesthorpe.local mapped to ip 10.x.x.x
    We have a forward lookup zone created for countesthorpe.local, but also for our external domains In this 'external' zone we have a CNAME set ( for server5.countesthorpe.local.

    It seems to me that DNS on 10.6.5 isn't looking or accepting that a domain name can be an alias for an domain or ip in a different zone.

    Please help me Apple!?!?!
  • christian.aust Level 1 Level 1
    Same for me. I've updated to 10.6.5 lately and see exactly this behavior: After starting the OS, DNS resolution works for a while, then suddenly stops.

    I can still connect using explicit IP adresses. My local DNS server runs on dedicated hardware, using tcpdump I see that DNS requests from my MBP are actually sent to the server and answered immediately. However, OSX sees nothing.

    Even more, "sudo tcpdump udp" on the MBP doesn't show anything, as if the interface was down. Before the error occurs, it happily shows all kinds of UDP requests.

    Eventually I have to reboot. Very annoying.
  • Loscookas Level 1 Level 1
    Exactly the same problem like from jadzea!

    Точно такая же проблема как у jadzea!

    Message was edited by: Loscookas
  • raymondchua Level 1 Level 1
    I wonder when will this problem be fixed. It's very annoying to change address settings every single day at work and home. Apple, please hear us and fix this ASAP. Million thanks!!
  • a brody Level 9 Level 9
    Classic Mac OS
    This is not a means of contacting Apple. It is a user to user board. A user is someone who uses the computer. It is not the developer of the software for the machine. Please read the terms of use on the right. It explains that clearly. If you wish to contact Apple:

    In the meantime, use this as your opportunity to find out how others have solved the problem by reading the entire thread. If you don't have a solution to try for the original poster, and none of the solutions offered here help, please start a new topic thread here:

    You'll get a wider audience, and won't confuse the original poster with solutions that don't apply to them.
  • Neurorad Level 1 Level 1
    Sam problem on my Mac Pro. Everything worked fine in 10.6.4, but any browsing in Safari, etc., under 10.6.5 was unusable after a few minutes after rebooting. Clearly is a DNS issue. No other machine on the network has this issue. Did all the usual, including resetting the PRAM, updating my Cisco router to the latest firmware, etc, without improvement. I finally gave up and restored to a recent 10.6.4 backup. Unfortunately, I now cannot install the latest XCode 4 beta version since it requires 10.6.5,

    Hopefully 10.6.6 will fix this!
  • DarkKent Level 1 Level 1
    This is wat happen to me. I got like a 07 MacBook pro on 10.6.5. Im also connected via ethernet an use my mac as a router sharing my ethernet connection. Everything was fine and flowing. Then 2 days ago firefox froze loading pad causin me to restart cuase it wouldn't reopen. Then it started happening on other sites. Here to... Now safari doin the same thing. Sometime locking soon as it's opened. Also now the wifi signal I output from my Mac is also stopping and starting every bout 5 mins... Thing is it just started happening out of the blue... I've tried all the so call fixes n they don't work... Everything Else Works Fine... Come On Out Of The Blue Like This... WATS GOING ON?????
Previous 1 2 3 Next