Previous 1 2 3 4 Next 54 Replies Latest reply: Jan 29, 2013 1:56 PM by Sherwood Botsford Go to original post
  • pcolvin15 Level 1 Level 1 (90 points)
    If your Drobo has iSCSI capability get off the USB or FW connections. 1st iSCSI is much much faster. 2nd if you have a crash and need to access the drive from a single user (command line) operational situation, the USB and FW are streaming serial media and not supported/mountable in that mode. the iSCSI is.

    Have update from 10.6.3 all the way to 10.6.5 and have no problem. However, I follow the procedure of running a disk verify and permissions check before I update, and again afterward. Best to run the update using the combo update, not the software update version in safe mode. If you updated via software update, then download the combo version, boot to safe mode, do the verify/permissions checks, run the install, reboot back into safe mode and re-run verify/permissions. Then reboot back to normal ops.
  • ticzon Level 1 Level 1 (5 points)
    I have now noticed that another USB2 HD that is connected on the same machine has also disconnected. I changed the cables and also moved the cables around and either both or one of my USB2 devices disconnect (a USB2 HD or my USB2 Drobo).

    I own several Drobos and noticed that the FireWire 800 Drobo has been fine with the 10.6.5 update when connected to my Mac with Firewire.

    I am almost done downgrading my MacMini back to 10.6.4 and will wait for a fix. I can't waste anymore time having to play around with my USB2 HDs and/or Drobo USB2 1st Gen.

    Is Apple starting to slip on it's quality? Are they spending too much time working on the iPhone and IPad?
  • Robert Carneim2 Level 1 Level 1 (115 points)
    At the risk of going off my own topic . . . what are you doing to your boxes that your permissions get corrupted and/or you have to boot into single-user mode so often? (At least, it seems that way---I read some of your other posts.) I've been dealing with OS X servers and clients on all sorts of hardware with all sorts of internal and external storage connections, and I haven't had to run fsck since probably 2002.

    (And as for iSCSI---I'm sorry, I didn't explicitly state which Drobo I was dealing with: Drobo. In any case, if given the option, I probably wouldn't choose iSCSI on the Mac because I'd have to install and use the 2nd party initiator instead of native drivers. Though, given my current USB problems, I'm not feeling to good about those either.)

    Anyhooo . . . it occurred to me when I noticed USBMassStorage events in my log during disconnects, that it might be a USB problem, and the server I have been having the AFP problems with has had a Drobo connected with FW800 with no problems (other than the AFP problem); and since changing the other server's Drobo connection from USB2 to FW800 yesterday, that connection has been stable too (so far). And, someone else posted that their FW800 connected Drobo has been running just fine as well. And there have been some other posts of other USB drives having connection issues.

    So, I'm going to leave well enough alone on that front and concentrate on my AFP problem.

    -Bob
  • The Duke of WIndsor Level 1 Level 1 (5 points)
    Well, it's been about a week and my FireWire 800 connection has yet to disconnect (knock on wood). I'm assuming it must be some USB thing. I would have thought USB would be stable what with it having been around since Macs had round mice and all. Oh well, I'm sticking with FireWire until further notice.

    AND I recommend everyone with this problem contact apple at:

    http://www.apple.com/feedback

    AS WELL AS Drobo at:

    http://www.drobo.com/support/contact-support.php
  • Scrobz Level 1 Level 1 (0 points)
    Same problem here though i have non server 10.6.5 edition.

    Drobo disconnects when there is heavy activity on usb.

    Datarobotics confirms problems due to 10.6.5 and advised me to use firewire until Apple has fixed this issue
  • pcolvin15 Level 1 Level 1 (90 points)
    Since when is covering best practices where called for an indications that my permissions are always corrupted or problems that I have to boot into single-user mode regularly? These forums are here to help users. Do you send the same type of posts to Mr. Hoffman whose staff takes a ton of time to help users properly set up DNS and the more intricate services of SNL?

    3rd party drivers are a way of life. We get them when we use anti-virus programs, databases, and many things that extend OSX (such as kvms, track balls, cell modem cards). Data Robotics has done a fantastic job of fixing the usability and stability of their driver sets for their hardware this year. Going back on topic, I, too, have had AFP problems in my server farm, which appeared first with the LaCie Quad units we ran under FW800 and then with the DroboPro under USB and FW. Interestingly enough, our AFP problem went away when we moved our Drobos to iSCSI. This points toward bus speed latency, i/o handling prioritization, or write cache corruption with the slower busses that needs to be looked at when researching what is causing the problem to occur.
  • Robert Carneim2 Level 1 Level 1 (115 points)
    No worries . . . to each his or her own. For my part, I try to minimize complexity and fidgeting when I can to maintain stability and reliability. The reason I’m in the fix I’m in now, is that I got a little bit complacent—I’ve never had a problem with Apple's security and incremental updates (heck, even Windows and other OSes’ updates), so I’ve waited less and less time each time before starting to apply these updates to my systems, and stopped keeping a way to back out of such updates (virtual machine snapshots for Windows and Linux servers has spoiled me [come on Apple, let me run on ESX!]).

    Till now, I’ve always read other people's “latest update broke my such-and-such” posts with a slight air of smugness, because most of the time, it is other products and non-standard configurations that are affected. Well, no more.

    Anyway, I’m happy enough running the FW800 instead of USB2 on that one machine, and my AFP problem on the other machine doesn't seem to necessarily be a 10.6.5 update issue—it’s just a coincidence in that I hadn’t been running a domain configuration with mobile accounts using Snow Leopard prior to the 10.6.5 update.

    Well, back to it.

    -Bob
  • atp_aviator Level 1 Level 1 (0 points)
    Just bought a macmini server 10.6.5 last week (updated to the latest fix) and am experience random disconnects from the fileserver usually within an hour or so. Caused me to lose some data while using data from the server.
  • Steven Major Level 1 Level 1 (30 points)
    My Drobo, that was previously been disconnecting with USB, has been rock solid via Firewire since I switched connections. I read in a different forum that a user with 10.6.5 client downgraded the USB related ktexts to their 10.6.4 versions (extracting them from the 10.6.4 Combo Update) and that resolved his issue with USB disconnects as well. Obviously, I'm not doing that with a server, but it's another interesting tidbit.
  • The Duke of WIndsor Level 1 Level 1 (5 points)
    This whole episode is kind of making me fall in love with FireWire all over again.
  • atp_aviator Level 1 Level 1 (0 points)
    I am running 10.6.5 on a new Minimac with an iMac, Macworkbook on AFP and a windows XP machine on SMB, used solely for files haring on a LAN. The AFP shared points on the Minimac randomly, but frequently (less than 1 hr) disconnect, to the point of frustration, losing data, etc. The SMB share point, accessed on the XP machine, seems rock solid.

    I am new to OSX Server, so could it be something in my configuration doing this?
  • schwabe Level 1 Level 1 (0 points)
    Hi,

    I have exactly the same problem.
    After the update to 10.6.5 our macminiserver drops AFP-access to clients 2-3 times/ week. Looked into afp-logs, couldn't find any strange.
    Afer rebooting the macminiserver AFP works fine for a while.
    SMB with PC or Mac works always fine.
    Hope Apple will fix that soon.

    Message was edited by: schwabe
  • Nic Barnes Level 1 Level 1 (35 points)
    Same here. Two Drobos connected over USB to a Mac Mini running 10.6. Since the update to 10.6.5 they have been randomly losing connection to the Mac. Requiring an unplug/replug or reboot of the server to clear.

    Have tried the newer 10.6.5 and it doesn't fix the problem.

    Will try switching one of them to Firewire and see if that helps.
  • Vinko Level 3 Level 3 (955 points)
    I just want to add that I am also have the same problem with my 1st generation Drobo connected to my MBP 15" via USB; the only port available since my Mac does not have Firewire.

    The drive will disconnect on its own during rapid access of writes to the drive.
  • Morten Nielsen Level 1 Level 1 (5 points)
    I’ve been having these spontaneous external HD USB-disconnects since upgrading to 10.6.5. Been trying out *a lot* of the tips found in this and other forums, but nothing worked in my case. Even tried booting in 32 bit.

    Then - in my desparate search around the net for others with this specific issue - I stumpled over this thread/post concerning USB-sticks:
    Link: [http://discussions.apple.com/message.jspa?messageID=12566073#12582956]

    And what do you know: Downgrading to 10.6.4 USB kernel extensions seems to work! Before I had disconnects randomly from within a few minutes to maybe an hour. Now I’ve been heavily writing to the USB-connected disk for approx 12 hours without any problems. (Knock-on-wood!)

    Could of course have been testing for a week or so before posting here just to be sure, but thinking of how desperate I were myself, why not post already...

    Hope someone else will find this useful.

    Message was edited by: Morten Nielsen
    Add an 8th step to the list: Repair disk permissions after reboot.