5 Replies Latest reply: Nov 17, 2010 12:16 AM by arthur63
Sug Level 1 Level 1 (0 points)
I have tried re-booting my iPhone but the apps are not opening up. The only ones that do are the ones that came with the purchase of the phone. The apps that I downloaded are crashing when I try to open. They worked fine till a couple of days ago.

Can anyone help?

Mac, Mac OS X (10.6.4)
  • Lawrence Finch Level 7 Level 7 (27,225 points)
    If you've done a hard reset (hold HOME and SLEEP until an Apple logo apprears, do not Slide to Power Off) and the phone is not jailbroken connect you your computer, go to the Apps tab and uncheck all of the apps, then sync to remove them from your phone. Then repeat, this time checking the apps to add them back.
  • One slippery dog Level 1 Level 1 (45 points)
    Hello,
    If reseting the iphone still doesn't help you will want to double-click the home button and you'll see the display shift upward and a row of your app icons on the bottom, gently place your finger on one and hold until they dance, and a red ball with a white minus appear tap the minus until all of the apps are gone then press the home button once again this will clear all of your recently ran or running apps. Multitasking in iOS 4.xx the apps will NOT be deleted just stopped and cleared out of memory. This will correct the issue.
  • Sug Level 1 Level 1 (0 points)
    Thank you so much! I did that, and now everything works!

    -Suganthi
  • Sug Level 1 Level 1 (0 points)
    This is very helpful to know.

    Thank you so much. I really appreciate it.

    -suganthi
  • arthur63 Level 1 Level 1 (0 points)
    Was really getting frantic with my apps "crashing", a hard reset didn't work, so followed whta you suggested and Hey Presto!! they now work!

    Many, many thanks, it's saved me a journey to my not so near iStore.