1 2 Previous Next 15 Replies Latest reply: Dec 24, 2010 2:59 PM by mel.wil
jacwuhan Level 1 Level 1 (15 points)
I have a Macbook aluminium 2008 and a superdrive firmware update 3.0 popped up in SU. The update starts but stop saying that" There was a problem installing this update. Quit all applications and try updating. If the problem continues, contact apple support." I don't have any application opened.
I checked SU here is the output:

This update will eliminate the noise made by the optical disk drive during wake from sleep on your Mac. This update works with the following EFI updates:

iMac EFI Firmware Update 1.4
Mac mini EFI Firmware Update 1.2
MacBook EFI Firmware Update 1.4
MacBook Pro EFI Firmware Update 1.8
To complete the firmware update process, please follow the instructions in the updater application (/Applications/Utilities/SuperDrive Update.app). The updater will launch automatically when the installation is complete.

I checked the firmware of my macbook and it is 1.3 and I tried to update to 1.4 but the computer shows that I don't need this update.
I don't know what is going wrong, How can I install this update? your help will be appreciated
thanks

MacBook aluminiumlate 2008; Powerbook 12'', Mac OS X (10.6.5), none
  • 1. Re: Superdrive firmware update problem
    paulshaw Level 1 Level 1 (0 points)
    I am also experiencing the exact same issue with my 15-inch Macbook Pro. I have just had a new superdrive installed under Applecare, which needed updating to the latest firmware. However, when I try and run the updater I get the same error message as you did.

    I will probably contact Apple support or take it into an Apple Store but I am hoping there is a simple solution.
  • 2. Re: Superdrive firmware update problem
    rvbarc Level 1 Level 1 (0 points)
    I'm having the same problem with the "superdrive firmware update 3.0".
    My Machine:
    MacBook 2.13 MId-2009
    model identifier: 5,2
    Boot Room Version: MB52.0088.B06
    SMC Version: 1.38f5

    Apple's support page states that the "MacBook EFI Firmware Update 1.4" is required before completing the superdrive update; however, on their support page , http://support.apple.com/kb/ht1237 this EFI firmware update is not listed as a compatible update for my macbook model.

    I tried installing the "Macbook EFI Firmware 1.4" update anyways but I get the message "this computer does not require this update.
  • 3. Re: Superdrive firmware update problem
    jacwuhan Level 1 Level 1 (15 points)
    Hi rvbarc and Paulshaw
    Have you fixed your superdrive update problem? If not that is how I fixed mine.
    First I found that the problem is not the Efi firmware update but Snow leopard.
    rvbarc, It seems that your MacBook preinstalled os is Leopard 10.5.7, so you need 10.5.7 to be able to update.
    If you have your MacBook restore dvd you can just install it in a spare usb or firewire drive and boot the computer with that drive. you will be able to install the SD update.
    Paulshaw I don't know your MacBook Pro specifications but I think that the same apply to you. You will need to use 10.5.7 to be able to install.
    For mine I just reinstalled Leopard 10.5.5 which is my computer preinstalled OS and updated to 10.5.7 and the update applied without any problem. After that I formatted back my computer to Snow leopard.
    I did it because I always have a backup of all my files so reinstall the os is not a big problem to me.
    If you don't want to downgrade you can just use an usb drive for leopard.
    Hope that helps.
  • 4. Re: Superdrive firmware update problem
    itwizz Level 1 Level 1 (0 points)
    I'm having a very similar problem to the OP in that I can't use the SuperDrive Updater. I have a 2009 MacBook Pro with all the latest Updates installed and I've got a feeling the latest service pack update has messed up the updater as it worked fine before it came out!

    I've checked the System Profiler and all my FW is up-to-date so why is the updater saying there's a problem with the update when the drive doesn't need updating?
  • 5. Re: Superdrive firmware update problem
    spikedesmith Level 1 Level 1 (0 points)
    Confirmation (and kudos) to the post from jacwuhan; I had the problem described in the original post and was able to boot from a Leopard system and install the SuperDriver Firmware update 3.0. More details:

    OS 10.6.5 - I recently replaced my SuperDrive with a Matshita UJ-868 and Software Update wanted to install SuperDrive Firmware Update 3.0. When I downloaded I was unable to install the update; the error was "There was a problem installing this update. Quit all applications and try updating. If the problem continues, contact Apple support". The MSHWFirmware log only showed: INQUIRY of (MATSHITA DVD-R UJ-868 [KA14]) failed with No Sense: No additional sense information.

    I exhausted as many obvious possibilities I could think of:
    1. The drive seemed to be working; I was able to read/write a DVD
    2. I quit all applications and even tried booting in Safe mode (to ensure nothing was running) and received the same error.
    3. I tried resetting PRAM and SMC (same results)
    4. I repaired all permissions on the disk (same results).

    As jacwuhan posted, I installed OS X Leopard on a spare USB drive and was able to install the firmware update. When I rebooted into OS X Snow Leopard, Software Updater showed that all software was up to date.

    Some additional information on installing OS X Leopard from the original media which was shipped with the computer:

    1. You need to make sure the drive has a partition map scheme of "GUID partition table"; if you don't partition your drive in this fashion the installation will not be able to chose the USB drive for installation (don't worry; Mac gives good diagnostic information if you fail to do this).
    2. Plug-in USB drive and insert original OS X Leopard media in drive, reboot and hold down the Option key to choose to boot from the OS X Leopard media
    3. Choose to install OS X Leopard on the USB drive; the initial installation of 10.5.5 wants 11.4 GB; you'll want more as you have to install updates - I would recommend at least have a 30-40 GB partition
    4. After installing 10.5.5, boot with the USB drive and select the Software Update
    5. Initially the SuperDrive firmware update will not appear in the Software Update; you will have to update to the latest version of Leopard (for me it was the Mac OS X Update Combined - 10.5.8)
    6. After installation of the 10.5.8 update; reboot and select Software Update; this time SuperDrive Firmware update 3.0 will be available.
    7. After you install in Firmware update, you can reboot to your original hard drive; Software Update should now tell you your system is up to date.

    Hope this helps you out - shout out to jacwuhan for helping me out of this.
  • 6. Re: Superdrive firmware update problem
    itwizz Level 1 Level 1 (0 points)
    Unfortunately that doesn't help with my problem as I've checked all the relevant version numbers and they're all up to date but when I try to run the SuperDrive Update program in Applications/Utilities it just says there's a problem and to try again .
  • 7. Re: Superdrive firmware update problem
    spikedesmith Level 1 Level 1 (0 points)
    itwizz - just to reiterate what jacwuhan stated: " ... First I found that the problem is not the Efi firmware update but Snow leopard." I would make the same guess that this is a bug in Snow Leopard. On my system, all of my firmware (EFI, etc.) was at the correct level; the problem was that from a Snow Leopard system, I could not update the SuperDrive firmware. When I booted from Leopard I was able to install. I don't think you are going to have luck getting this update on unless 1) you do so from a Leopard installation or 2) Apple fixes this issue in Snow Leopard.

    Good luck, hope you are able to find your problem.
  • 8. Re: Superdrive firmware update problem
    itwizz Level 1 Level 1 (0 points)
    I'm going to have take the wait and see option as I Don't have a spare USB Device that's big enough for the Leopard install nor the funds to get one.
  • 9. Re: Superdrive firmware update problem
    jacwuhan Level 1 Level 1 (15 points)
    Spikedesmith, I am very happy that you were able to update your SD. Itwizz, I think that the wait and see option is not a good one because may be Apple will not do something about that. Nowadays, hardisks are very cheap. I China were I am 320GB hardrives now only cost 30$. You can even borrow one from a friend.
    Wish you a Good luck.
  • 10. Re: Superdrive firmware update problem
    Scott B. Silverman Level 1 Level 1 (65 points)
    I am having the same issue on Snow Leopard, and so booted to a Leopard installation to run the update. For some reason the SuperDrive utility says that my SuperDrive is up to date, which it is not. Booting back in to SL returns the same error message. Argh!

    @itwizz If you take your computer to the Genius Bar at an Apple Store, they will fix the problem for free, even if you are no longer under warranty. This would be a better solution than "waiting to see."
  • 11. Re: Superdrive firmware update problem
    itwizz Level 1 Level 1 (0 points)
    I've had to send my Mac Book Pro in for reapirs anyway as there is something wrong with the screen so they are going to fix that and the SuperDrive issue at the same time.
  • 12. Re: Superdrive firmware update problem
    itwizz Level 1 Level 1 (0 points)
    I've just received my Mac Book back and all my problems have been fixed .

    It turns out that The SuperDrive and EFI firmwares were erroneously installed by my old install of Leopard so the genius's at apple managed to wipe both from the system, fixed my screen and the built in Calculator as it wasn't updating the currency rates for some odd reason.
  • 13. Re: Superdrive firmware update problem
    mel.wil Level 1 Level 1 (0 points)
    Hi, i have a 2009 macbook pro 15" and I'm having the same issue. I'm not super techy...when you say boot leopard on a usb...or from a usb...any where i can get some more direction about how to do that? where to get leopard...how to get it on usb? I need the baby steps version. Thanks!!!
  • 14. Re: Superdrive firmware update problem
    jacwuhan Level 1 Level 1 (15 points)
    You can check on google. your questions are answered there.
1 2 Previous Next