3 Replies Latest reply: Nov 28, 2010 9:27 AM by Moncsicsi
jalex85 Level 1 Level 1 (0 points)
I just updated the system a couple of minutes ago but now I found that the middle click in my macbook pro is activated. I can open and close links in new tabs at safari by clicking with the middle click but I would like to disable it.

I find it a bit annoying having to click in one edge of the trackpad. I loved the way it worked before, where I could click anywhere in the trackpad.

Macbook pro5,5, Mac OS X (10.6.5)
  • thomas_r. Level 7 Level 7 (29,980 points)
    I'm not sure what a "middle click" is... a click in the middle of the trackpad (which is just a click and not anything special)?

    It sounds like you're trying to use the secondary click and have it set to only trigger in one corner. Open System Preferences, go to your Trackpad preferences and adjust the settings. You can get a secondary click with a single finger in a bottom corner, with two fingers anywhere on the pad or by holding control while clicking anywhere on the pad.
  • jalex85 Level 1 Level 1 (0 points)
    I forgot that about a year ago I installed a plugin to enhance the magic mouse capabilities. It seems that the programmers of this plugin launched an update which included some enhances to the trackpad. It allows to do a middle click and a lot of other functions.

    Today when I turned on my mac snow leopard updated as well as this plugin.

    So it is a problem with the plugin.

    You guys should try it if you have magic mouse it's called http://magicprefs.com/ and it enhances A LOT the capabilities of the magic mouse.

    Thanks for the help!
  • Moncsicsi Level 1 Level 1 (5 points)
    jalex85,

    Thank you for the advice. I was going nuts and about to send my MacBook Pro in for repair. Unchecking the middle click option in the MagicPrefs' preference pane solved my problem.

    Thanks again!