5 Replies Latest reply: Nov 17, 2010 12:07 PM by Paul_31
jacob! Level 1 Level 1 (0 points)
Hi folks! I got a new iMac this year which came with a "Magic" mouse. It worked fine until this last update that I installed today. All of a sudden, bluetooth won't turn on.

Currently, the bluetooth logo in the top left corner of my screen is gray. When I click it, "Bluetooth: Off" is displayed in gray, and below it "Turn Bluetooth On" is a clickable option. I click it, and nothing happens.

So I went to System Preferences > Mouse > Set Up Bluetooth Mouse > Turn On Bluetooth. Again, nothing happens. The button simply changes color from blue to gray, and that's it.

Finally, I click Show All > Bluetooth, and I check "On". Nothing. If I close the window, and go back to System Preferences > Bluetooth, "On" is no longer checked.

Any help would be awesome.

iMac, Mac OS X (10.6.5)
  • Paul_31 Level 6 Level 6 (13,050 points)
    Hi - you could try this, it's fixed strange Bluetooth behaviour for me in the past.
    Go to Macintosh HD>Library>Preferences and move the file 'com.apple.Bluetooth.plist' to the trash. Restart and hopefully you'll be able to re-pair the mouse (and keyboard if it's BT).
    Have you got a wired mouse/keyboard you can use if all else fails?
  • jacob! Level 1 Level 1 (0 points)
    Thanks for the reply, Paul.

    I did as you said, trashed the file, and rebooted, but still got the same result.

    To answer your last question, yes, I have a wired mouse and keyboard. However, I miss my side-scrolling ability I had with the magic mouse. It's a great help when editing video like I'm doing now.
  • Paul_31 Level 6 Level 6 (13,050 points)
    As the problem started with the latest OS update I think my next step would be to re-install the update using the combo installer, available here: http://support.apple.com/kb/DL1324
    Worth repairing permissions before and after the update - Utilities>Disk Utility, click on Macintosh HD and select 'repair permissions'. Good luck.
  • jacob! Level 1 Level 1 (0 points)
    That worked! I didn't repair the permissions after reboot since I saw the bluetooth logo was on and it started working.

    Thanks a ton!
  • Paul_31 Level 6 Level 6 (13,050 points)
    Great, glad you're sorted. Still worth doing a 'repair permissions' after any major update.
    Thanks for the star.