5 Replies Latest reply: Nov 20, 2010 1:10 PM by LilyLC
Keith Thirgood Level 1 Level 1 (105 points)
My Epson StylusPro3800 just stopped communicating with all of the Macs on my network. I receive a cryptic "communications error" message when I try to print to it.

I rebooted the Mac and tried again. Same result. I tried another Mac on the network, same result. I swapped ethernet cables and the port in my switch the cable to the printer is plugged into, to see if it was a cable or port problem. Same result. (All the other devices going through the switch are communicating with no problem.)

I deleted the printer from the Printer & Fax preferences file. However, after I reinstalled the driver software, when I went to the Add new printer dialog box, the Epson printer does not show up under the AppleTalk menu as it used to. The other printer on my network does show up.

What do I do now?

Mac Pro 2 x 2.8 GHz Quad Core, Mac OS X (10.5.6), 16 GB RAM
  • greg sahli Level 7 Level 7 (24,320 points)
    Has anything else in your network changed? Different router? Give us some detail just to be sure.
    Have you tried powering down the router for 10 secs and then back up?
  • Keith Thirgood Level 1 Level 1 (105 points)
    I hadn't powered down the switch (not a simple router) as it was working just fine for all the other devices and Macs that flow through it.

    As an experiment, I've just done so.

    Unfortunately, I can't test to see if it has made any difference, as I still cannot see the printer driver in the Add Printer dialog box, so I cannot add my Epson to the printer list to even see if there continues to be a communications error.
  • LilyLC Level 4 Level 4 (2,635 points)
    Keith Thirgood wrote:
    ...Epson StylusPro3800 just stopped communicating...cryptic "communications error"...(All the other devices going through the switch are communicating with no problem.)


    You did not state, but did you try turning the printer off and after a few minutes, turn it back on?

    ...after I reinstalled the driver software, when I went to the Add new printer dialog box, the Epson printer does not show up under the AppleTalk menu as it used to. The other printer on my network does show up.

    What do I do now?


    If any of your computers use OS 10.4.x, then click "More Printers." Then select EPSON AppleTalk from the drop-down list, select the zone from the drop-down list, and then select the printer model.

    Alternatively, instead of AppleTalk, try Bonjour (OS 10.4) aka Default (OS 10.5).

    HTH
  • Keith Thirgood Level 1 Level 1 (105 points)
    I' ve tried restarting the printer with the same results.

    I'm using OS X 10.5.8. When I click More Printers, all that show up are Canon IJ Network, Epson Firewire, Epson TCP/IP and HP IP Printing. There is no Epson Apple Talk under that tab.

    Under the AppleTalk tab, only Local Zone with my Ricoh printer shows up.

    When I try Default, two Adobe PDF printers show up as well as the AppleTalk Ricoh and a Bonjour Ricoh. No Epson printer shows up.
  • LilyLC Level 4 Level 4 (2,635 points)
    Keith Thirgood wrote:
    I' ve tried restarting the printer with the same results.


    In your original posted, you stated "another Mac." If you did not delete and re-install the print driver on that Mac, can it see the Epson printer?

    As for your computer (the one in which you re-installed the print driver), you might consider checking the hard disk just in case a file might be corrupt. To do that, boot your computer with the OS Install disk holding down the "c" key. Choose your language.
    Go to the Utilities menu and select Disk Utilities.
    In the left pane, click on your hard disk. On the right pane, click the First Aid tab and below, click the button Repair Disk. (If it finds any errors it will attempt to fix and rerun the test.)
    Afterwards, click the Repair Disk Permissions.
    Reboot your computer.

    When I try Default, two Adobe PDF printers show up as well as the AppleTalk Ricoh and a Bonjour Ricoh. No Epson printer shows up.


    Consider checking the network settings on the printer itself. See FAQ at
    http://www.epson.com/cgi-bin/Store/support/supDetail.jsp?BV_UseBVCookie=yes&info Type=FAQ&oid=79928&prodoid=63062509&foid=88080

    You might also consider setting the printer up as with an IP address. (See the Network or User Guides that you received with the printer or the Epson website.)

    FYI: I used to have an Epson 3000 and now have an Epson 3880 and find IP with LPD protocol faster than AppleTalk.

    HTH