Previous 1 2 Next 21 Replies Latest reply: Jan 3, 2011 2:23 AM by nexusle Go to original post
  • bryanparke Level 1 Level 1 (0 points)
    thanks alb@pt. I have two other computers with 10.6.5 printing to that printer just fine. i am running latest 10.6.5 combo update as well as the latest epson printer driver update via software update and also applied it manually via

  • alb@pt Level 1 Level 1 (20 points)
    Yes, it's odd. I have a laptop that has no problem with the Epson drivers and 10.6.5 but my desktop did have a problem with it. Best of luck.
  • acduke Level 1 Level 1 (0 points)
    I upgraded to 10.6.5 a few days ago and now that I'm trying to print off some stuff for my final project in typography class, my printer won't work! It's a Canon MP560 that was working fine before. Like some of you, I did the combo update after using the beta version of 10.6.5 that featured AirPrint. Well, I think AirPrint hung around after the upgrade, and that might be what is causing our problems. No wonder Apple didn't officially release AirPrint for shared printers, as it is so buggy! Does anyone know the files that were added in the beta that AirPrint uses so that we can remove them and try that? I've tried most everything that everyone else has listed, resetting everything over and over, reinstalling, etc. I'm about to freak out as I have to have this resolved for my final!

    Oh and also, printing a test page from the printer utility works fine! So weird! Here are a few of my recent error messages from doing different printer related tasks:

    12/12/10 11:37:48 PM[109] ([0x0-0x1d01d][159]) Exited: Killed
    12/12/10 11:38:23 PM[513] launchctl: Error unloading:
    12/12/10 11:38:53 PM[125] INFO:Determining printer's features...
    12/12/10 11:38:58 PM[125] Queue:CanonMP560series
    12/12/10 11:40:57 PM TextEdit[560] Printing failed because PMSessionEndDocumentNoDialog() returned -30870.
    12/13/10 12:18:30 AM[695] launchctl: Error unloading:
    12/13/10 12:18:32 AM[695] launchctl: Error unloading:
    12/13/10 12:28:24 AM[714] launchctl: Error unloading:
  • alb@pt Level 1 Level 1 (20 points)
    did you try uninstalling your Canon printer drivers and reinstalling?
  • sanderr2 Level 1 Level 1 (0 points)
    I've got the same problem iMac i7, 10.6.5 Epson PW7000.
    Console message is

    17/12/2010 Dec 17 21:09:00 TextEdit[187] Got error -30870 creating suggested paper! Constraint handling and settings may not work properly!
    17/12/2010 Dec 17 21:09:24 TextEdit[187] Printing failed because PMSessionBeginCGDocumentNoDialog() returned -30870.

    Is there any way of regressing without reinstalling OSX? I tried the CUPS fix but that didn't work, nor did uninstalling drivers, fixing permissions, resetting printers in OSX etc etc.

  • Ron Daigle Level 1 Level 1 (5 points)
    I had this same error recently with my Mac Pro, and tried just about everything -
    resetting printing system, re-installing drivers, re-installing combo update to 10.6.5.
    I was about to give up and re-format my hard drive when I found this program - 'Print Therapy' from
    Running the fix permissions utility told me that two files were missing from usr/share/cups/mime -
    apple.convs and apple.types. I transferred these files from my laptop and now everything works.
    Don't know how they got deleted in the first place.
  • nexusle Level 1 Level 1 (0 points)

    Can you share these two files?
Previous 1 2 Next