Previous 1 2 Next 17 Replies Latest reply: Mar 5, 2012 6:16 AM by BobHarris
Richard Setterberg Level 2 Level 2 (165 points)
I'm running 10.5.8 on my 2.66 Mac Book Pro. I cannot customize the date and time in the menu bar.

I am familiar with the known process of customizing the date, copying it and pasting into the time section. But no matter what I do, nothing changes. In fact, when I select a standard format, it doesn't change either. It stays frozen in the "Thu 8:13 PM" format.

I've tried trashing the MenuBarClock.plist, but no luck getting anything to change.

Any ideas?

24" Intel iMac 2.8; 15" MacBook Pro 2.66 G5 1.8, PB G4; G3, Mac OS X (10.5.8)
  • red_menace Level 6 Level 6 (14,690 points)
    Are you pasting into the medium time format?
  • Richard Setterberg Level 2 Level 2 (165 points)
    Yes, I just tried that. When I do, it adds the "EST" to the menu bar but nothing else. I didn't even add the "EST" to my customization.
  • Richard Setterberg Level 2 Level 2 (165 points)
    Are there any preferences I can trash other than the MenuBarClock.plist?
  • Richard Setterberg Level 2 Level 2 (165 points)
    Is reinstalling the system my only option.

    Any help out there?

    Yes, I've rebuilt permissions.
  • red_menace Level 6 Level 6 (14,690 points)
    You might try removing the com.apple.systempreferences.plist file from your user preferences - I see some time formats in there. That preference .plist has some other general settings in it, so you can just move it somewhere like your desktop to see if that resets things after the system rebuilds it.
  • Ralph Johns (UK) Level 9 Level 9 (68,795 points)
    Hi,

    As I understand it the Custom Option displays elsewhere other than the Menu Bar.
    For Example the date and time references in an Email that can be made into To Do things or how the Date or time is formatted in Word or other word processor.



    10:21 PM Tuesday; November 30, 2010
  • Richard Setterberg Level 2 Level 2 (165 points)
    No. The time and date appears where I would expect it in the upper right corner of my screen in the menu bar. It appears right before the Spotlight icon at far upper right, and right after my battery level indicator.

    The problem is I cannot change the format no matter what I do. Right now, it says "Tue 6:25 PM". I have gone to the International preference pane and tried any number of changes to the date and time formats, but nothing happens. (Originally I wanted to combine the day, short date and time.) No matter what I change, the time reads as above, and the MenuBarClock.plist does not change (i.e., the date/time modified in the Get Info window does not change).

    I have tried trashing the MenuBarClock. plist and the systempreferences.plist, as suggested above. I have repaired permissions. Nothing seems to work.

    By the way, I did this on my iMac 24 desktop a while ago, and the changes took without problems.

    Anything else I might try?
  • Richard Setterberg Level 2 Level 2 (165 points)
    Ralph:

    Sorry; I misread your post. You are saying that the formats are meant to be used in places other than the menu bar.

    If that is so, how is it that I was able to get my time/date display to change on my desktop by fiddling with the time/date format in the international pane?
  • Ralph Johns (UK) Level 9 Level 9 (68,795 points)
    Hi,

    Nominally you can change the fort of he Menu Bar clock within these Parameters


    The default is 12 hour and no date.

    As the tabs indicate the Clock is separate from Date and Time in this sense.

    You can Change this




    8:25 PM Wednesday; December 1, 2010
  • Richard Setterberg Level 2 Level 2 (165 points)
    Ralph:

    According to

    http://www.macyourself.com/2008/08/31/modify-the-default-clock-in-os-xs-menu-bar -to-show-the-full-date/

    I get to make substantial changes to the menu bar clock. I'm saying it works with my desktop, but doesn't with my laptop. Both are running the same operating system: 10.5.8.
  • Ralph Johns (UK) Level 9 Level 9 (68,795 points)
    Umm,

    In International (System Preferences) I do have this Drop down
    http://img.skitch.com/20101202-dsa6qhux12u5gcqdjh9mkrn1xg.png

    My Custom Option is not available so nothing I set in the Custom Button works.
    (these are the things I remember trying to use before to make the clock change).
    I am the Admin account so I don't know why I can't change this to Custom

    If I Click the menu bar clock I do see the day in Full (But greyed out) where as the clock displays a shortened version of the day.

    I followed you link and tried the settings they used.
    Turning Off the Show Day option only removed the short version.
    In fact changing it to Not show the 24 Hour clock showed 07 as the Hours with no PM indicator (and that option was greyed out even when I went back and added PM to the Custom option - which was Live after Adding the Date to the Time settings)

    I will try a PRAM reset once I have caught up with Subscription emails



    7:37 PM Thursday; December 2, 2010

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • Richard Setterberg Level 2 Level 2 (165 points)
    Hmm.

    I do have the "Custom" available on that dropdown, but selecting it doesn't seem to matter. I have tried "Custom", "United States" and "United States (Computer)" but it makes no difference.

    I, too, have the greyed out day and date if you pull down the time in the menu bar. My objective is to get it to display both without having to pull it down.

    My results are the same as yours when turning off "Show the day of the week." I think without doing this (in cases where the link instructions actually works), you get duplicate displays of the week. Doing it simply turns off the default one.

    Thanks again for helping. Any other clues out there would be appreciated.
  • Ralph Johns (UK) Level 9 Level 9 (68,795 points)
    Hmm too,

    If this did work I can't get it to follow those Instructions.



    6:57 PM Friday; December 3, 2010
  • JHSkier Level 1 Level 1 (0 points)
    I am Now having the same problem, have you or anyone else solved it? It's quite strange.
Previous 1 2 Next