2 Replies Latest reply: Nov 19, 2010 8:40 PM by Robert Paris
Robert Paris Level 1 Level 1 (145 points)
At home I have an Airport Extreme router and both WPA-2 encryption and MAC address filtering work just fine on both my MacBook Pro laptop and on my new iPad... But then I headed off to visit my dad in another part of the country. He has ATT DSL with a 2-Wire 2701HB-G router... I have both my MacBook Pro and my iPad with me... Setting up WPA-2 encryption worked fine and MAC address filtering also works fine on my MacBook Pro... But that doesn't work at all on my iPad... I have followed the very simple instructions that the 2701HB-G offers to enable MAC address filtering but each time I enable it, the iPad loses connection... Disable MAC filtering and the iPad immediately regains connection... I've even let the 2701HB-G go out and find its own list of available machines to allow under MAC address filtering... It sees the iPad by the name I gave it but even that method fails when I accept that list and enable MAC address filtering... I've also tried completely rebooting the router and restarting the iPad but simply stated, whatever I try causes the iPad to lose connectivity the moment I turn on MAC address filtering... All the while my MacBoo Pro connects just fine with MAC address filtering on... Any thoughts???? And is it true that MAC address filtering doesn't really offer much protection anyway??? Especially considering I do have WPA-2 protection turned on???

thanks... bob..

Two 17 inch MacBook Pros and a FW800 G4 dual 1.25 Ghz, Mac OS X (10.6.4)
  • Craig Brady Level 4 Level 4 (1,790 points)
    2 Wire Routers have been known to have issues with some of the newest computer equipment. Mac filtering is not a very effective security measure, as so many systems have the ability to spoof any Mac Address they choose. With WPA Security set, there is really no need.
  • Robert Paris Level 1 Level 1 (145 points)
    Thanks for the input, especially for letting me know what I already thought, that MAC address filtering wasn't gonna help much if any as long as WPA or WPA2 was up and working... And as a follow up, I got up today, tried precisely the same thing that yesterday failed at least 10 times and today the iPad connected EVEN WITH MAC FILTERING ON!!!!

    And I am quite confident I did absolutely nothing different.... But something was different... I even disabled and re-enabled MAC filtering two or three times and now it is working every time... One of life's many mysteries...

    Again, thanks for the help...

    bob...