6 Replies Latest reply: Nov 25, 2010 9:05 PM by aprouser
raginbullsht Level 1 Level 1 (0 points)
I have three windows computers (XP, VISTA & 7) and one mac mini all sharing a drive connected to my airport extreme. I can access the drive fine with computers except windows 7.

My configuration on the airport was to prompt for a disk password, so I changed it to ask for username and password and I still cannot connect.

I have tried to map it via \\10.0.1.1\Disk and also \\extreme\Disk neither work.

I have been able to connect or at least it appears to connect by showing me the drive listed in windows 7, but none of the files are present. Windows xp and vista show the files fine and still can connect.

Windows, Windows 7
  • Tesserax Level 8 Level 8 (49,415 points)
    Hello raginbullsht. Welcome to the Apple Discussions!

    There are a number of posts related to copying issues between Windows 7 and AirPort Disks. Two potential solutions being forwarded are: 1) Changing the LAN Manager authentication level, and/or 2) Disabling the Windows Search feature.

    To change the LAN Manager authentication level:
    o From the Vista desktop, click Start
    o Search for: security
    o Click 'Local Security Policy'
    o Goto Local Policies > Security Options
    o Under Policy, double-click 'Network security: LAN Manager authentication level'
    o Change level to: Send LM & NTLM responses
    o Under Policy, double-click 'Network security: Minimum session security for NTLM SSP based (including RPC) clients'
    o De-select 'Require 128-bit encryption'
    o Click OK

    To disable Windows Search:
    o Start > Control Panel > Programs > Programs & Features
    o On the right-hand side, click "Turn Windows features on/off"
    o Scroll down, and de-select "Windows Search".
    o Press OK, close all windows and restart.

    A third "solution," that has worked for me, is verify that both the AEBS and the Win7 PC are using the exact same Workgroup Name. In my case, I use "WORKGROUP" (without the quote marks) for this name.

    On the AEBS, you would enter this value on the Disks > File Sharing tab.

    On Win7, Start > Control Panel > System and Security > System > Change Settings > Change > Workgroup
  • iCiu Level 1 Level 1 (0 points)
    Hi,
    sorry for my bad english but I'm Italian.

    I have the same problem with Airport Extreme and Windows 7.
    Now I can see the USB HDD under Windows Seven but sometime when I copy a big file the connection falls (I'm connected to airport with wireless). If I try with LAN cable all work fine!!
    Why?! When I try with wireless the upload started buy after 5 minutes the connection falls for 1 minute.
  • Tesserax Level 8 Level 8 (49,415 points)
    Hello iCiu. Welcome to the Apple Discussions!

    The problem you describe is also another symptom of the issue around this general problem. Have you tried any of the solutions that I have provided ... and it still doesn't work?
  • iCiu Level 1 Level 1 (0 points)
    Hi,
    thanks for your answer!
    I doesn't try your solution because with my share setting all works fine if I use the LAN cable (I have copied about 200Gb i this way without problem).
    Maybe I found a solution at my problem... My airport extreme was too near to my PC and the wireless connection don't work... Tomorrow I will try with my windows laptop if this is the problem (In Italy are 8pm and my laptop is in my office).

    Tomorrow after my test I will post in this discussion. Maybe my information can help other user.

    Ciao e grazie
  • aprouser Level 2 Level 2 (225 points)
    I also had (have) this problem. I did find a solution, but since I don't understand why it works, am still keeping the (have) in there. This problem reminds me of the "Monkey Theory" - something to the effect that if you have a million monkeys pounding randomly on typewriters, given a enough time they will eventually type out the entire works of William Shakespeare. My route to a solution was not much better than that, but I have found some consistency with it, as it also seemed to solve a previous problem of not being able to set up a guest wireless account on the Airport Extreme.

    With the guest network setup, I could not get either my PC (running Windows 7 Professional) or my MBP (running OS X 10.6.5) to connect to the guest network (it had a different name / password than the non-guest wireless mode). After much ado, the troubleshooting method that finally worked was to just rename / give new password to the guest account, and apply the update. After that, worked like a charm on the PC and MBP - and could easily toggle (log off then on) to the primary wireless and guest network without problem.

    So then I wanted to try to share a USB hard drive on the Airport Extreme. After configuration it was accessible immediately on the MBP, with this setup from the Airport Utility:
    - Disks: File Sharing:
    -- Enable file sharing
    -- Secure Shared Disks: With a password

    For the PC, I also had many problems and I tried many solutions - too numerous to mention. In the end, the thing that worked for me was to simply change the password under the "Secure Shared Disks: With a password" with the Airport Utility on the PC. I knew that went into effect because I could then not access the Airport Extreme shared USB from the MBP. So then launched the Airport Utility on the MBP, changed the password there (same one I had typed in on the PC), where I have the "Remember this password in my keychain" checked. After that the shared USB was visible on the MBP - automatically - from finder (looking under "SHARED").

    Then, rebooted the PC and, sure enough, when I went into My Computer I could see the shared drive.

    In the above "I tried many solutions", one was the;
    To change the LAN Manager authentication level:
    o From the Vista desktop, click Start
    o Search for: security
    o Click 'Local Security Policy'
    o Goto Local Policies > Security Options
    o Under Policy, double-click 'Network security: LAN Manager authentication level'
    o Change level to: Send LM & NTLM responses
    o Under Policy, double-click 'Network security: Minimum session security for NTLM SSP based (including RPC) clients'
    o De-select 'Require 128-bit encryption'
    o Click OK


    But currently have it working with the Win 7 defaults of:
    1) "Send NTLMv2 response only" for "Network security: LAN Manager authentication level"
    2) "Require 128-bit encryption" for "Network security: Minimum session security for NTLM SSP based (including RPC) clients"

    also, my "Windows Search" is enabled.

    I might end up revisiting these ideas though, because if I disconnect the network drive from the PC and then try to remap it, I run into some of the same problems that occurred in the initial troubleshooting - in other words I cannot just map the drive, need to reboot.

    If the above change the password "Secure Shared Disks: With a password" solution works with anyone else, would be glad to hear it. Thought I would post it and then work on the re-map issue.
  • aprouser Level 2 Level 2 (225 points)
    But currently have it working with the Win 7 defaults of:
    1) "Send NTLMv2 response only" for "Network security: LAN Manager authentication level"
    2) "Require 128-bit encryption" for "Network security: Minimum session security for NTLM SSP based (including RPC) clients"

    also, my "Windows Search" is enabled.

    I might end up revisiting these ideas though, because if I disconnect the network drive from the PC and then try to remap it, I run into some of the same problems that occurred in the initial troubleshooting - in other words I cannot just map the drive, need to reboot.

    So the problem that I had in summary:
    - I had gotten the Airport Extreme shared USB drive to connect to the PC by first a reboot and then connecting via wireless to the Airport Extreme
    - If I disconnected from the shared drive on the PC, then I could not re-map it (I could get it back by the reboot / connect mentioned above): Windows was asking for "user name" and "password" when I went through the "Map network drive", following the ideas specified in "AirPort: How to mount an AirPort Extreme USB hard disk volume in Mac OS X and Windows" (http://support.apple.com/kb/HT1331?viewlocale=en_US)

    After more monkeying and searching around, I found that could fix this by:
    1) On the PC, go to Start, type "advanced share" in the search box. This will take you to "Change sharing options for different network profiles" (can also get there by going to Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings).
    2) Once there, go down to the bottom "Password protected sharing" and click "Turn off password protected sharing". Save your changes.
    3) Disconnect / reconnect to your Airport Extreme - I am doing it via the primary (non-guest) wireless.

    Then, whenever I connect to the primary (non-guest) wireless on Airport Extreme, the share automatically maps itself. I can disconnect from it (the share) and it will disappear from under My Computer. To reconnect to it (the share), I just recycle the wireless connection. And, if I log on to the guest network, the share is not visible, which is how I would expect it to perform with my settings.

    In Control Panel Microsoft describes "Password protected sharing" as:
    When password protected sharing is on, only people who have a user account and password on this computer can access shared files, printers attached to this computer, and the Public Folders. To give other people access, you must turn off password protected sharing.


    Maybe I am just tired from pounding away at this (yes, still using the "Monkey Theory" analogy - it is actually listed as the "Infinite monkey theorem" on Wikipedia if you want to read about it) but the whole thing still doesn't make much sense to me.

    As far as why changing Network security policies may work for some and not others is a bit of a mystery. I did pursue this further and ran Wireshark while I changed these settings around. There were some differences in the "Negotiate Protocol Request" and "Negotiate Protocol Response" sequence, as would be expected but the end result for me was just keeping the default Win 7 values and making the changes mentioned above to get things working.

    Otherwise, in Wireshark, I could just continually see as the PC got rejected for an attempt to logon to the share with its credentials, which I could not effectively change via the "Map network drive".

    I also just ended up Turning off network discovery from the control panel (same location as mentioned above). Now, if I try to browse in the "Map network drive" , I get a popup that sates:
    "Network discovery is turned off. Network computers and devices are not visible. Please turn on network discovery in Network and Sharing Center."


    Yet, there is my nicely mapped Airport Extreme shared drive, sitting under My Computer, fully accessible and listed as a Network Drive. So, I am not sure what is really more baffling, the semantics or the technology that is at work underneath it.

    I would love to hear if anyone else can get things working by doing any of the above.

    Message was edited by: aprouser