Previous 1 2 Next 24 Replies Latest reply: Nov 13, 2012 7:09 PM by 1jknapp Go to original post
  • p0rkch0p Level 1 (0 points)

    Unfortunately I don't have this option anywhere on my Actiontec modem, or on my Belkin router....any other ideas?

  • Hibernian56 Level 1 (15 points)

    Basically its a problem with Mail leaving an open socket for each IMAP folder. Take a gMail account, it has up to 9 folders, other IMAP accounts would  normally have 5 (Inbox, Sent, trash, Junk, Deleted).


    So in my case I have 2 gMail accounts and 5 other IMAP accounts, thats 42 connects constantly polling your ISP and clogging up your connection.


    The genius' at Apple have know about this for nearly 7 years now and of course no fix. They seem to prefer the usual arrogant "it just works" line, if we don;t admit to a problem, there is no problem. Just google "OSX mail IMAP".


    Anyway, if you turn off "use IDLE command f the server supports it" and set Mail to check for mail every 5 minutes it tends to sort it. Its a pita but that Apple for you... Also, if you have "push" turned on your iPhone and are tethering for a connection, changing to "fetch" will make a HUGE difference to your connection speed, basically due to the same open socket problem.


    In a nut shell, its just lazy coding, AGAIN.


    Otherwise use Thunderbird or another mail app.

  • Watdabni Level 1 (0 points)

    Hi Hibernian (or, for that matter, everyone!)   I am having the same problem.   I have tried turning off 'use IDLE command if the server supports it' as you suggest but no joy.  I can only get my speed back by force quitting Mail.   Do you, by chance, have any other suggestions?   I don't really want to switch mail apps as this is the only one I have been using for a very long time. I will be most grateful!


  • p0rkch0p Level 1 (0 points)

    Watdabni, I am not sure switching mail apps will do it, I saw the same problem (as mentioned above) with Outlook/Office 2011 for Mac.


    What DID work for me is switching providers.  Once I dropped ATT DSL, and went to Comcast Internet, I no longer see the problem.  I think it is some sort of MTU/max frame size issue with the DSL, but I never found a specific fix.

  • Watdabni Level 1 (0 points)

    Hi p0rkch0p,

    Thanks very  much  for the suggestion but I  don't think it will  work in this case and, even if it did, I would be very reluctant to change providers.   I have two  reasons: (i) I have been using Mail with no problems until about Monday 19 March 2012.  My set-up has not changed and so  I would expect that, if it were the provider's fault, I would have experienced the problem before this; and (ii) even if it was likely, I have a provider which is acknowledged to  be one of the very best in the UK.  They  have always been brilliant with problems and this is the first they  have not been able to  help with.  There is no reason to think they are at fault and, even if they  are, I would rather stay  with them if possible.  I have had many bad experiences with ISPs before signing up  with the current provider and I am very reluctant to  give up a good one!

    I am going to the Apple Genius Bar on Monday. If they can identify the problem and provide a solution, I will relay it on this forum.


    Thanks again.

  • Watdabni Level 1 (0 points)

    Hi P0rkch0p (and anyone else who has  helped or has had this problem)

    As noted above, I went to the Apple Genius Bar today, was assisted a nice fellow named Tomi who solved my problem and it may well be that his solution will work for others too, so I am posting it here. 


    After some experimentation Tomi was unable to locate the problem other than to be sure it was a corruption somewhere in the system.  He deleted my System Configuration folder and had me restart the computer.   It solved the problem immediately.   It was not necessary to recreate this folder as Tomi said it would do that automatically - and it did.  


    The System Configuration folder can be found in the Library folder of the System folder.  For speed, I would suggest using Spotlight but that does not seem to work.


    I hope someone else out  there finds this helpful.

  • jillW Level 1 (0 points)

    Watdabni, Thank you so much for posting this solution.  Is it still working?  And do you remember, did deleting that folder mean that you lost any configurations that you then had to go in and redo?




  • Watdabni Level 1 (0 points)

    Hi  JillW.  Yes, still  working and, no, I did not have to  do  anything else. I hope it works for you too.


    Best Wishes

  • p0rkch0p Level 1 (0 points)

    Jill and Watdabni, I did something similar with my Outlook profile, and that did work for some time.  However, after a couple months, mine came back, so I changed over to Comcast.  I have not had any problem since then, going on about 3 months now.

  • 1jknapp Level 1 (0 points)

    I had the same problem using Outlook 2011 for Mac. As soon as i opened it, my speed dropped from 12 mbps to 1 mbps.

    I think there may have been a way to fix it with the firewall settings but since i didn't know how. I switched from IMAP to POP. I think IMAP is the issue with the firewall.. not Mail or Outlook.


    Switching to POP worked for me. had to spread the word..

Previous 1 2 Next