Previous 1 2 3 Next 142 Replies Latest reply: Dec 19, 2015 11:39 AM by bndrrdrgz Branched to a new discussion.
David Irvine Level 1 Level 1
Owned Apple TV for two weeks. Two weeks ago, everything was fine for films already in my iTunes library.

This week, when selecting play on a movie, I get the message 'This content requires HDCP for playback problem' inconsistently. Some vids work, some don't. Then they do then they don't! I have tried on a Samsung TV and a Sony Bravia? Same for both!

How do I resolve this. I have tried different HDMI ports, turned Apple TV 2 off and on. Tried different cables (Although my HDMI cable is the one I purchased from Apple).

Any suggestions? Is it something Apple need to fix? This is kinda embarrassing when I tell friends how good Apple TV is, get them round to watch a movie and inconsistently get this.

Many Thanks for any help


Apple TV2, Windows Vista
  • gazpacho Level 1 Level 1
    I think you mean "DHCP"... this is a problem with your router .. the Apple TV needs to connect to your network and to do so it requires an IP address from your wireless router. When you turn off the Apple TV, it obviously isn't connected to your LAN and when you turn it back on again, it looks for a DHCP service to obtain an IP address to connect to your LAN.

    turn everything off... Re-set your wireless LAN wait 3 minutes... and then turn everything on again.

  • gazpacho Level 1 Level 1
    Oh... It could also be signal strength issue from your wireless LAN. Make sure your router is centrally located.
  • David Irvine Level 1 Level 1
    Thanks for your reply Gaz. I took a screen shot. It definitely says HDCP. (High Bandwith Digital Content Protection google says lol). The full message reads...

    'This content requires HDCP for playback. HDCP isn't supported by your HDMI connection. This content requires HDCP for playback'

    I only get this message for films that have been downloaded from iTunes store, and the movies in question are not in HD. That said, TV programmes I have downloaded from iTunes in HD work beautifully fine. So it doesn't appear that I have lost my connection as these load quite fast.

    The router is also in the same room. I'm not doing anything differently to what I last done when when everything worked fine.

    Thanks for taking the time to suggest though.
  • gazpacho Level 1 Level 1
    hehe.. trust me.

    I just googled.. apparently it also means "High-Bandwidth Digital Content Protection".. which might answer your problem directly given that it only effects some content.


  • David Irvine Level 1 Level 1
    So basically it's a new HDMI kind of connection which some TV's may not support? That would make sense but what puzzles me is this... It worked fine two weeks ago on the same TV! So why now?

    The TV I have is less than Two years old! I'm not interested in replacing the TV just to use 'certain limited' content. That would be nuts lol. Especially as I could link my laptop via HDMI and it work fine that way. That said, I'd rather not have my laptop next to TV hence a good reason for Apple TV2.

    Besides if it came from iTunes it should work perfectly fine. Content wise... I couldn't be more compatible and legit lol.

    Did you ever experience this issue?
  • Harold Goh Level 1 Level 1
    I am also facing the same issue.

    Just bought the ATV2 and came back excited to hook it up. Purchased a HDMI cable from the neighbourhood AV store and the setup was very smooth. Played some trailers. Impressed with the streaming speed.

    Then the bummer moment came. Played the movies off my MB Pro. "This content requires HDCP for playback". What!?@!

    I am still searching the net for answers. Will go back to the store tomorrow to ask the guy for advice. My TV is a LG one, just for comparison and info.

  • Crudest Level 1 Level 1
    I also have the same problem - I have a Samsung TV that is fairly old - probably uses a previous generation of the HDMI protocol.

    A lot of my content has been ripped from DVD to there is no content copy protection. However stuff downloaded from iTunes has the protection so it sometimes gives me grief.

    Anyway, I find that 90% of the time it's a sequence thing. I have a Harmony remote so I make sure that the TV is powered up first for all of my devices. When the Apple TV goes to sleep, and comes back on before the TV is powered up, that's when I consistently get the error.

    Some times though there is no rhyme or reason and the only way I can get the error to go away is to keep everything powered up and turn the TV off and back on again (sometimes 2 times) to force the handshake again.
  • BHBMBP Level 1 Level 1
    Have had my Apple TV for over a month and never had this issue until this first software update. Now I notice this same error when pressing play on a Netflix show or movie. I bought my HDMI at Apple. I found that if I exit by putting it to sleep, then try again, it seems to work. Seems like a software issue to me with the newest OS. Quite annoying.
  • lvm3912 Level 1 Level 1
    I can also verify that this happens when trying to stream Netflix movies and tv shows. Some at least.
  • vazandrew Level 6 Level 6
    Apple TV
    Make sure your cable is all the way into the port on both ends. Sometimes it may come loose.
  • ALICE UNCHAIND Level 1 Level 1
    I too sadly have this handshaking issue. I'm in Phoenix, AZ. Day one buyer for ATV2. Worked all of about two days in terms of streaming HD content from either my MAC or netflix. About the third time i tried to stream HD content from Netflix or Blu Ray digital copies from my Mac, I get the HDCP compliance message stating my display is not authorized.

    I have tried every concievable combination of unplugging and rebooting of TV (Samsung 2005 DLP), ATV2, and HDMI switcher (Monoprice) and nothing will work. My DirecTV HD-DVR works like a charm. If I rent an HD pay per view from DirecTV, no problem. If I rent an HD movie on iTunes, won't display it due to the HDCP issue. I've NOT ONCE had an issue with my DirecTV HDDVR having an HDCP compliance issue and of course its connected to my TV via HDMI thru my monoprice HDMI four port switch.

    I guess the only other thing I could try is exchanging the unit itself. But everything else works as advertised. It feels like this is just a software issue that needs to be patched, and fast.
  • ALICE UNCHAIND Level 1 Level 1
    Also, plugging my ATV2 directly into my TV's single HDMI port does not solve the problem. I get the same HDCP issue. So we can rule out the switch being the problem.
  • tonski Level 1 Level 1
    Same deal with me, had AppleTV for a couple of weeks same message. Advice from someone was to just swap HDMI potrs and guess what - works perfectly now.

    BTW. I have a LG LED LCD.
  • johnnymoy17 Level 1 Level 1
    I bought mine first week it was out. It worked perfect until the first update and now it's a useless brick. I moved the hdmi cable from the apple tv to my mac mini and it does netflix now since the Apple Tv is crippled. I regret getting Apple TV now. I should have just used the mac mini to begin with. It's going into my no longer used devices I thought would be nice but aren't drawer until Apple fixes it's flaws.
Previous 1 2 3 Next