11 Replies Latest reply: Nov 23, 2010 9:48 AM by OmmyTree
mandm1 Level 1 Level 1 (0 points)
I was wondering if anybody can help me with this problem...I've been using wifi at my house without any problems until about 3 days ago...I don't get a wifi symbol at the top anymore. When I go wifi settings, it tells me that I am connected to my home wifi, but no symbol at the top (only 3G is showing up). I tested it out at local Starbucks, and was able to connect without any problems. I've turned my modem off/on and tried resetting network settings on my phone, but it is still not working. Can somebody please tell me what I can do to get wifi at home? Thanks!

iphone 4
  • tcw1969 Level 1 Level 1 (10 points)
    I'm having the same problem, I have to keep reconnecting.
  • Barry Porter1 Level 2 Level 2 (330 points)
    is your home network open or closed? to you have any connection restrictions set?
  • mandm1 Level 1 Level 1 (0 points)
    How would I check if my network has any restrictions? I didnt make any changes to my network...my wifi just stopped working out of nowhere.
  • landfall Level 1 Level 1 (0 points)
    Something is goofy here.
    I have a 3Gs, my wife has a 3Gs.
    I update to 4.1, she did not.
    I have no wifi, she has wifi.

    Can not find or join any wifi network, then the unicorn shows up today (for no apparent reason)
    I click "join" type in password, back to wifi.

    Clearly a 4.1 software issue
  • markj55 Level 1 Level 1 (5 points)
    Have tried everything - reset router, restored iPhone and same problem.
    Phone will not connect to wifi.
    Using OSX 4.1
    Anyone come up with a fix?
    Thanks,
    Mark
  • Andrea Rimicci Level 1 Level 1 (120 points)
    mandm1 wrote:
    ...wifi settings, it tells me that I am connected to my home wifi, but no symbol at the top (only 3G is showing up)...


    When phone tells you are connected, but no symbol on top, it means the wifi authentication was successful and your device authenticate with the network, but the device cannot navigate to the internet. It may be wrong DNS settings, or your wifi router not able to access internet, too.

    Have you tried to access your home wifi with other devices, as example a notebook?
  • English Level 2 Level 2 (165 points)
    You could try checking that your router and phone are on the same IP address. The 'Settings - WiFi - > will show you your IP address on the phone and you will have to login to your router to check the allocated IP address there.
  • puka51 Level 1 Level 1 (0 points)
    Like others here i am using 4.x OS, my phone does not even see my wireless network but my laptop and webbook both see and conect fine. Phone used to see and connect to network, not sure when it stopped seeing it. Does anyone know if there is a way to force the phone to see network? Thanks in advance for any help.
  • mandm1 Level 1 Level 1 (0 points)
    It works again! I turned off my computer at home, then turned off wifi settings on iPhone and then reset my router. When I turned back wifi settings on the phone, I got the wifi symbol at the top. weird...
  • Tjdrennan Level 1 Level 1 (0 points)
    I have this same problem iphone 4 with the latest 4.2.1 software. on 4.1 wireless worked fine but now after the upgrade to 4.2.1 my phone can't find any wireless signals at all??? Any idea's? is this a clear bug in the ios?
  • OmmyTree Level 1 Level 1 (0 points)
    Hi, since i updated to ios 4.1 (prev vers 4.0.1) my iphone 3G don't connect over my home wireless network (wep protection).
    I have try to restore my iphone (with 4.1, 4.2 and 4.2.1) from backup and also make new device, restore network settings from device and from router, set open wireless but nothing, with wep give invalid password, and with out password don't find network.
    Network work propely, (i write with my mbp connected with wifi)