Previous 1 2 Next 26 Replies Latest reply: May 20, 2011 4:31 AM by willyb311 Go to original post
  • Lordofdaflies Level 1 Level 1 (0 points)
    Same problem as all of the above...I just TURNED IT OFF AND TURNED IT ON and there it was the beautiful airplay icon
  • shippie Level 1 Level 1 (0 points)
    I too had all the AirPlay icons on my iPhone except for streaming music. A reboot of the iPhone fixed it.
  • Paul Howard4 Level 1 Level 1 (30 points)
    Bumping this topic. I have the Airplay icon on my phone. It plays on my Airport Express for my kitchen speakers but when I switch to Apple TV 2 it doesn't work. Everything else on the Apple TV2 works fine. It has the latest software update as well as my iPhone 3GS. I've rebooted my phone and everything else.

    Just can't get Airplay to work on my Apple TV from iPhone but airplay works fine for everything else on my iPhone, including Pandora.
  • Paul Howard4 Level 1 Level 1 (30 points)
    OK, it figures that I put the previous post up and now for some reason Airplay is working. I did just watch a movie on Apple TV and it worked right away. I watched a movie Netflix via Apple TV though and it didn't work then. I wonder if their is a correlation inactivity of watching movies on Apple TV and using Airplay???
  • archesdevil Level 1 Level 1 (0 points)
    I have been having the same problem. Power cycling the Apple tv fixed it for me. Hopefully I won't have to do this very often.
  • Scott 4834 Level 1 Level 1 (0 points)
    I am running an iPhone 3G with 4.2.1. I have an apple tv 2. I have gotten airplay to work from my computer, but not from the iPhone. Any idea what I need to do?
  • wongyld01 Level 1 Level 1 (0 points)
    I have Apple TV (2nd gen) and ipad, it worked properly (airplay) before I updated my ipad to ios 4.3.1. Now with ios 4.3.1, I cannot use airplay anymore (icon of airplay disappeared) and even cannot use ipad with apple remote to control apple TV. Anyone has the same issue?
  • YoungZ1980 Level 1 Level 1 (0 points)
    Hi folks just had this prob myself and wanted to tell you how i fixed it. Everything has the latest software--iPhone, Time Capsule, AppleTV and MacBook.

    I have a dual band Time Capsule 802.11n network, with different names for the 5GHz and 2.4GHz nets so that i know which one i am on. My AppleTV was connected to the 5GHz network and i could play music and even videos from my Mac, but the iPhone was super intermittent and then just stopped showing the airplay icon while i was trying to look at pics on my TV.

    I reconfigured the AppleTV to run on the 2.4GHz network and AirPlay icons showed up on the phone. Went back to 5Ghz and it disappeared again. Put it back on 2.4G and it came back. The iPhone itself only runs on 2.4G, and although i would have expected the connection and data to go through the router--thus bridging the 2 different freqency networks--it seems like the iPhone actually connects directly to the AppleTV when using AirPlay, so if they are on different freq networks it won't work.

    If you have a single-name dual band network, i could imagine the ATV connecting to 5G and the phone stuck on 2.4 and thus it won't work. So put your ATV onto the 2.4G network and see if that works. Freaking complex problem.
  • byteybird2 Level 1 Level 1 (0 points)

    The Verizon iPhone see the AirPlay Icon but nothing streams over to the AppleTV 2.

     

    I have 2 iPads and 2 iPhone 4's (one Verizon and one Att) and the AppleTV 2.  All devices have the lastest ios. AppleTV 4.2, iPads and ATT iPhone 4.3.2 and Verizon iPhone 4.2.6.  Also using the latest Time Capsule.

     

    Using the Photo Gallary, the AirPlay icon shows up on all devices.  With only one device at a time, selecting the AirPlay icon turns from white to blue (after selecting Apple TV).

     

    All devices with the exception of the Verizon iPhone connects and displays photos from the Photo Gallery.  A Neighbor came over who also has the Verizon iPhone and was able to see the AirPlay icon but nothing streamed to the Apple TV.

     

    Anyone have this issue?

  • willyb311 Level 1 Level 1 (0 points)

    I am having the exact same problem and have found no help anywhere to resolve it. I can use airplay from my Mac book and iPod, but not Verizon iPhone. The icon is there, I can stream audio, but no video. Once I select the apple tv, the video just sits there and nothing happens...

  • byteybird3 Level 1 Level 1 (0 points)

    The solution was to reset the Apple TV.  Go to Setting | General | Reset

     

    After you re-connect to the network; restart the iPhone (power cycle).

  • willyb311 Level 1 Level 1 (0 points)

    that worked byteybird3 - and it fixed a problem with the way youtube sorts videos (it was doing it randomly rather than by date added)  Thanks for your help!

Previous 1 2 Next