Previous 1 2 Next 18 Replies Latest reply: Aug 5, 2012 9:34 AM by stevemick
DoubleRR192 Level 1 Level 1 (0 points)
Ok I updated my iPhone 4 with iOS 4.2.1 and it will not let me stream music or videos to my iMac. In fact, there is not even an Airplay button on the volume control bar. Is there something I need to setup?

iMac, Mac OS X (10.6.4)
  • wjosten Level 10 Level 10 (93,390 points)
    Quote from Apple:

    AirPlay lets you stream digital media wirelessly from your iPhone, iPad, and iPod touch to your Apple TV and AirPlay-enabled speakers.
  • kfalconieri Level 1 Level 1 (0 points)
    Wjosten, I have a question for you about buying old iPhones. Could you shoot me an email. It would be much appreciated. Thanks.

    <Edited by Host>
  • pputnam Level 3 Level 3 (585 points)
    No Airplay button on my iPhone 4 either. Works great on my iPad.
    OOOps , just figured out why it isn't showing. I didn't have wifi enabled. Now it shows up. DUHHHHHH.
  • DoubleRR192 Level 1 Level 1 (0 points)
    Ok so where do i go to enable the wifi for airplay?
  • pputnam Level 3 Level 3 (585 points)
    Just make sure wifi is enabled on your iPhone in the Settings. I usually have mine disabled because it uses a lot of battery when you are out and about.
  • DoubleRR192 Level 1 Level 1 (0 points)
    Mine is always on. It is still not showing up anywhere in the volume controls. It doesn't even show my phone as an option in iTunes 10 volume control.
  • Paul Cozza Level 1 Level 1 (5 points)
    I was having a similar problem. I powered down my iPhone, then powered back on. Problem solved. If you haven't tried that, give it a shot.

    Message was edited by: Paul Cozza

    Message was edited by: Paul Cozza
  • Gester737 Level 1 Level 1 (10 points)
    After reading some of the posts about iOS 4.2.1 not worked I tried shutting down my phone. While it was booting I noticed my itunes was still set to play on my airport express. after I switched the speakers to play on the computer the button on my iPhone 4 came up on the ipod and youtube. See if all your devices (desktop, laptop, phone, ipod) aren't using the express if you want your phone to use it.
  • jameyfrank Level 1 Level 1 (5 points)
    I think I figured out the problem. My Airport Express had a different IP subnet (169.254.#.##) than my iPhone, iMac, and Mac Mini (all those were 10.0.0.##). I set the Express to DHCP, reboots and now it has a 10.0.0.## IP and airplay now works fine from my iPhone.
  • Colston Level 1 Level 1 (0 points)
    Great. Finally a solution which worked for me. Thanks. Try that guys, powering on and off is in my experience slightly pointless (but it can seemingly "solve" issues)
  • MarcHumphries Level 1 Level 1 (0 points)
    Have been looking for the solution for too long.... It's amazing what switching it off and on again can do! All sorted now and working well.
  • Nathan_A Level 1 Level 1 (0 points)
    I've found that you don't have to actually shut off the phone. It's sufficient to simply force-quit the iPod music app on the phone.

    You can do this by bringing up the multi-tasking menu, and then holding down on the icon until the little red "remove" circle with a white dash shows up. Touch that circle on the iPod music app. That actually fully quits the application. The next time you launch it, it should try to re-detect AirPlay compatible devices.

    Apple needs to update this app to include that service search routine into the reactive event for the iPod music app rather than in the initialization event procedures.
  • michele169 Level 1 Level 1 (0 points)

    hi i hope that you can find a solution to my problem..i have upgrade iphone 4 to 4.3.5 and then i can't use airplay becouse the icon is desappeared...what can i do?

Previous 1 2 Next