1 2 3 Previous Next 43 Replies Latest reply: Jun 20, 2012 5:04 AM by Mixta26 Go to original post
  • 30. Re: Airplay Stops Working
    timothy57 Level 1 Level 1 (0 points)

    this has been frustrating-  It's hard to have a party at the house with constant interuptions in the music.

    I read somewhere that IPV6 was the problem and that I should turn that off-  BOGUS-

    Finally in frustration I googled "Apple air play interption"  where the tribal knowledge suggested changing the wireless settings on my router (Cisco 4200) to a specific channel rather that automatic mode.   I picked channel 5-  it's been over an hour with no interruptions-  I really hope this is the hack to make it work.  /Tim in San Jose

  • 31. Re: Airplay Stops Working
    jamiezigelbaum Level 1 Level 1 (0 points)

    Here's what fixed this issue for me: 1) analyze wifi interference, 2) manually set wifi channel

     

    I downloaded NetSpot (free wifi analysis tool http://www.netspotapp.com/), loaded a floorplan of my office into it and walked around my space following NetSpot's protocol. After mapping all the wifi networks in my area I found that channel 8 (2.4GHz) was totally free. I changed my wifi router (an Apple Time Capsule) to channel 8 for the 2.4GHz range and channel 161 for the 5GHz range (there were very few other 5GHz channels visible during analysis). I left the Radio Mode on automatic since we have many people using the wifi here across various devices.

     

    I have an airport express that extends my main network. I use it with Airplay. I didn't change its settings at all (it is extending the channels set by the Time Capsule) and after the above I haven't had one interruption in music playing.

     

    Z

  • 32. Re: Airplay Stops Working
    bjksd Level 1 Level 1 (0 points)

    This is what solved this problem in my setup (MBP, OSX 10.7.2, Airport Express):

    (from terminal) networksetup -listallnetworkservices

    located interface then

    networksetup -setv6off Wi-Fi

     

    Tried changing the IPv6 settings in System Preferences, but neither "Link-Local only" nor "Automatically" works. After I set IPv6 off it starts working and as soon as I set it back to default it stops working.

     

    This also fixed my "Home sharing" problems

    Might have something to do with my no-good-no-name router, but it still might be worth a try...

     

     

    B

    .SE

  • 33. Re: Airplay Stops Working
    damienf8 Level 1 Level 1 (0 points)

    I just bought an iPad 2 and Apple TV v2 for my parents and spent all day trying to get airplay to work.  We upgraded our router to a high end Linksys.  Now airplay works fine when sending from my iPhone 4, but does NOT work from the iPad 2 or from my Macbook Pro.  I tried detecting the networks in the neighborhood and locking our router on channel 161.  Still, when playing from the iPad 2 or my Macbook pro, the audio is extremeley choppy.  Too tired to continue trying to fix.  This is very frustrating.

  • 34. Re: Airplay Stops Working
    Tom Alperin Level 3 Level 3 (705 points)

    This might help. You should be aware that your iPhone 4 only works on the 2ghz band and not the 5ghz band.  Your iPad 2 and Macbook Pro should be supporting the faster 5Ghz that your router must support since you have channel 161 set. I had skipping issues involved with a number of configurations including extending an network when it wasn't necessary to extend the network (music skipped when switching between routers), microwave oven usage, cordless phone usage, and IPv6 settings.

     

    Here's a thought, given the experience I've had with my network. I am assuming you have a dual band router. There may be issues with your 5ghz equipped devices switching between the radios and causing a skip when this happens.  The 5ghz band actually has a reduced range and I've had problems with my devices not staying connected to the correct radio unless I specify a different name for each band.

     

    I'm not familiar with the newer Linksys routers, but I bet there is an option to give each radio it's own network name. If so name them like: "mywirelessnetwork" and "mywirelessnetwork 5ghz."

     

    You should then delete the connection settings on both of your faster devices so that they don't still connect to the 2ghz radio. This should guarantee that they can't roam between the two radios.

  • 35. Re: Airplay Stops Working
    damienf8 Level 1 Level 1 (0 points)

    Tom, thanks for the reply.  I had the same thought and had already disabled the 2nd antenna.  The iPhone 4 works fine on channel 161.  The iPad 2 and Macbook Pro don't work on the same.

  • 36. Re: Airplay Stops Working
    Bob Timmons Level 9 Level 9 (78,635 points)
    The iPhone 4 works fine on channel 161

     

    Since Apple's specs clearly indicate that the iPhone 4 will only operate on 2.4 GHz wireless networks....and Channel 161 is a 5 GHz channel.....I'm wondering how you managed to configure the iPhone to work on a 5 GHz network.

     

    Can you share this secret?

  • 37. Re: Airplay Stops Working
    damienf8 Level 1 Level 1 (0 points)

    Bob, thanks for your reply.  I checked and you're right the iPhone 4 doesn't work on channel 161.  My best guess is that my iPhone 4 was connected to the router when I had it in dual-band mode and then when I changed it to 1 antenna on channel 161, it somehow didn't get booted off right away.  In any case, your comment made me think that perhaps I needed to be on a 2 GHz channel to make the Apple TV work, so I locked the single router antenna on channel 1.  Now the iPhone 4 works, my Macbook Pro works (yay), but the iPad 2 still doesn't work!  I tried "forget this network" and rebooting the iPad...no dice.  Weird.

  • 38. Re: Airplay Stops Working
    Tom Alperin Level 3 Level 3 (705 points)

    Is the router dual band? The problem isn't having both wireless networks going at the same time, it's that hardware either roams between the two networks or devices may not connect to the radio you intend them to.

     

    Did you check to see if there was an option to give each radio it's own network name? This should solve the problem and also force your devices to connect to the fastest network available. You should also make sure your Apple TV is set to connect to the faster network, although you shouldn't have any problems with it roaming. You might want to try a different channel for your 5ghz network to see if you can get it to work better as well.

     

    Do you have bluetooth enabled on the iPad? For some reason, my iPhone will skip when using Airplay sometimes if I have bluetooth enabled. Turning it off stops the skipping, although it doesn't do this all the time. I have yet to have this happen with the iPad, but it's something else to try.

  • 39. Re: Airplay Stops Working
    damienf8 Level 1 Level 1 (0 points)

    Tom and Bob, thanks for the help.  I eventually got it to work by making sure that the two networks on my dual band router had different names.  I guess the choppy playback was probably because the iPad was jumping between the 2 networks.  Anyways, thanks to your replies it gave me to motivation to keep fiddling with things until it worked.  Thanks!

  • 40. Re: Airplay Stops Working
    Raj Level 1 Level 1 (100 points)

    Although it seems like it's best to keep two different names for dual-band routers, which may help the iTunes issue, I have also got around the problem by using Airfoil, which will stream the audio from any (?) application on your Mac. It doesn't seem to have any trouble filling in where iTunes could not connect to my stereo via an Airport Express. It would be best to try to troubleshoot your router setup first, of course, but if you're pulling out your hair for a solution, Rogue Amoeba's Airplay works really well.

  • 41. Re: Airplay Stops Working
    digimouse Level 1 Level 1 (0 points)

    I have tried everything single thing listed on here to no success and finally called apple care and using my iphone as a gateway i spoke to a tech named Jared and solved the problem. we had to delete all apple software assiocated and then reinstalling them you dont lose anything when you reinstall. 

    instructions here: http://support.apple.com/kb/HT1925

    the tech said if that didnt work we would have to change some file names .

  • 42. Re: Airplay Stops Working
    InvernessMark Level 1 Level 1 (0 points)

    In the UK we don't have the option to change channels.  What I seem to have stumbled accross is changing the settings from 'extend an existing network' to 'join a network' and that seems to have solved the problem as far as airplay is concerned, though it means my Airport Express is now not doing everything it says on the tin!

  • 43. Re: Airplay Stops Working
    Mixta26 Level 1 Level 1 (5 points)

    I have the same problem & have tried all the so called fixes but to no avail. This is ridiculous and not what I expected from the superior technical powerhouse of Apple...it should be easy to stream music! I have wasted literally days over trying to sort this out over the last six months including calls to Apple support (condescending & patronising) trawling the web & trying all the router & channel settings, using only ethernet & switching the wireless off. It still drops out & turns off after an hour.  I've had enough, so it's for sale on ebay if you want it because I've found audio pro wf 100 which is brilliant.  It's a dongle (I know...more bulky) that creates it's own network independently & connects immediately...no software or airfoil to mess around with...no dropouts...lossless playback...brilliant quality playback through my hi fi, just what I wanted in the first place. Admittedly it's double the price but I've been so frustrated with the whole thing it's worth it!  Why oh why didn't Apple fix this?

1 2 3 Previous Next