1 2 3 4 5 Previous Next 73 Replies Latest reply: Dec 19, 2011 3:06 AM by bona123 Go to original post
  • 60. Re: Airplay from iPhone to Airport Express - no sound? (Dlink Router)
    itwastaken Level 1 Level 1 (0 points)
    Had the same issues, could see the Airport Express on the iPhone but no sound.

    Airport Express + D-link Router + iPhone + Windows 7 machine

    Here's some of the things I did to fix it:

    1. Connect iPhone to Windows 7 machine, sync.

    2. Connect Airport Express to small radio near router, computer, iPhone, etc., for testing.

    3. Login to your Dlink Router.

    4. Setup, Network Settings, DHCP Server Settings:

    Enable DHCP Server (check)
    Always Broadcast (check)
    NetBios Announcement (check)
    NetBios Note Type (Hybrid)

    5. Make a DHCP Reservation for each device on your network

    Save (Reboot if necessary)

    6. Setup, Advance, QOS Engine (optional):

    Create a QOS rule for your Airport Express with a priority of 50 (I used 1 rule for both because I set their IP addresses 1 digit apart)

    Save (Reboot if necessary)

    7. Setup, Wireless Settings, Manual Wireless Network Setup:

    WPA Mode: Auto (WPA2 or WPA)
    Ciper Type: TKIP

    Save & Reboot

    Try the iPhone. If it works but other devices on your network get knocked off, change back each item above but test first--1 change at a time starting with the wireless security settings first. Also, try moving the Airport further away, 1 room at a time until you get it to its final destination.



    Sampling of my system devices used w/ AirPlay:
    iMac i7
    HP laptop w/ Windows 7
    D-link DIR-655
    D-link DAP-1522
    2 Airport Express
    iPhone4

    Message was edited by: itwastaken
  • 61. Re: Airplay from iPhone to Airport Express - no sound?
    sarl Level 1 Level 1 (0 points)
    I had the same issue with Airplay streaming from my iPhone 3GS to my Apple TV 2. It was working perfectly until suddenly it was no sound, although it the iPhone was connected and appeared to be streaming. I tried all the different advice in this thread, but what finnaly resolved the issue was a reset of the ATV2 (pressing the down and menu button for six seconds).

    Hopefully this will help some of you as well.
  • 62. Re: Airplay from iPhone to Airport Express - no sound?
    Brantman1 Level 1 Level 1 (0 points)
    Having the same problem as the first poster. Am able to stream music from my MacBook to speakers plugged into my AirPort Express perfectly but not able to from my iPhone 4. It worked for the first few days I had it set up and then quit working abruptly. Every once in a while it will connect and work great but then if I disconnect and try to reconnect it won't work again. The AirPlay button on my iPhone turns blue like it's connected to the network and the songs appear to be playing but no sound.

    When I looked in the AirPort Express' log I found a few entries that read this:
    "airtunes time sync receive error: -6710" and when the iPhone did connect successfully I was able to see that in the log as well but when it won't play but appears to connect the log will show no activity.

    It sounds like some people are having success switching their Connection Sharing to make sure a public IP address is shared but I have to keep mine in off in Bridge Mode because I also have my modem connected to an At&t 3G Microcell. Any ideas out there? Thanks!
  • 63. Re: Airplay from iPhone to Airport Express - no sound?
    migzy Level 1 Level 1 (0 points)
    resolved my airplay problem by rebooting my iphone 4 firmware 4.2.1

    setting on my airport express are as follows

    Airport tab

    firmware 7.5.2
    wireless network created 802.11n
    encryption on

    Internet connection tab
    Connect using ethernet
    Connection sharing off (bridge mode)
    Tcp/IP manually set
    Dns setting from router

    Think airplay is just flackey on the iphone
  • 64. Re: Airplay from iPhone to Airport Express - no sound?
    Brantman1 Level 1 Level 1 (0 points)
    Yeah, that's what my setup is too but no luck. Tried hard resets of all devices: iPhone, AirPort Express, modem; tried restoring iPhone as a new phone, tried downgrading firmware on AirPort, tried manually switching channels on the router in case of interference, tried turning IPv6 off... Still getting same results, am able to stream from my MacBook perfectly but not from my iPhone. It will work maybe one out of twenty tries.
  • 65. Re: Airplay from iPhone to Airport Express - no sound?
    edoublea Level 1 Level 1 (0 points)
    Identical problem for me...

    Brand new AirPortExpress (7.5.2) is connecting to my existing Linksys WiFi network.

    Two iMacs on the network can both stream via AirPlay to the AirPort with no problems.

    Two iPhone4s and one iPad can all select the AirPort as a speaker source, but no sound comes out when streaming from those devices. The app seems to think audio is streaming normally, but no signal is coming from the AirPort audio jack.

    All devices have the latest firmware.
  • 66. Re: Airplay from iPhone to Airport Express - no sound?
    jtaylor210 Level 1 Level 1 (0 points)
    Hello "edoublea",

    I had an identical problem, albeit with a slightly different setup. I could play tunes from my MacBook to the Airport Express, but my iPhone4 (iPod app) just showed the airtunes icon ok without actually making an audio connection through it. No sound, no error message.

    At that time, my MacBook and my iPhone were connecting to the internet via an [ageing] Netgear wireless router. Also my Airport Express was connected to the Netgear wireless network. My Airport Extreme is also connected via patch cable to the Netgear router.

    Now I can successfully play tunes from iPhone to my Airport Express.

    What adjustment did I make?

    I switched all my settings away from the Netgear wireless network and on to the Airport Extreme wireless network. In other words, the MacBook and iPhone now connect to the internet via the Airport Extreme (which, as I mentioned, is cable-connected to the Netgear router). The Airport Express no longer joins the Netgear wireless network, instead, it hooks on to the Airport Extreme wireless network. With those changes, the music stream from the iPhone to the Airport Express "miraculously" re-appeared.

    My tentative conclusion is that the router had been overloaded, whereas the Airport Extreme can cope okay with multiple devices.

    Good luck.
  • 67. Re: Airplay from iPhone to Airport Express - no sound?
    Crystalkong Level 1 Level 1 (0 points)
    I have the same problem. I tried changing the IP address & rebooting but nothing works. Can someone help me please?
  • 68. Re: Airplay from iPhone to Airport Express - no sound?
    dmichaelson Level 1 Level 1 (0 points)
    *My setup:* Old Airport Express connected by an ethernet cable to Linksys WRT54G router. Newest model iPod Touch/iOS. I just get silence when I stream from the iPod Touch. I can stream fine from iTunes on Mac (latest OS X).

    *Didn't help:* The AE and the Linksys router are on the same subnet. The iPod Touch and the Mac use the same router address (the Linksys's). Using a static IP or DHCP for AE didn't make a difference. Hard reboots on iPod Touch, AE, and Linksys didn't help.

    Solution!: The "Wireless Mode" was switched to "Off" in the AE (since the Linksys router is providing the wifi, and the AE is right next to it, just being used for music streaming). This is in Airport Utility -> Manual Setup -> Airport tab -> Wireless sub-tab. Switching this AE setting to "Join a Wireless Network" (and choosing the Linksys's wifi network) has solved the problem for the iPod Touch, and I can still stream from the Mac.

    Note that I did do "Restore Default Settings" in the AE when creating this setup. However having done so, simply toggling the "Wireless Mode" setting between "Off" and "Join a Wireless Network" recreates the problem (no streaming on iPod Touch, yes streaming on Mac) and the solution (streaming on both), so I think the solution is that setting, not the act of restoring to default settings.

    Discussion: I'm not sure if there's any performance disadvantage to this (I think there only even could be if you sometimes want to access the AE via the wired LAN?), but it's working fine. I've subsequently rebooted my iPod Touch and streamed from both it and my Mac, and it still seems solid at least so far. Surfing the internet is also unaffected.

    By default the AE will be using DHCP and this works (Under Internet -> TCIP/IP), but I've also switched it to manual IP address and this works too (assuming you enter valid numbers).

    A clue might be that when you do the "Assisted Setup" wizard in Airport Utility, switching the wifi off is not even an option. When you pick "Use this AE only for music streaming and printing," it produces the "Join a Wireless Network" setting in manual setup which is the one that works.
  • 69. Re: Airplay from iPhone to Airport Express - no sound?
    TennisPerson Level 1 Level 1 (0 points)
    Same thing happened to me, I could play music through iTunes. To get it to work, I turned off my device and then back on. The AirPlay icon appeared, I clicked on my AirPort Express, put in my password(if you have one), and waited. It takes longer for the tunes to start streaming from an iPhone than a Mac on iTunes.
  • 70. Re: Airplay from iPhone to Airport Express - no sound?
    Wouter Konings Level 1 Level 1 (0 points)
    I have managed to stream music using an iPhone 4 to my sound system through an EA, but that requires my iMac iTunes to be active, and I need to set iTunes to the EA.
    I prefer to be able to stream my iPhone music directly to the EA without the need to have my iMac running.

    I have the latest iOS on my iPhone 4. Configured my EA standalone to be independent of my iMac. My iPhone recognises the EA network, but I cannot stream any music to it because the Remote App wants me to set up the music library on my iMac and type the 4 digit code there. Is there a way to stream music to the EA without using my iMac?
  • 71. Re: Airplay from iPhone to Airport Express - no sound?
    lionelfromst-jean Level 1 Level 1 (0 points)

    SOLVED:

     

    same thing for me, iMac streaming to AE from itunes perfectly, iphone 4 and ipad finding AE, airplay turning blue but no sound on the peakers. AE 6.3 (old one). all the latests firmware everywhere. wifi router Freebox Revolution (France). Solved issue by turning off the "802,11,n" in the wifi settings of the Freebox Revolution router. Those first models of AE don't support n wifi ...

  • 72. Re: Airplay from iPhone to Airport Express - no sound?
    gregfromwhangarei Level 1 Level 1 (0 points)

    I have the iPhone 4s. Initially, no sound through my Airport Express. I installed Airport Utility, restarted the iPhone and it all worked fine. Not sure if Airport Utility was necessary.

  • 73. Re: Airplay from iPhone to Airport Express - no sound?
    bona123 Level 1 Level 1 (0 points)

    I had the same problem with sound working from Itunes (mac) but not via iphone or ipad.

     

    I resolved it by removing an old pre-N router (from netgear, 240 something) from the network.

1 2 3 4 5 Previous Next