Previous 1 2 3 Next 37 Replies Latest reply: Jun 13, 2015 4:06 PM by Kimbybean Go to original post
  • Roger Green Level 1 Level 1 (90 points)
    Earlier this week I updated my iPhone 4 and iPad to iOS 4.2.1. The iPhone would display the icon to connect to my AXs (2), but I couldn't find an icon to connect the iPad anywhere. The solution for me was to simply reboot the iPad (hold down sleep/wake button until you see "slide to power off"), and then when iPod was started, the icon was there, next to the volume slider. Works perfectly.

    Hope this helps somebody.
  • alllyn Level 1 Level 1 (0 points)
    Reader Nate was eager to download the new iOS update and get up and running and streaming with AirPlay. He was however, very disappointed to learn the wireless streaming technology was not supported on his 1st generation Apple TV.

    He sent this message to Steve receiving a reply almost immediately:

    Steve,

    Why no airplay support for 1st gen. apple TV? I payed good money for this device.



    Steve’s reply:

    It’s different technology. It does everything it did when you bought it.

    Sent from my iPhone

    It has often been the case with new Apple technology that the early adopters are often considered the beta testers of the technology. Apple seems to be a very forward thinking company and not hesitant to abandon support for old devices such as older generation iPhones. I guess Nate found out the hard way that Apple and technology must progress forward and may not support the latest new features.
  • AkinKaplan Level 1 Level 1 (0 points)
    I have a similar issue where my ipad was not able to see apple tv (no airplay icon).
    After trying everything (on/off, restore, etc.) I finally solved the issue. You should disable "User Isolation" in your modem settings under Wireless section. When enabled, your modem does not allow you wireless devices to communicate with each other thus your ipad can't see your apple tv.
    When this is enabled but your apple tv is connected to an ethernet cable you can still use the airplay.
  • Lynkus Level 1 Level 1 (0 points)
    AkinKaplan, that's a thought. I finally purchased an AppleTV, and still no AirPlay icon. So, I've spent about an hour trying to troubleshoot. The "User Isolation" is called "Public Secure Packet Forwarding" on cisco's equipment, and it is disabled on my radio; hence, all clients can communicate with each other.

    It'd be *really nice* to know how these iDevices are trying to setup the AirPlay session. Does anyone know where I can find technical documentation on the protocol? I can ping my iPad's addy from another wireless client, so ICMP is working. This is odd, and like many other Apple products, technical documentation seems virtually non-existent.

    alllyn wrote:
    ... It’s different technology. It does everything it did when you bought it.

    Sent from my iPhone


    BTW alllyn, your little story doesn't have any relevance here. In fact, "it DOESN'T do everything it did when I bought it." If I could continue to stream from iTunes to my Airport Express, as I was able to do when I bought it, I wouldn't be making such a fuss. To the contrary, the iPad's software update broke that functionality.
  • Lynkus Level 1 Level 1 (0 points)
    Finally, I'm getting somewhere (obscure)! I may just have to move my Airport Express to the wired segment and start capturing packets. Just a moment ago, I got an Airplay icon on my iPad, but here's the unacceptable how: I attached a second Aironet 1242 with a fresh SSID to the wired segment.

    In other words, I'm bridging wireless to wired and back, across two distinct wireless "networks" both of which share a common network address.

    So, there you have it! *The Airplay protocol doesn't work on all access points.*

    If I can figure out a way to hack it on a single AP, I'll post another update. On the other hand, if someone out there can point me in the direction of an IETF RFC-esque document describing the Airplay handshake, I'd greatly appreciate it. Good luck!
  • Lynkus Level 1 Level 1 (0 points)
    I'll be darned. My setup is working now. The break in functionality shouldn't have been there, but was caused by my AP's station role. I had my AP defined as a "Root Bridge with Wireless Clients." Thankfully, I can get away with resetting its role to "Access Point," which is now working.

    I'm still interested in any technical documentation that someone can provide.
  • pincus321 Level 1 Level 1 (0 points)

    Hi all,

    Maybe if I relate my experience this will clarify your issues.

    1. I use a Billion router for my Wireless anyone who has used a Billion will realise that playing with the the security and some of its features can cause lots of issues with connectivity.  For example packet filtering can really clobber your access even for someone who knows what they are doing.  Secondly Intrusion detection has caused me numbers of intermittent disconnects and blacklists of https sites.

    2. I have recently started using FaceTime and for older members in the family I wanted to put it up on my Apple TV.  So after getting my Apple ID correct for my Mac, iPad and iPhone all with the correct software versions my iPad would not work but Facetime would. Recognise there is a connection here, the Apple ID is correct.

    3. Well if you do not see the Airplay icon you can guarantee that the device cannot connect to the AppleTV.  So if you put the Apple TV to sleep does it connect to your router when it wakes? Well if you cannot see the Airplay icon you can bet your AppleTV has gone offline. So for a Billion, you have to forget the network and connect again.  See the icon you are working again. So the router and most importantly its reputation for buffering, connectivity speed etc make all the difference. Lets face it an Apple Airport is a Lucent buy in.

    4. Next if you can say connect your Mac Computer and iPhone but not your iPad chack your Apple ID for iCloud if it is not the same on all devices it wont work, obvious you say.  Well if you have changed it and still cannot see the icon try turning off the iPad.  The icon will probably return.

    5. In my case I have a screen saver which is using my iPhoto library for random pictures, do you get Bad connection errors, look at your router.

    Hope this helps

  • Kimbybean Level 1 Level 1 (0 points)

    I recently had to reset my modem and I guess it re-enabled the AP isolate feature because my airplay was always a available before. AP isolate is how its listed on my surfboard 6580 modem. Because of you, I have now disabled it and I now have my airplay icon back. Thank you so much. You have saved me a big headache  from getting worse. have a WONDERFUL DAY AND THANKS  for sharing . 

Previous 1 2 3 Next