Previous 1 2 3 Next 91 Replies Latest reply: Mar 13, 2011 2:25 PM by Darmok
Syth Level 1 Level 1 (45 points)
I connect to a mail server that has a self-signed certificate. Under previous versions of iOS, this meant that I would have to allow the server connection once after a phone restore or update; however under iOS 4.2.1, I have to allow the certificate every time I access mail after the phone has been idle for the 'lock' time.

Can I get iOS 4.2.1 to trust the self-signed certificate the mail server uses?

MacPro Quad Core, G4 1000bT, MacBookPro, mini server, Mac OS X (10.6.5), 10.6.5 Server on MacPro
  • mordzy Level 1 Level 1 (0 points)
    when verifying the account it should prompt you regarding the 'not trusted' certificate.

    i have seen this on ios 4.1 and 4.2 today.

    you can choose to accept the certificate.
  • kevinmoore73 Level 1 Level 1 (0 points)
    I am having the exact same problem. Have you found a fix? I really don't want to buy an SSL cert.
  • Bruno L. Level 1 Level 1 (0 points)
    This is also an issue that I've been experiencing since upgrading last night. I called Apple Care, but as my phone is over the 90 days initial phone support period, the person I spoke to couldn't really help. She suggested to delete my accounts (I've got 5 with this issue) and recreate them, which I had done this morning, to no avail. She also suggested to create a new server and turn off SSL, but that didn't work either. Looks like I'm in for a trip to the Apple store. Whether that'll help is another story...
  • Bruno L. Level 1 Level 1 (0 points)
    I seem to have found a resolution for this. I had a user name and password in my Outgoing Mail Server info, I have now removed these as they appear to be optional. You will probably still get the verification message a couple of times while setting up your accounts or modifying your settings, but once this is done, go back into Outgoing Mail Server and make sure SSL is turned off. I've recreated all my accounts, and so far, so good.
  • kevinmoore73 Level 1 Level 1 (0 points)
    I do not consider disabling SSL and authentication to be any solution at all. Sure they're optional, but using SSH instead of Telnet is optional too!

    Also, you'll still be prompted to accept the self-signed cert on the incoming mail side even after disabling SSL/auth on the outgoing side.
  • Bruno L. Level 1 Level 1 (0 points)
    I am not really technical at all, so I am not sure I fully understand the subtlety of it al, but I haven't been getting any message at all since I've done this, either for incoming or outgoing mails, and believe me, I tried sending and receiving emails a few times from each of my accounts before posting on here. Whether this is the solution, I can't say, but it is currently working for me, and thought it might be helpful to others. It looks like it is saving me a trip to the Apple store, which is definitely a plus.
  • rebby Level 1 Level 1 (0 points)
    I am having the same issue as well. 3G running 4.2.1. Disabling SSL is not an option for me and, as others have already stated, I'd hate to purchase an SSL cert when what I have is working just fine otherwise.
  • kevinmoore73 Level 1 Level 1 (0 points)
    I broke down and bought a cert today. It's a shame, but that MobileMail pop-up window was driving me crazy.

    Message was edited by: kevinmoore73
  • Dr_Stein Level 1 Level 1 (0 points)
    I am also affected by this. Both my iPhone 4 and my iPad 3G now display the certificate error "Cannot Verify Server Identity" when I wake the device up and send an email. I get it for both incoming and outgoing email.

    I can click "Continue" and it works. I can click "Details" and "Accept" and it works. BUT I do not want to have to do this whenever I try to send mail after waking the device up. I know my mail server, I signed the certificates, and I am OK with its level of security. However, there seems to be no way to tell iOS that the certs are OK and safe to use and not bug me about.

    This is not good. :/
  • fhdogs Level 1 Level 1 (0 points)
    Someone please help... Or apple fix this asap... With nearly 15 domains, I'm not about to buy private certificates. Why can't I accept it once, or trust the site like I always have before.
  • Syth Level 1 Level 1 (45 points)
    Well, at least I am not the only one. It is very annoying as sometimes I get the dialog up to 8 times when waking up my iPhone.
  • lihuihz Level 1 Level 1 (0 points)
    i got the same issue, any solution for it? or waiting for iOS 4.3
  • Aaron Goldman Level 1 Level 1 (35 points)
    Hello all,
    Can someone please explain (in non-techie terms) why we should or shouldn't use SSL when setting up an exchange account. I had it on, but was continually getting this same error after upgrading to 4.2.1. I just tried turning SSL off as suggested here (thanks Bruno), and I am no longer getting the error. Is my email going to be less secure now?
    Thanks.
  • kevinmoore73 Level 1 Level 1 (0 points)
    The short and simple answer is that yes, it will be less secure. Any unencrypted communication is less secure than encrypted communication.
Previous 1 2 3 Next