Previous 1 2 3 4 Next 48 Replies Latest reply: Jul 4, 2013 6:43 AM by Marbono Go to original post
  • GeorgeSpence Level 1 Level 1 (0 points)
    This worked for me too.
  • Paul Braun1 Level 1 Level 1 (15 points)
    That's what mine does. I can stream a movie that I ripped and transferred via iTunes, but podcasts and songs look like they're playing on the iPhone4, but the little "wheel of waiting" never starts up and the stream never plays on the ATV. Both have the latest versions of everything.

    Also irritating -- the fact that I can't stream a video clip that I took directly from the photo album/video player. Apparently I'm expected to import it into iPhoto first, then import it into iTunes, then transfer it to the iPhone? Why can't I just stream it directly from the phone without all the extra labor and translations? DRM shouldn't apply - I took it myself with my own camera.
  • romtrans Level 1 Level 1 (0 points)
    I have tried everything but still not able to use airplay from my Iphone 3GS or 4 to run music like pandora, youtube works fine. What else can I do????
  • Lodoe Namgyal Level 1 Level 1 (10 points)
    VERY BADDDDDDDDDDD, I HAVE THE SAME PROBLEM. VIDEO WORK FINE. BUT NO MUSIC, NO ICON VERY BADDDDDDDDDDD. I AM HAPPY THAT I AM STUPIT, OTHERS HAVING SAME PROBLEM,, =VERY VERY BADDDDDDDDDDDDDDD...
    LODOE
  • sevgy Level 1 Level 1 (0 points)
    Same here. I have a very simple network, a Netgear N300 running WPA2 with everything connected to it. I can play videos from iPhone and iPad both running iOS 4.2.1. When I try to Airplay music, usually nothing happens at all on the Apple tv. Sometimes the artist name shows up. Once or twice the music plays for a few seconds. How is it that video works but not audio? Very strange.. has to be a software issue.. many people I know don't have this problem though..
  • John Muccigrosso Level 1 Level 1 (100 points)
    Similar problem with my iPod Touch.

    1. Video Airplay works fine.
    2. No Airplay icon in Music.
    3. Reboot.
    4. Airplay icon in both, but doesn't work in Music. The iPod thinks it's working, but no sound from via the ATV.
  • John Muccigrosso Level 1 Level 1 (100 points)
    Another reboot and still nothing, but then it suddenly worked. No clue why.
  • Glazunov2 Level 1 Level 1 (0 points)
    Try unplugging the apple tv for a minute and making sue there's no static - that was what caused this problem for me.
    It's sorted now and no need for reset.
  • DF503 Level 1 Level 1 (0 points)
    I have replicated the issue over and over again and here's what I have found (after performing 2 factory resets on my iPhone 4).

    I has to do with my iPhone 4 attempting to override a movie playing from my desktop iTunes collection. If you send video from your iPhone 4 to the ATV while the ATV is already playing movie content, the iPhone 4 overrides the playing content. If you attempt to send audio from your iPhone 4 to the ATV while the ATV is already playing movie content, the iPhone 4 will switch the audio output from ATV back to the iPhone speaker within a second. If you then again attempt to change the output to the ATV for a second try, it will cause issue to be replicated.

    It appears that the issue in question is software bug in the AirPlay network connection code of the iPhone 4 iOS, not the ATV since a reboot of the iPhone 4 or toggling the airplane mode off and back on resolves the issue.
  • hughg Level 1 Level 1 (0 points)
    I had exactly the same problem of airplay working fine for photos and video but not for music.

    It looks like it is the Apple TV screensaver getting in the way somehow and blocking the iphone music player. Once the screensaver is turned off, I can stream music no problem (airplay icon appears as it should).

    Hope that helps.
  • Mainemannak Level 1 Level 1 (0 points)
    Possible fix. I was having the same issue. I tried everything you did. But...I did a restore on my ATV and it fixed it. Had to go through the long setup process again, but airplay work great from both iPod Touch and iPhone 4. Hope this helps.
  • Christopher Nelson3 Level 1 Level 1 (35 points)
    Thanks for pointing that out! Seems to work for me- I tried turning airplane mode back off after I started streaming and it continued to stream well.
  • Snaky Level 1 Level 1 (0 points)
    I'm having the same issue as Matt. Did anybody find a solution to this yet? Airplay icon appears in iPhone when watching pictures or movies, but not when listening to music.
  • zub3qin Level 1 Level 1 (10 points)
    Same problem here.
    Have Apple TV, Macbook, iPad and iPhone. All updated to the latest OS versions.

    Movies (including youtube) streams fine from iPad or iPhone to Apple TV using Airplay.

    But music alone won't. So if I play a song on iPod or Pandora, I get the Airplay icon, I select Apple TV, but no audio comes out of the apple tv. It thinks it is streaming, but it isn't. But movies (with the corresponding audio) streams to Apple TV fine.

    On the other hand, music from my macbook goes to Apple TV fine.

    It is just streaming music from iPad and iPhone that doesn't work.

    Note, my problem is not that I don't get the Airplay icon-- I do. It just thinks that it is streaming and nothing is happening.

    I've rebooted Apple TV, iPhone and iPad. No success.

    Anyone else seeing this? Any thoughts?
  • Doniso Level 1 Level 1 (0 points)
    Fist of all, sorry for my english.
    I had the same problem, videos from itunes or youtube works fine, but when I tried to stream only audio, from ipod aplication or spotify it doesn´t work. Some times make a little noise, other times the conexion returns to the iphone or ipad...ant many times the wifi of the phone or the ipad hangs, and have to reboot...
    I´ve tried many things, with two diferent routers (both of them wireless n), different configurations, open ports, went to the genius bar, even broke a router (it hangs and there wasn´t any way to restore, even with a hard reset)...
    Finally, today it starts to work. What I did is:
    1. Change wifi channel to 9.
    2. Disable WSC setup in my router configuration.
    3. I think this is the most important: enable WMM (wifi multimedia) on the configuration of my router. It´s a comtrend model, maybe this is called in another way in other router configuration.
    4. And reset my apple tv (menu+down 5 secs).
    Probably it´s not necesary to make all these steps, looks like point 3 is the different from previous attempts...
    So check your WMM router configuration and try.
    Hope it helps.