10 Replies Latest reply: Feb 21, 2012 9:40 PM by oskar arturo
netslacker2000 Level 2 Level 2 (265 points)
I have just a handful of applications that when I try to update the the app store app prompts me for a password to my other account which the apps were not purchased on. All the apps were validly purchased on the first account, but now the apps are associated with my second itunes account and I can't update them. I've gone into the app store app and set the account to my first account but that does nothing for the update, it keeps prompting me for my password for my second account. I need it to switch back to the first account for these few apps. What's odd is that every other app updates just fine and are associated with the correct account, except for just these few. Any thoughts?

The message I get is that "this discounted price is only available to owners of previous versions.... blah blah." well, I own the previous version, that's how I got it on the iPad. But it's a different account. The update prompt does not allow you to change the username/email, only enter a password. Anyhoo, this is getting annoying.
  • nick101 Level 4 Level 4 (3,645 points)
    Have you treid logging out of the app store completely, then logging back in?
  • netslacker2000 Level 2 Level 2 (265 points)
    Yes, I have. I've tried logging out, then trying to update (so no account is logged in) but it just prompts for the wrong password. If I enter the password (although it's the wrong account) it tells me I must own the previous version. This is only a problem for 3 apps, every other app that I update asks for the correct password. Just these 3 got confused.

    I'd re-install them but then I'd lose game progress. Since one of the apps is Angry Birds I'm kinda trying to avoid losing the progress otherwise my 6yo will be upset with me!
  • nick101 Level 4 Level 4 (3,645 points)
    Maybe an email to the App Store - there' a report a problem facility somewhere in iTunes

    Message was edited by: nick101
  • dr00t Level 1 Level 1 (0 points)
    This is due to someone downloading certain apps under a different Apple account. The way to resolve this is to identify, using the list of apps in the update area you are seeing, which apps are yours and which apps were originally downloaded using the other account ID.

    If this is too hard, as it was in my case, I simply erased all the apps one by one in line with the list. As I erased them, I would periodically check the update list to see the apps disappearing. Once they all went away, or once all the apps downloaded with the other account are gone, you should no longer experience the prompt for the account which you cannot access.

    Like I said, if you know which apps were downloaded with the other account... then cherry-pick them for deletion. Otherwise, just erase them all.... JUST the ones in the update list... not all the apps on your device.

    Good luck.
  • netslacker2000 Level 2 Level 2 (265 points)
    Well, that's the thing.. I have both accounts.

    The real problem is (err, was) is that I purchased the app on account A, but then purchased or installed other apps from account B. When I went to update the app (originally purchased on account A) it was now prompting for the password from account B. If I entered B's password it would just say that I had to own a previous copy of the app. There was no way to get it re-associated back to account A - the account that had the record of its purchase. It's an error/bug in iOS 3.2 (?) as I've seen it now a couple of times on the iPad (but never on my iPhones or iPods).

    The only solution I could come up with was to delete the app (and lose all of its app data - which is what I was trying to avoid all along) and reinstall it from the original account.

    Either way, problem solved.
  • rickstar Level 1 Level 1 (0 points)
    I ran into the same problem. I had purchased apps using more than one account. When updating apps, I would get errors. Here's what I did to fix it . . . not easy, though.

    First, attempt to update your apps on the PC. This will update all of the apps associated with the current account on iTunes.

    1) Double-clicked in Apps iTunes (on PC)to open the Apps in another window
    2) Arranged windows so I could see both my apps window and the main itunes window side by side.
    3) Select an app in the apps window
    4) Click on the down arrow right next to the name the Name column which and choose the app name from the drop down list. This will open the app info from the iTunes store in the main iTunes window.
    5) Compare the versions. If the Store version is newer, delete the app from the iPhone and from the PC.

    Repeat for each app.

    Time-consuming but it works.
  • Nexifer Level 1 Level 1 (0 points)

    I did this on iPad.  Haven't tried on iPhone yet. Go into store. Click on purchased tab. At the bottom left it shows which acct is being shown for purchases apps. Click on it and sign out. Then sign in with correct acct. It works!  Been having same problem for a long time. 

  • stocis Level 1 Level 1 (0 points)

    did you manage to solve this issue?

    please do let me know if you did and how.

  • Nexifer Level 1 Level 1 (0 points)

    I have tried without success on the iphone using the same procedure.  Not sure why it worked on the ipad and not the iphone...  Will continue trying.

  • oskar arturo Level 1 Level 1 (0 points)

    I have the same problem with a 4s running ios 5.0.1 and the only way i managed to update apps is on the mac using itunes which is just a pain in the ***