Previous 1 2 3 4 Next 45 Replies Latest reply: Jul 23, 2015 10:42 PM by sripradha
DoubleRainbow Level 1 (0 points)
Hello! Yesterday, my Macbook didn't start up properly after falling asleep (not sure why), so I manually shut it off. After it restarted, I noticed that the two-fingered right click wasn't working properly. I can still scroll with two fingers, and I can right-click if I use a mouse. But the trackpad two-fingered click doesn't work.

I've restarted my computer twice, and I've tried turning the two-fingered right click setting on and off in System Preferences. Do you have any advice or suggestions? Thanks!

Macbook, Mac OS X (10.5.8)
  • Mark Fitch Level 1 (35 points)
    I had the same thing happen recently, then all of a sudden it started to work. The two finger swirl worked but not right click. Very strange.
  • lapoota72 Level 1 (0 points)
    Hi there I have been looking for anyone else with the same problem as I have been experiencing and this is the closest that I have come. I purchased the 13" Macbook last December (Just over a year, typical!)
    Everything working fine one day and then the next no secondary click. At first I wasnt sure that the trackpad was working at all or that it was clicking but after checking and playing a little with the preferences the trackpad pretty much got back to working ok. The only thing now is that the right-click function where you click on the bottom left or right of the trackpad no longer is working.
    The two finger secondary tap is working ok. If you take the click off and change it all then it still doesnt appear to help even with a few restarts.
    Also the login screen what we normally did was to navigate to the user and click on the name and then enter the password etc. Now I have to use the cursor keys to highlight the user and enter the password.
    It is this that is making me wonder whether it is a software problem rather than a hardware problem in that if it was the button underneath that was broken then why would it affect the login in screen?
  • newbiemacuser2006 Level 1 (10 points)
    I am trying to "rename" a folder. How do I do this when my "two finger" method isn't working?

    I used to put pointer and middle on the trackpad, and thumb on the bar...that no longer works.
  • Adam White Level 4 (1,315 points)
    Has anyone tried the old Ctrl+click method. It was there in the beginning and it is still the backup way to do a right-click.

  • newbiemacuser2006 Level 1 (10 points)
    Well, THAT worked!
  • splizaat Level 1 (0 points)

    I know this thread is old but I had the same problem on my 13" Mid-2009 macbook pro. For some reason with the option to click bottom right corner of the trackpad and have it act as "secondary click" I checked and unchecked, restarted, looked for updates etc.


    THEN i fixed it.


    In apple menu>preferences>expose & spaces. Goto Expose Tab up top and make sure that "ALL WINDOWS:" says "F9" in the closest box. And mine DID say "secondary click" on the other option but i set it to "-" and now my right click works. Hope this helps you all It worked for me...

  • laurafromottawa Level 1 (0 points)

    This happened to me, too. I went to the Apple icon in the top left corner, and chose "Preferences". Then I went to Track Pad. There's a video playing but I didn't watch it (because I'd seen it before). On the left, the check mark beside "secondary click" was gone under the "two finger" menu. So I turned it back on. I think it happened when I got a software update, not sure.

  • mattiacore Level 1 (0 points)

    I have a 3 month old MacBook Pro running on 10.6.7. Today, single tapping and the secondary two finger click stopped working. Tapping the track pad gently - no pressing - will not do anything (opening links, selcting files, opening folders etc.), and tapping it gently with two fingers will not do the secondary click either. However, if i actually *press* the trackpad, then it will. finger srcorlling, swiping, pinching and all that seems to work fine. only the "gentle tap" (no actual trackpad clicking) doesnt work anymore. I had to select press bottom corner to get the secondary click function for now


    Any leads anyone?

  • chrisfromhopewell Level 4 (1,085 points)

    System Preferences > Trackpad

    Under the 1 Finger section mark the boxes that you want to have marked and  to make sure that it's the right thing hover over it and it will show you an example video of what it does.

  • laramae Level 1 (0 points)

    splizaat, thank you so much for your hint! i understand this is an older thread, but i've almost gone nuts over this secondary click thing -- just have my macbook for 5 months, and love it dearly, but i always used ctrl+click as i couldn't figure out why tapping/clicking with two fingers wouldn't work. today at 4am i snapped and decided to find a solution, no matter what. and after raiding the net and finally registering on here, i find your suggestion and it's EXACTLY THAT. i wasn't sure it would do it for me since meanwhile we have lion, but it's the very same thing. i was worried it might be a bug with my macbook at first, then realised some preferences must be contradicting without being able to find out which as i only tried trackpad constellations..

    anyway, long story short: THANK YOU SO MUCH. you saved me so much trouble! and after my thorough research i have to say you seem to be the only person on the net who figured this out

    (i just had to express my deepest gratitude in this absurdely long post, couldn't help it)

  • Cliff Kwok Level 1 (0 points)

    Hi, I really got nut on how to set the right click under boot camp environnent.


    Dear Splizzat and laramae,

    are you saying set in Expose - all secondary click or just some?

    I can't get the same result as you say, would you mind to instruct me the step how to do it?


    Thank very much



  • laramae Level 1 (0 points)

    Hi Cliff,


    I'd love to help you out and wanted to upload snapshots of my preferences, but they're in German unfortunately and hence I realised it probably wouldn't help that much.


    Anyway, I'm not familiar with boot camp, but these are my settings: In Mission Control i set all Mssion Control, programme windows, view desk and view dashboard to "-" (hope the labelling is somewhat accurate, I'm really not sure about the German-English conversion); and under Trackpad i set secondary click to "click or tap with two fingers". Note, I couldn't have "move with three fingers" activated, too, just as intelligent zoom - "double tip with two fingers".


    I reckon this is total amateur talk I'm producing here, it's just what I figured out works for myself If you need more information, I'd be happy to help!


    Best wishes,


  • Cliff Kwok Level 1 (0 points)

    Hi Lara,


    Thank you very much for your kind assistance.

    I fixed it. For me, I am using bootcamp, what I needed to do is download Bootcamp 1.0 first (which is hard to find) and the trackpad will be fine after bootcamp installation.


    Thanks again.


    Cliff Kwok

  • laramae Level 1 (0 points)

    Hey Cliff,


    Glad you worked it out! Sorry I wasn't much of a help though. But it's very friendly of you to pretend my noob-talk wasn't totally useless


    Best wishes,


Previous 1 2 3 4 Next