Previous 1 2 3 4 Next 45 Replies Latest reply: Jul 23, 2015 10:42 PM by sripradha Go to original post
  • airpirate Level 1 (0 points)

    If anyone is still hung up on this.. Provided your trackpad is not mechanicaly bad.


    Go to trackpad under system preferences and look under "secondary click" and you will see a little drop down menu. There you can select the option you want, two finger tap, or actial click on bottom right of trackpad etc.

  • Masrook Level 1 (0 points)

    I had the same problem, but I was able to fix it

    Go to System Prefrences > trackpad and check if you have checked both one finger secondary click and two finger secondary click. If that is the case uncheck the Two finger secondary click. Here you go the secondary bottom right/left click will work all fine.


    All the best... Hope that answers your question...

  • lkshcvlisjdflbdfpsb Level 1 (0 points)

    Let me bump this thread.


    My MBP recently failed to secondary click with two fingers on one hand BUT if I use one finger from the right hand and one finger from the left hand, it works fine.


    Secondary click (click or tap with two fingers) is enabled.


    What say you?

  • Lucubrato Level 1 (0 points)

    Very helpful splizaat.


    I was having this problem on my iMac, and I got to the point I figured it was some sort of conflict.


    Running Lion, it was under System Preferences — Mission Control. The secondary drop-down bar for Mission Control activation was set to "Secondary Mouse Button", which was why I couldn't get the right-click on my mouse or trackpad to work.


    Thanks for the tip.

  • AKHILJN Level 1 (0 points)

    I faced the same issue with latest(2012) mac book pro 13" (released in June) and could fix the issue using below solution


    System Preferences — Mission Control. The secondary drop-down bar for Mission Control activation was set to "Secondary Mouse Button", which was why I couldn't get the right-click on my mouse or trackpad to work.

  • runninonmt Level 1 (0 points)

    Had the same issue and it was driving me crazy.  Enabling/Disabling Secondary Tap under the Two Fingers section in trackpad preferences had no effect.  First clue was in this thread earlier when I saw somone saying tapping wasn't working but actually pressing down hard gave the desired result.  Voila, same w/ me.  So, I went back to preferences and I noticed that, somehow, under the One Finger section the Tap to Click box was unchecked.  No clue how that happened as I use this hundreds of times daily, at least, and immediatly noticed when it broke/changed.   Checked that box and all is well.

  • downeyt Level 1 (0 points)

    Right-click stopped working. Called Apple Care. After several procedures, this one worked:


    Shut down trackpad

    Shut-down computer

    Unplug comuputer for 30 seconds.

    Start computer

    Log in

    Start trackpad

    Open trackpad preferences

    Uncheck secondary click

    Check secondary click


    Explanation: blue tooth munged

  • Datura-takara Level 1 (10 points)

    After reading all the above, especially the bluetooth munged bit from Apple care via @downeyt

    I turned off bluetooth for a few seconds (turned it back on with digitizing pad as even the keyboard is bluetooth!)

    That did the trick!!

  • shawnfromvero beach Level 1 (0 points)

    This still has not helped me, my secondary button is checked the tap to click is checked, theres no drop down menu for me, idk if that is because this thread is old and im up to the newest version of mac, but my secondary click dosent work, i know that i can use the old way by holding control, but i want it the way it was lol. i have a 2008 (old mac) macbook pro 17 inch, any advice anyone can give me would be of great help!

  • Unami Level 1 (0 points)

    i did a clean install of ml on my mbp 2009 and after this, i couldn't get the two-finger-rightclick to work. turned out, like runninonmt, i had 1-finger-tap disabled (looks like i depress the touchpad for left-click and make a twofinger-tap for right :-) . because of this the 2-finger-rightclick-tap didn't work, no matter if the box was checked or not. i activated the 1-finger-tap. bingo.

  • downeyt Level 1 (0 points)

    Thanks @datura-takara, that was a lot easier than the apple care procedure. I turned off bluetooth and turned it on again. Now the right-click is working again.

  • Tiktoc Level 1 (0 points)

    So, no two-finger tap for secondary clip in Finder when I try in a list.  Snow Leopard 10.6.8, Late '08 Macbook (not pro).  But when I try the two finger tap in my Browser, it's just fine.  When I two finger tap in the Finder pane that gives the info for the highlighted file (in Column view), it works just fine.  If I control-click on the highlited filename, no result.  But if I go up and click in Actions, the functions are there and work properly.  Software Update shows that I'm current (maybe this is the problem?). 


    Screen shot 2013-05-05 at 10.54.29 PM.png

    So, for example, if I try to two finger tap for secondary click on the highlighted "Chord Paper.pdf", nothing happens.  It's the same when I use a control-(single) click - nothing happens.  But if I two finger tap to secondary click under the "More info..." button, I get full functionality.  Here in my browser window, it works just fine.  I am running really low on hard drive space while this is happening, 1.7GB left.  But I've been down that low before and nothing like this has happened.

  • pike3902 Level 1 (0 points)

    I'm encountering the same issue as Tiktoc.

    I first tried to reset the Finder preferences: with deleting the .plist files (in ~/Library/Preferences) for both Finder and the finder sidebar, and then force quitting Finder. This fix Finder for a short moment, but the problem reapears quickly.


    The secondary tap is working well with any other application.


    If anyone would have a suggestion, I'll be most obliged.



  • catchy Level 1 (0 points)

    Yep, same as Tik and Pike. I'll continue searching for a solution.

  • bereanboarder Level 1 (0 points)

    Me too. MacBook Pro. 10.6.8, suddendly the 2 finger secondary tap stopped working in the finder. I've tried just restarting the finder, it's painless and quick but it only works until I navigate away from the finder. Once I come back it's gone.