7 Replies Latest reply: Nov 29, 2010 7:34 AM by MacNiels
Udder Level 1 (25 points)
I am currently able to send and receive email since upgrading to 4.2 on my iPhone4, but I've been getting pop-up messages through out the day (and night) saying the following:

Cannot Access myemail@mydomain.com
Review your account information in Settings.

Obviously my settings are correct since I am able to send and receive mail for this account. But still, these annoying pop-ups greet me when I unlock my phone.

Is this happening to anyone else here?
Has anyone found a way to stop this?

Thank you.

PowerBook G4 Ti 867, 24 inch iMac 2.33, Mac OS X (10.6.5)
  • Asher_Langton Level 1 (10 points)
    This is happening to me, too. In my case, the email address on the popup is my Apple ID, but I don't access that email account on my phone. This started happening when I added the free MobileMe Locate My iPhone capability. The MobileMe account actually appears to work correctly, but it occasionally generates these popups.
  • Udder Level 1 (25 points)
    Now that I think about it, I first noticed this after setting up Find My Phone on MobileMe and the my Apple ID is the same as the mail account on my phone.

  • KrisHeinold Level 1 (20 points)
    Mine is doing the same. I have several accounts in mail and only one account is messing up. The account is not the same as my mobile me. This is VERY annoying since I email a lot from this account on my phone. Any idea's for fix?
  • Zehwuh Level 1 (0 points)
    Having the same problem when using the Find My iPhone feature while cellular data is off. WiFi is however on.
    Don't know if this would change if I enabled cellular data again, but since I'm in a different country than my phone provider, it would cost a lot to have data on. I will give it a try in a week though.

    Either way it would be good not to have to click "OK" 10 times after a nights sleep.
  • MacNiels Level 1 (0 points)
    Same problem here. iPhone is capable of receiving mail, but not able to send e-mail by SMTP with password check from the same accounts. It reports a missing password, but the password is filled in and synced from my Mac. The same password works fine for receiving e-mail.
  • krokadil Level 1 (0 points)
    I was getting the same "Cannot Access myemail@mydomain.com" constantly even though I was clearly receiving new emails. I tried everything that worked for anyone else - deleting and entering my email account again, turning the phone on and off, changing the email password, and even doing a complete restore on the phone - but no luck.

    Here's what I was missing: I kept dismissing the popup message because I assumed it was actually about my email account. When I finally clicked on Settings it took me not to my email setup but the MobileMe setup. As I don't have a MobileMe account I signed in with my Apple ID, the username of which was my email address! I can only assume that when MobileMe was doing its periodic ping or check on my phone for the Find My iPhone service it was trying to pull my password from my email account (which was fine) and then trying to use the SAME one for the MobileMe login (which was different). I changed my Apple ID password to the same as my email password, deleted the MobileMe account on my iPhone, added it back, and now everything is fine! I haven't had the popup message for two days!

    That's what worked for me, so take it with a grain of salt, but if your MobileMe user name is the same as one of your email addresses then changing the passwords to be the same should take care of this problem. Let me know if that works -

    Good luck!
  • MacNiels Level 1 (0 points)
    I discovered that, while the Mail-application on a Mac automatically uses the username and password filled in with the POP-server information also for a SMTP identity check, you have to type in this again manually in your iPhone mail settings in a separate field. This data is not synced from the Mac Mail application to this field with your iPhone if your provider requires an identity check on its SMTP server (like Dutch internet provider XS4ALL).

    Settings-app -> Mail, Contacts, Calendar -> Accounts (pick one) -> Server outgoing mail -> Add SMTP server as main server or change existing one -> tap and fill in your username and password manually, and be sure this server is on (1)

    Works like a charm. Wondering what happens if I sync my iPhone, perhaps I have to do it again