14 Replies Latest reply: Aug 12, 2012 3:13 PM by DNA1977
DNA1977 Level 1 Level 1 (0 points)
For the last couple of days, my default search engine (www.google.com) was not searching, and giving me following error:

Safari can’t open the page “http://www.google.com/” because Safari can’t connect to the server “www.google.com”.

I went through pages in support about problems with third-party plugins. I've tried un-checking "Enable plug-ins"; Resetting Safari; Emptying Cache; Re-starting Safari and computer, nothing has worked. Other search engines are working e.g. bing, yahoo. I can't open any of google websites from .com or .co.uk or gmail. I've just tried using Firefox and it also can't open google websites.

I'm using Safari 5.0.3 (5533.19.4) on a Mac OS X 10.5.8.

I had Glims installed on my machine, which I just un-installed it; re-started; re-set safari, but still can't open google website.

As far other websites are concern, so far all the websites which are in frequent use can open. Is there problem with Google, Safari/Firefox (browser) or my mac (virus or something)?

Thanks a lot everyone.

PS: Oh yes. I got update on Safari yesterday, is that causing any issues?

MacBook 2.4 GHz IC2D, Mac OS X (10.5.8)
  • Allan Jones Level 7 Level 7 (31,785 points)
    You are not seeing an apparition. If I enter "google.com" in the address bar, I get a similar result to yours in Safari 4.1.3 on my trusty old G4 tower running 10.4.11, but not with Safari 5.0.3 on my MBP 2.2G running 10.6.5. It also works in Camino and FireFox on the G4.

    On the G4, entering a search item in Safari's Google window gets me to the proper results page.
  • Carolyn Samit Level 10 Level 10 (95,580 points)
    HI,

    From your Safari menu bar click Safari / Preferences then select the Security tab. Click: Show Cookies.
    Delete all Google related cookies.

    Quit Safari (Command + Q) Relaunch Safari.

    See if that helps. If not, open a Finder window. Select your Home folder in the Sidebar on the left. Now open the Library folder, then the Cookies folder. Move the Cookies.plist file from the Cookies folder to the Trash. Relaunch Safari.











    Carolyn
  • baltwo Level 9 Level 9 (61,785 points)
    Drop the quotation marks. That's what's causing the error the URL is http://www.google.com/
  • DNA1977 Level 1 Level 1 (0 points)
    Hi Carolyn,

    I tried both ways but of no avail. Still can't open www.google.com or any related website with google on it. Can't search or anything...

    Wait, I CAN open maps.google.co.uk as well as maps.google.com and video.google.com, but nothing else from Safari or Firefox. Other than google, bing and yahoo and other search engines are working fine in both browsers. I'm getting the same error message that Safari can't connect to the website.

    Thanks for the help though.
  • DNA1977 Level 1 Level 1 (0 points)
    Thanks for your reply.

    That was an error message. Of course, me not adding quotes.
  • baltwo Level 9 Level 9 (61,785 points)
  • DNA1977 Level 1 Level 1 (0 points)
    I've just downloaded Chrome and tried to use Google website (www.google.com and www.googl.co.uk). It worked at the beginning then later on stopped - Same error saying website could not be connected. Later, I cleared ALL history from Firefox. Suddenly, I could access these website on Chrome ONLY. Again after a while, I could NOT. Tried again clearing the history from Safari, Firefox and Chrome, and then restarting computer but of no avail.

    Is my machine infected with virus or something?
  • DNA1977 Level 1 Level 1 (0 points)
    OK... I found a solution for myself.

    I'd installed NetBarrier X5 and I was getting warnings for a long time that my computer got "scanned" by some IP addresses so I kept blocking them PERMANENTLY. But I was still able to use Google websites until a few days ago.

    Yesterday, I was trying to access an online game website and I was told that I couldn't, so either I had to "enable" cookies or "allow" the IP address on my firewall. I went into Netbarrier X5 and it had a huge list of IP addresses blocked. I didn't know how to confirm which one was which so out of frustration I deleted all the list.

    I logged into online game, so I tried Google websites... wooolllaaaah... it worked and is still working great!!!!!!!! So I presume it was my Netbarrier X5 causing some kinda problem.

    Hope this works for others as well.
  • Brhoome Level 1 Level 1 (0 points)
    Kakar, THANK YOU!

    I have been struggling with this for a while now, i go to bing.com as an alternative, and from time to time i look for solutions but never found.

    Today, you solved my problem. It was Netbarrier X5, i really hated that app now; i cleared the list of IPs that were blocked for trying to retrieve my phone number :/


    Anyhow, thanks a bunch again!
  • osecours Level 1 Level 1 (0 points)

    I had the same problem too.

    I searched by using bing.com (fortunately MS search engin has helped me )

     

    I found a archived post https://discussions.apple.com/message/11061084#11061084

    I did what Carolyn said and I also checked the PeerGuardian app

    but I don't think it's because of this app that my connection wasn't possible, because I rarely use it.

     

    Et voilà, everything works now.

     

    I'd like to thank Carolyn and Rave for allowing me to do not format my dear iBook G4 that I haven't formated for over 3 years!!! (I've done the whole backup of my iBook) 

  • DNA1977 Level 1 Level 1 (0 points)

    Thank you osecours.

     

    I did go through that page and tried it, but unfortunately it didn't work out for me. I was systematically following the steps to rectify it but of no avail. I was messing around to sort out the problem until I deleted the "block list of IP address" in the NetBarrier X5. It solved my problem, at least.

     

    I will advice people to go through steps mentioned on that page (and search for other remedies) till they have to delete the block list. Going systematically will tell the right cause of the problem

  • saadfromdubai Level 1 Level 1 (0 points)

    its not working for either. the error says

     

    Invalid URL

    The requested URL "/", is invalid.

    Reference #9.3dd9dd58.1310981689.48c70276

  • ayhanap Level 1 Level 1 (0 points)

    Deleting cookies solved my problem.

  • DNA1977 Level 1 Level 1 (0 points)

    Is there some sort of firewall running on your machine?

     

    You could also check your security, and if there are any "allow" list then you might want to ADD the web address. Or if it has "block" list then you could remove the web site from it if not removing the whole list.