Previous 1 2 Next 21 Replies Latest reply: Jul 12, 2012 2:02 AM by ConnBags Go to original post
  • tnkrgnr Level 1 Level 1 (0 points)

    I was having the same problem for a while, tried a few things and nothing. I just got my iphone4 to sync on itunes doing the following:  ( I should mention Im running windows vista)

     

    1   Go to my computer

    2   Click on Disc C

    3   Click Program Data (hidden file)

    4   Click Apple

    5   Click Lockdown

    6   Delete System Configuration

     

    After that I turned my phone off and back on and connected to itunes and I tunes recognized it. No more error message.   Hope it works for you too

  • patamons Level 1 Level 1 (0 points)

    I forgot to write here that my problem was solved : it was a filesystem error on my iMac.   More info in this post : https://discussions.apple.com/message/13383515#13383515

  • geesche Level 1 Level 1 (0 points)

    Seriously? Because one thing didn't work?

  • Csweetsmile8 Level 1 Level 1 (0 points)

    I tried what this guy showed on Youtube and it work. Hope it works for you.

    http://www.youtube.com/watch?v=nckFHq3jEqU

  • QuadraForever Level 1 Level 1 (0 points)

    On Windows 7 (32 bit in this instance) I struck errror 0xe8000003 when attaching an iPhone 4 and attempting to access it in iTunes.

     

    Initially I tried ending the processes for

    • iTunesHelper.exe
    • iPodService.exe
    • AppleMobileDeviceService.exe

     

    followed by restarting iTunes but without any luck.

     

    Next, I looked at deleting the C:\ProgramData\Apple\Lockdown directory altogether. I noticed that after removal, it sprang back to life. This was because one (or more) of those processes above was running I assume.

     

    Looking at that folder I noticed I couldn't change it's permissions in order to permanently delete it while those processes were running and that the owner of the object owner was undefined. Furthermore, I was not able to takeown via an administrative command prompt.

     

     

    What I did, which has fixed the error for me (after a full chkdsk just in case the security issue was due to disk corruption - HDD was fine, btw) was to:

     

    • kill those processes listed above
    • delete C:\ProgramData\Apple\Lockdown again
    • create C:\ProgramData\Apple\Lockdown manually
    • explicitly set the permissions for the current logged in user for that object to Full Control
    • restart iTunes

     

    Everything was then working again

  • nikhil25292 Level 1 Level 1 (0 points)

    Hey!! Im getting the same error. Im new to Apple. Can you please tell me where to find the /Var/db/lockdown??

  • ConnBags Level 1 Level 1 (0 points)

    all i had to do was close itunes because it was open while i was connecting my iphone. make sure it isnt running while you plug in your iPhone

Previous 1 2 Next