Previous 1 2 3 Next 32 Replies Latest reply: Jun 9, 2014 1:53 PM by samantha101904
nickjhowe Level 1 (0 points)
iTunes (10.1) won't back up my 3GS (4.1). If I sync the phone at no point is a backup created, and if I right click on the phone in iTunes there is no 'backup' option.

Any ideas?

iPhone 3GS/MacBook Pro, iOS 4, Snow Leopard 10.6.5
  • ChrisJ4203 Level 8 (47,816 points)
    That sounds like a problem in iTunes. I would try and restart the computer, if that doesn't help, I would reinstall iTunes. I have 10.1, but on a PC, it does a backup of the phone first thing before a sync, and I also have the option to do a backup from the right click on the device.
  • nickjhowe Level 1 (0 points)
    Thx. They were the first things I tried - no help.

    I'm going to connect the 3GS to another Mac and see what happens. I suspect something has got corrupted, but no idea what.

    Anyone else got any suggestions?
  • ChrisJ4203 Level 8 (47,816 points)
    Sorry I couldn't help any more. Since it seems to be an iTunes problem, I'm guessing it is at the computer side. I find it strange that a reintallation of iTunes didn't help.
  • Charles.P Level 1 (0 points)
    i have the same pb...
    any solution ?
  • iRex Level 1 (0 points)
    reinstall OS
  • Sazman Level 1 (25 points)
    My first question is. Did you enable right click on your mac?
  • gdiogenes(BR) Level 1 (0 points)

    Same issue here. iTunes 10.2.2, iPhone 3G with IOS 4.2.1. It does not perform backup. I've reinstalled iTunes, deleted all the old backups (last one was from 2 months ago) and still nothing. There is no option to force the backup as it used to have in previous versions off itunes.

  • stenro Level 1 (0 points)

    I'm using all latest Snow Leopard, iTunes.  I've had the problem for a while- missing Backup option (it works under my wife's iTuens on her profile, though.)

    I found this on another board and it fixed my problem perfectly!

     

    o Close iTunes.

    o Open Terminal and type the following commands in:

     

    defaults write com.apple.iTunes DeviceBackupsDisabled -bool false

     

    defaults write com.apple.iTunes AutomaticDeviceBackupsDisabled -bool false

     

    Relaunch iTunes and now Backup option is there.

  • Sideways Eights Level 1 (0 points)

    Hello, I believe I have found the problem.  It appears to be a bad preference file for itunes.  I have never posted i a forum until now and am not sure if this is the right way to post, so bare with me.  I have been all over google struggling to find a fix so I hope this works for all and is passed on to others.

     

    I have had the same problem for a little while and finally came across the problem, at least in my case.

    There is an itunes preferences file that was corrupted, but once I found and removed the bad file I was

    immidiately able to right click and create a backup.  I found the file on my Sony Vaio with windows 7 in

    the following spot:

     

    C:users/user/appdata/roaming/applecomputer/itunes

     

    All I did is delete the file and itunes automaticly brought up the tutorial once it was open and synced, then

    I right clicked on my device and saw the option for back up, selected it, and in no time it was complete.

     

    Good luck

  • Mohd.Khairil Level 1 (0 points)

    Thanks for the solution... It worked!

  • Aaron* Level 1 (0 points)

    Excellent!

     

    Worked for me as well. Just need to make sure iTunes has been shut donwn completely before deleting the preferences file.

     

    Thanks!

  • Raydk Level 1 (0 points)

    Thanks for this solution!  It helped me with this problem that just suddenly occured after i restored my iPhone.

    God i hate this peace of crap iTunes software!!

  • cmorgan Level 1 (0 points)

    Thanks, Sideways! I always wondered why I had to redo my screen layout each iOS update.

  • lemur90 Level 1 (0 points)

    Stenro's method worked for my 3gs and itunes 10.5.  Thanks!

Previous 1 2 3 Next