9 Replies Latest reply: Mar 18, 2012 11:44 AM by crigo22
araym Level 1 (5 points)
Keyboard Clicks worked right up to the point that I installed 4.2.1. Now they don't work at all. Or almost at all. They will work on the initial password screen. They also work on the Settings->General->Sounds page. But no where else.

I've turned all of the sounds (including Keyboard Clicks) off and on again several times. I've cranked the volume up all the way. I've also played with the new Mute switch just in case that was giving me the problems. Nothing seems to work.

Has anyone else experienced this problem?

13" 2.4GHz Aluminum Macbook, Mac OS X (10.6.5), iPod touch 2G 16GB, iPad 3G 16GB
  • Barbara Brundage Level 7 (22,065 points)
    Have you tried power cycling, the ipad, turning it completely off and then on again? And have you checked that the mute button isn't on? That's the button that used to be the rotation lock switch, but is now used to mute system sounds, like mail notifications and (possibly) key clicks.

    EDIT Oops, I see you did try the mute switch. Sorry, missed that before.
  • oldspook619 Level 1 (5 points)
    My key-clicks seem to be a lot lower that before. With the volume all the way up I can barely hear them.
  • araym Level 1 (5 points)
    Yes, I tried all of those things: power cycle, did a full reboot as well, mute button/slider, turning the Sound switches off then back on, turning the volume up all the way. To date nothing has helped. And it isn't just that the sound is low - it just isn't there at all.

    As I said it works in two places: the initial screen lock and the Sounds page, but nowhere else. And it stopped working exactly when I did the 4.2.1 upgrade so there is no question that is the cause somehow.
  • Niche Level 1 (0 points)
    Just a thought- have you got the new Airplay feature turned on in iTunes or the video app? - I think that kills the keyboard tap sound - in fact I know it does because I'm typing this right now whilst listening to tune via airplay - and the keyboard is silent...
  • araym Level 1 (5 points)
    Just a thought- have you got the new Airplay feature turned on in iTunes or the video app?

    Now this is an interesting question. However I checked it out and I don't think so. First because I don't own an Apple TV or compatible speakers. Indeed I've never even used Airplay and had to consult the web to find out how it works.

    So I checked. I brought up a video and then a song, and did not see the Airplay up arrow icon on the control window as shown in the Apple demo videos. So I'm pretty sure it is not currently enabled on my iPad. I also went into iTunes, and the only reference I could see to Airplay was under iTunes->Preferences->Devices. There were options to look for remote speakers and for remote devices. Those options were selected so I turned them off. I didn't see any other Airplay features in iTunes, that I could find. So I'm guessing this isn't the problem for me.

    I did find one other place where Keyboard Clicks works. In addition to the initial screen-lock password page, and also the Settings->General->Sounds page, I also discovered that Clicks works on the search page that you get when you swipe to the right on the home page. But, other than those three pages, Clicks doesn't work anywhere else.

    I'm still thinking that it is a 4.2.1 bug, since it appeared exactly when I did the upgrade, but it is odd that no one else has (yet) reported this same problem. It's still possible that there is a weird configuration issue (like Airplay - thanks for the suggestion) but if so I haven't found it yet.
  • Tyrellcorp76 Level 1 (0 points)

    Just read your point about keyboard clicks and my problem is now sorted.



  • ClarkPad Level 1 (0 points)

    I tried all the same suspects. Just loaded ios 5. The trick for my same problem was simply to change the setting for the "use side switch to:".   -  from "lock rotation" to " "mute". And back. I also tried the proverbial putting a headset phone jack in and out several times as previous posts have suggested. Not sure which action got my keyboard clicks back, but they are indeed ok now.

    Just wanted to post this if it happened to some else after plating to its 5.



  • arnieg Level 1 (0 points)

    Just tried all af the above on my IPad 2 and the keyboard is still silent. HELP!!

  • crigo22 Level 1 (0 points)

    Had same issue that came suddenly on version 4.3.x

    To solve it, Go to Settings > General > Reset > then tap "Reset all Settings"


    All your preferences and settings are reset. Information, such as your contacts and calendars, and media, such as your songs and videos, aren’t deleted.