3 Replies Latest reply: Nov 28, 2010 7:47 AM by johanamsterdam
Aussieinhk Level 1 Level 1
Once again Apple has screwed something up. Upgraded to 4.2.1 on Friday and now my 3G reception does not work. I've factory restored and still no good. Whats up with the quality control these days? Seems as if every software update across iOS and Mac OS/X has at least 1 major flaw.

Does Apple read these posts?

iPhone 3G, iOS 4, Sick of Apple screwups
  • Aussieinhk Level 1 Level 1
    Right. Sorted the issue. Reset Network settings, re-entered them as per my carriers web page advice. Restarted my iPhone, sent an SMS to the Carrier to activate 3G and I'm back in business.

    Why the bloody **** did iOS 4.2.1 screw that up?
  • johanamsterdam Level 1 Level 1
    my problem is more curious i use 4.2.1. on a 3g iphone which is "open" from italy
    my network is kpn/simyo
    4.2 everything worked... no tethering offered
    4.2.1. most apps including safari weather etc are not able to use the data network,but the NS dutch railways app is able to use the data connection
    and suddenly i get offered tethering in the network settings
    But the screen for manually set your network settings is disappaered, so as my provider cant send setup files to my phone makes it impossible to manually setup a phone network, which is strange for an "open" never been locked iphone

    Will see what happens the next day as there are more buggs reported about network and 4.2.1.
    WIFI works perfectly....
    Was planning to buy an iphone 4 but if apple cant guarantee the use of what you buy..... by issuing software with flaws..... If they would just offer a downgrade option for software..
  • johanamsterdam Level 1 Level 1
    a friend helped me to this solution
    http://www.iphone-notes.de/mobileconfig/
    since then connections are working again...