Previous 1 2 Next 18 Replies Latest reply: Jul 21, 2011 12:48 AM by sirima
Matthew Mrizek Level 1 Level 1 (0 points)
I bought iLife 11' the day it came out and everything on it works great, except iPhoto. It was really cool when I first got it. It worked pretty well the first time I opened it. But then after that, It would not open up all the way again. It will get to the grayish screen and then the little spinning color wheel (or Beach ball as I like to call it) will come up and stay there for about a minute until the crash report comes up. I also noticed that each time I tried to start up iPhoto, it would take it longer and longer to finally crash. I don't know if that helps or not. I have already deleted my plist, iPhoto receipts in HD/Library and reinstalled iLife '11. I even ran the highly-suspect Repair Disk Permissions and zapped the PRAM, just for luck. iPhoto still won't start up, and I don't know what to do now.
Can someone please help?
Here is the crash log if it can help:

Process: iPhoto [326]
Path: /Applications/iPhoto.app/Contents/MacOS/iPhoto
Identifier: com.apple.iPhoto
Version: 9.1 (9.1)
Build Info: iPhotoProject-4750000~1
Code Type: X86 (Native)
Parent Process: launchd [123]

Date/Time: 2010-11-23 23:56:07.975 -0500
OS Version: Mac OS X 10.6.5 (10H574)
Report Version: 6

Interval Since Last Report: 80499 sec
Crashes Since Last Report: 5
Per-App Interval Since Last Report: 252 sec
Per-App Crashes Since Last Report: 4
Anonymous UUID: 3E1164DE-B516-4203-94EA-90F8082CD753

Exception Type: EXCBADACCESS (SIGBUS)
Exception Codes: 0x000000000000000a, 0x000000001e336000
Crashed Thread: 31
I have more if you need it.

17" MacBook Pro, Mac OS X (10.6.5)
  • Old Toad Level 10 Level 10 (127,560 points)
    Welcome to the Apple Discussions. Backup the library and try the two fixes below in order as needed:



    Fix #1


    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your User/Library/Preferences folder.

    2 - delete iPhoto's cache files that are located in the User/Library/Application Support/Caches/com.apple.iPhoto folder.

    3 - reboot, launch iPhoto and try again.




    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding the the Option key. You'll also have to reset the iPhoto's various preferences.


    Fix #2

    Launch iPhoto with the Command+Option keys depressed and follow the instructions to rebuild the library. Select options #1, #2 and #6.



    Click to view full size



    OT
  • Matthew Mrizek Level 1 Level 1 (0 points)
    So now I can use iPhoto to an extent. I used Fix #2 I immediately have to go to faces and press pause otherwise it will crash on me in seconds. I can edit pictures and things okay now. The problem now arrises when I try to put pictures on my iPod Touch using iTunes. I make the album in iPhoto and it shows up when I go to sync pictures. Now once the pictures are on my iPod Touch, some of them differ from the pictures I originally put in the album. How do I make it put the right pictures on my iPod?
  • Old Toad Level 10 Level 10 (127,560 points)
    There is still something damaged in the library. Try rebuilding the library using iPhoto Library Manager as follows:




    Using iPhoto Library Manager to Rebuild Your iPhoto Library


    1 -Download iPhoto Library Manager and launch.

    2 -Click on the Add Library button, navigate to your User/Pictures folder and select your iPhoto Library folder.

    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File->Rebuild Library menu option

    4 - In the next window name the new library and select the location you want it to be placed.

    5 - Click on the Create button.

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be untouched for further attempts at fixing or in case the rebuilt library is not satisfactory.
  • Matthew Mrizek Level 1 Level 1 (0 points)
    Thank you sooooo much Old Toad! All my problems have gone away, except for one new one that I want to ask you about. I had 16 gigabytes available on my hard drive before the repairing of my library and now I have 4 gigabytes. I saw it made pretty much a duplicate of my old library. What should I do to get that space back? I don't want to delete the wrong thing and this whole series of unfortunate events start over. I have backed up my computer before and after I repaired my Library.
  • Old Toad Level 10 Level 10 (127,560 points)
    You now have two copies of your library. You'll need to decide which to keep and use and which to get rid of.

    It's important that you keep a minimum of 10GB of free space on your HD to get the optimum performance from your system and applications.

    One way to recover some space is to to run Monolingual to remove the unneeded language modules. Just be sure to keep English and your primary language. I kept English and English American. I recovered about 1 GB of space on my MBP.

    If might consider getting an external HD to store lesser used files. You could move your full library to the external HD and run a smaller library on the MBP. iPhoto Library Manager can be used to move albums or events between the two libraries as needed.'

    If you already have an external HD then use it. But you do want to clear up at least 10 GB of space.
  • Matthew Mrizek Level 1 Level 1 (0 points)
    So should I copy my old library onto an external hard drive and then delete it off of my Mac Book Pro's Hard Drive?
  • Old Toad Level 10 Level 10 (127,560 points)
    Yes, but don't delete it until you've opened the one on the external HD and confirmed it's working correctly. Once you do that delete the one off the internal HD.l
  • Matthew Mrizek Level 1 Level 1 (0 points)
    But I thought that the old library didn't work. I thought that was the root of my problem. When you say open it to see if it works, what SHOULD it do? Before it would always crash and it had all of my events in weird orders. i.e. all of the dates were all mixed up.
  • Old Toad Level 10 Level 10 (127,560 points)
    If you backed up your library and then ran the two fixes on one of them did the library that you tried the fixes on work OK? If so then copy it to the external HD and try it there before deleting the two libraries off your boot drive.
  • Matthew Mrizek Level 1 Level 1 (0 points)
    Are you saying I should move both of them to the External HD and run iPhoto on what is on the External HD? Is the second Library (the new one that was made after iphoto manager ran) Independent of the original Library? For example, if I deleted the Original library off my Internal HD, the Second/new library would run perfect. Correct?
    Sorry if I'm just running you around in circles.
  • Old Toad Level 10 Level 10 (127,560 points)
    Yes. The new library created by iPLM is independent of the original library. Run it on the EHD to make sure it's working correctly and all photos are present. Then you can delete the other unneeded libraries.
  • Addict Level 1 Level 1 (0 points)
    Thank you so much Old Toad. Fix #1 actually did it for me. My iPhoto '11 was crashing everytime I closed it and it was not seeing my iphone for importing photos. It was also crashing when trying to rebuild the database. I'm actually amazine Fix #1 worked, but I'm very happy it did.
  • Matthew Mrizek Level 1 Level 1 (0 points)
    I was trying to move my old Library to my External Hard Drive and this popped up when I got to 10 gigabytes out of 11, "The Finder can’t complete the operation because some data in “iPhoto Library” can’t be read or written.
    (Error code -36)"
    What does this mean?
  • Old Toad Level 10 Level 10 (127,560 points)
    It's an I/O error - input/output error.

    How is your external HD formatted? If it isn't formatted for *OS X Extended (journaled)* this video explains one reason you may be getting that error message: http://www.youtube.com/watch?v=FlSJuxEbXe8

    One possible workaround would be to create a new folder on the external HD and name it iPhoto Library or whatever you want the library to be. Then open your iPhoto library on the boot drive using the finder:



    Click to view full size


    select about 1/3 of the items in the open package and drag them to the folder on the external HD. That might get around the problem. When they finish copying select another 1/3 and do the same. This might get around the size limitation issue that could be limiting the copy.
Previous 1 2 Next